summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-12-12 14:52:04 +0000
committerRichard Purdie <richard@openedhand.com>2005-12-12 14:52:04 +0000
commit8fd58431099933596268fb47245e673cf55ce3c6 (patch)
treef4405b22fa75ec422d7012cb5cc80e057c5ba5ce /openembedded
parent3c470b4e199b91c16da139eef47df253627f00e3 (diff)
downloadpoky-8fd58431099933596268fb47245e673cf55ce3c6.tar.gz
oe/packages Updates from Openembedded
git-svn-id: https://svn.o-hand.com/repos/poky@189 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch73
-rw-r--r--openembedded/packages/console-tools/console-tools_0.3.2.bb5
-rw-r--r--openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch26
-rw-r--r--openembedded/packages/gmp/gmp_4.1.4.bb8
4 files changed, 107 insertions, 5 deletions
diff --git a/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch b/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch
new file mode 100644
index 0000000000..47d7ea54b9
--- /dev/null
+++ b/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch
@@ -0,0 +1,73 @@
1Patch from Matthias Goebl <oe@m.goebl.net>
2Added via OE bugtracker: bug #478
3
4--- console-tools-0.3.2/kbdtools/kbd_mode.c.orig
5+++ console-tools-0.3.2/kbdtools/kbd_mode.c
6@@ -29,11 +29,16 @@
7 OPT("-u --unicode ", _("UTF-8 mode (UNICODE)"));
8 OPT("-s --scancode ", _("scancode mode (RAW)"));
9 OPT(" --mode={8bit,keycode,unicode,scancode} ", _("set mode"));
10+ OPT("-r --rate=RATE ", _("set repeat rate (default: 33)"));
11+ OPT("-d --delay=DELAY ", _("set repeat delay (default: 250)"));
12
13 OPT("-h --help ", HELPDESC);
14 OPT("-V --version ", VERSIONDESC);
15 }
16
17+int rate=-1;
18+int delay=-1;
19+
20 static int parse_cmdline (int argc, char *argv[])
21 {
22 int mode = -1;
23@@ -46,11 +51,13 @@
24 { "mode" , required_argument, NULL, 'm' },
25 { "scancode" , no_argument, NULL, 's' },
26 { "unicode" , no_argument, NULL, 'u' },
27+ { "rate" , required_argument, NULL, 'r' },
28+ { "delay" , required_argument, NULL, 'd' },
29 { NULL, 0, NULL, 0 }
30 };
31 int c;
32
33- while ( (c = getopt_long (argc, argv, "Vhaksu", long_opts, NULL)) != EOF)
34+ while ( (c = getopt_long (argc, argv, "Vhaksur:d:", long_opts, NULL)) != EOF)
35 switch (c) {
36 case 'h':
37 usage ();
38@@ -58,6 +65,14 @@
39 case 'V':
40 version ();
41 exit(0);
42+ case 'r':
43+ rate = atoi(optarg);
44+ mode = -2;
45+ break;
46+ case 'd':
47+ delay = atoi(optarg);
48+ mode = -2;
49+ break;
50 case 'a':
51 mode = K_XLATE;
52 break;
53@@ -129,6 +144,20 @@
54 exit(0);
55 }
56
57+ if ( rate != -1 || delay != -1 )
58+ {
59+ struct kbd_repeat kbd_rep;
60+ kbd_rep.delay = delay;
61+ kbd_rep.period = rate;
62+ if (ioctl(fd, KDKBDREP, &kbd_rep))
63+ {
64+ fprintf(stderr, progname);
65+ perror(_(": error setting keyboard repeat mode\n"));
66+ exit(1);
67+ }
68+ if(mode==-2) exit(0);
69+ }
70+
71 if (ioctl(fd, KDSKBMODE, mode))
72 {
73 fprintf(stderr, progname);
diff --git a/openembedded/packages/console-tools/console-tools_0.3.2.bb b/openembedded/packages/console-tools/console-tools_0.3.2.bb
index 2a94a4f896..f7455825e0 100644
--- a/openembedded/packages/console-tools/console-tools_0.3.2.bb
+++ b/openembedded/packages/console-tools/console-tools_0.3.2.bb
@@ -1,12 +1,13 @@
1SECTION = "base" 1SECTION = "base"
2LICENSE = "GPL" 2LICENSE = "GPL"
3DESCRIPTION = "Allows you to set-up and manipulate the Linux console." 3DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
4PR = "r1" 4PR = "r2"
5 5
6SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \ 6SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
7 file://codepage.patch;patch=1 \ 7 file://codepage.patch;patch=1 \
8 file://configure.patch;patch=1 \ 8 file://configure.patch;patch=1 \
9 file://compile.patch;patch=1 \ 9 file://compile.patch;patch=1 \
10 file://kbdrate.patch;patch=1 \
10 file://config/*.m4" 11 file://config/*.m4"
11 12
12export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \ 13export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
@@ -43,4 +44,4 @@ pkg_prerm_${PN} () {
43 update-alternatives --remove deallocvt deallocvt.${PN} 44 update-alternatives --remove deallocvt deallocvt.${PN}
44 update-alternatives --remove openvt openvt.${PN} 45 update-alternatives --remove openvt openvt.${PN}
45} 46}
46 47
diff --git a/openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch b/openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch
new file mode 100644
index 0000000000..1a01f61533
--- /dev/null
+++ b/openembedded/packages/gmp/gmp-4.1.4/sh4-asmfix.patch
@@ -0,0 +1,26 @@
1--- gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:44:00 1.1
2+++ gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:18:57
3@@ -29,8 +29,8 @@
4
5 .text
6 .align 2
7- .global ___gmpn_add_n
8-___gmpn_add_n:
9+ .global __gmpn_add_n
10+__gmpn_add_n:
11 mov #0,r3 ! clear cy save reg
12
13 Loop: mov.l @r5+,r1
14--- gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:44:04 1.1
15+++ gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:18:59
16@@ -29,8 +29,8 @@
17
18 .text
19 .align 2
20- .global ___gmpn_sub_n
21-___gmpn_sub_n:
22+ .global __gmpn_sub_n
23+__gmpn_sub_n:
24 mov #0,r3 ! clear cy save reg
25
26 Loop: mov.l @r5+,r1
diff --git a/openembedded/packages/gmp/gmp_4.1.4.bb b/openembedded/packages/gmp/gmp_4.1.4.bb
index c9348ea43e..d80e728dc4 100644
--- a/openembedded/packages/gmp/gmp_4.1.4.bb
+++ b/openembedded/packages/gmp/gmp_4.1.4.bb
@@ -3,15 +3,17 @@ DESCRIPTION = "GNU multiprecision arithmetic library"
3HOMEPAGE = "http://www.swox.com/gmp/" 3HOMEPAGE = "http://www.swox.com/gmp/"
4LICENSE = "GPL LGPL" 4LICENSE = "GPL LGPL"
5 5
6PR = "r1"
7
6SRC_URI = "ftp://ftp.gnu.org/gnu/gmp/gmp-${PV}.tar.bz2 \ 8SRC_URI = "ftp://ftp.gnu.org/gnu/gmp/gmp-${PV}.tar.bz2 \
7 file://configure.patch;patch=1 \ 9 file://configure.patch;patch=1 \
8 file://amd64.patch;patch=1" 10 file://amd64.patch;patch=1 \
11 file://sh4-asmfix.patch;patch=1"
9 12
10inherit autotools 13inherit autotools
11 14
12acpaths = "" 15acpaths = ""
13 16
14do_stage () { 17do_stage () {
15 oe_libinstall -so libgmp ${STAGING_LIBDIR} 18 autotools_stage_all
16 install -m 0644 ${S}/gmp.h ${STAGING_INCDIR}/gmp.h
17} 19}