diff options
author | Richard Purdie <richard@openedhand.com> | 2005-09-28 17:23:13 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2005-09-28 17:23:13 +0000 |
commit | ec2f15d43241fc17ad3dc2f76204e3b37fef6041 (patch) | |
tree | 82358f583fd9013fc8674d8142d42f263a21eb11 /openembedded | |
parent | ae628e564939adbe4475ffd0eda7ad340118add4 (diff) | |
download | poky-ec2f15d43241fc17ad3dc2f76204e3b37fef6041.tar.gz |
Change to rxvt-unicode
git-svn-id: https://svn.o-hand.com/repos/poky@49 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
7 files changed, 138 insertions, 57 deletions
diff --git a/openembedded/packages/rxvt-unicode/files/makefile.patch b/openembedded/packages/rxvt-unicode/files/makefile.patch new file mode 100644 index 0000000000..86f82eeb4c --- /dev/null +++ b/openembedded/packages/rxvt-unicode/files/makefile.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | --- ../rxvt-unicode-cvs-r0/rxvt-unicode/Makefile.in 2004-08-12 22:32:40 +01:00 | ||
2 | +++ rxvt-unicode/Makefile.in 2004-12-24 03:09:00 +00:00 | ||
3 | @@ -9,7 +9,7 @@ | ||
4 | first_rule: all | ||
5 | dummy: | ||
6 | |||
7 | -subdirs = src doc src/test | ||
8 | +subdirs = src src/test | ||
9 | allsubdirs = W11 $(subdirs) | ||
10 | |||
11 | DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog | ||
12 | @@ -24,7 +24,7 @@ | ||
13 | |||
14 | #------------------------------------------------------------------------- | ||
15 | |||
16 | -all allbin alldoc tags: | ||
17 | +all allbin tags: | ||
18 | @if test x@host_os@ = xcygwin; then (cd W11; ${MAKE} $@) || exit 1; fi | ||
19 | @for I in ${subdirs}; do (cd $$I; ${MAKE} $@) || exit 1; done | ||
20 | |||
diff --git a/openembedded/packages/rxvt-unicode/files/signedchar.patch b/openembedded/packages/rxvt-unicode/files/signedchar.patch new file mode 100644 index 0000000000..6faa175143 --- /dev/null +++ b/openembedded/packages/rxvt-unicode/files/signedchar.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- ../rxvt-unicode-cvs-r0/rxvt-unicode/src/command.C 2004-12-21 06:43:00 +00:00 | ||
2 | +++ rxvt-unicode/src/command.C 2004-12-24 02:31:36 +00:00 | ||
3 | @@ -1862,7 +1862,7 @@ | ||
4 | #endif /* NO_SCROLLBAR_REPORT */ | ||
5 | |||
6 | { | ||
7 | - char upordown = 0; | ||
8 | + signed char upordown = 0; | ||
9 | |||
10 | if (scrollBar.style == R_SB_NEXT) | ||
11 | { | ||
diff --git a/openembedded/packages/rxvt-unicode/files/xwc.patch b/openembedded/packages/rxvt-unicode/files/xwc.patch new file mode 100644 index 0000000000..7cf59656ce --- /dev/null +++ b/openembedded/packages/rxvt-unicode/files/xwc.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- rxvt-unicode-4.8/src/screen.C~xwc.c | ||
7 | +++ rxvt-unicode-4.8/src/screen.C | ||
8 | @@ -3058,7 +3058,7 @@ | ||
9 | else | ||
10 | rxvt_warn ("can't get primary selection, ignoring.\n"); | ||
11 | |||
12 | -#if 0 | ||
13 | +#ifdef HAVE_XWC | ||
14 | XTextProperty ct; | ||
15 | |||
16 | if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0) | ||
17 | @@ -3632,9 +3632,11 @@ | ||
18 | } | ||
19 | else | ||
20 | #endif | ||
21 | +#ifdef HAVE_XWC | ||
22 | if (XwcTextListToTextProperty (display->display, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0) | ||
23 | freect = 1; | ||
24 | else | ||
25 | +#endif | ||
26 | { | ||
27 | /* if we failed to convert then send it raw */ | ||
28 | ct.value = (unsigned char *)cl; | ||
diff --git a/openembedded/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch b/openembedded/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch new file mode 100644 index 0000000000..eb87b84b25 --- /dev/null +++ b/openembedded/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | diff -urNd ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C rxvt-unicode-5.3/src/screen.C | ||
2 | --- ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C 2005-02-22 21:39:10 +00:00 | ||
3 | +++ rxvt-unicode-5.3/src/screen.C 2005-04-05 22:12:45 +01:00 | ||
4 | @@ -3064,7 +3064,7 @@ | ||
5 | else | ||
6 | rxvt_warn ("can't get primary selection, ignoring.\n"); | ||
7 | |||
8 | -#if 0 | ||
9 | +#ifdef HAVE_XWC | ||
10 | XTextProperty ct; | ||
11 | |||
12 | if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0) | ||
13 | @@ -3648,9 +3648,11 @@ | ||
14 | } | ||
15 | else | ||
16 | #endif | ||
17 | +#ifdef HAVE_XWC | ||
18 | if (XwcTextListToTextProperty (disp, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0) | ||
19 | freect = 1; | ||
20 | else | ||
21 | +#endif | ||
22 | { | ||
23 | /* if we failed to convert then send it raw */ | ||
24 | ct.value = (unsigned char *)cl; | ||
diff --git a/openembedded/packages/rxvt-unicode/rxvt-unicode_5.6.bb b/openembedded/packages/rxvt-unicode/rxvt-unicode_5.6.bb new file mode 100644 index 0000000000..92915bf872 --- /dev/null +++ b/openembedded/packages/rxvt-unicode/rxvt-unicode_5.6.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | SECTION = "x11/utils" | ||
2 | DEPENDS = "x11 xt libxft" | ||
3 | DESCRIPTION = "rxvt-unicode is a clone of the well known \ | ||
4 | terminal emulator rxvt, modified to store text in Unicode \ | ||
5 | (either UCS-2 or UCS-4) and to use locale-correct input and \ | ||
6 | output. It also supports mixing multiple fonts at the \ | ||
7 | same time, including Xft fonts." | ||
8 | LICENSE = "GPL" | ||
9 | SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \ | ||
10 | file://xwc.patch;patch=1 \ | ||
11 | file://signedchar.patch;patch=1" | ||
12 | PR = "r2" | ||
13 | |||
14 | inherit autotools update-alternatives | ||
15 | |||
16 | PROVIDES = "virtual/x-terminal-emulator" | ||
17 | ALTERNATIVE_NAME = "x-terminal-emulator" | ||
18 | ALTERNATIVE_PATH = "${bindir}/rxvt" | ||
19 | |||
20 | CFLAGS_append = " -fpermissive" | ||
21 | |||
22 | EXTRA_OECONF = "--enable-menubar --enable-xim \ | ||
23 | --enable-utmp --enable-wtmp --enable-lastlog \ | ||
24 | --disable-strings --with-term=rxvt --enable-keepscrolling \ | ||
25 | --enable-xft --with-name=rxvt --enable-frills \ | ||
26 | --enable-swapscreen --enable-transparency \ | ||
27 | --with-codesets=eu \ | ||
28 | --enable-cursor-blink --enable-pointer-blank \ | ||
29 | --enable-text-blink --enable-rxvt-scroll \ | ||
30 | --enable-combining --enable-shared \ | ||
31 | --enable-xgetdefault \ | ||
32 | --with-x=${STAGING_LIBDIR}/.." | ||
33 | EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \ | ||
34 | 'XLIB=-L${STAGING_LIBDIR} -lX11'" | ||
35 | |||
36 | do_configure () { | ||
37 | mv autoconf/configure.in . || true | ||
38 | rm autoconf/libtool.m4 | ||
39 | libtoolize --force | ||
40 | autotools_do_configure | ||
41 | echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h | ||
42 | echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h | ||
43 | echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h | ||
44 | echo '#define HAVE_XLOCALE 1' >> config.h | ||
45 | } | ||
46 | |||
47 | do_compile () { | ||
48 | if test -e ${S}/${HOST_SYS}-libtool; then | ||
49 | LIBTOOL=${S}/${HOST_SYS}-libtool | ||
50 | else | ||
51 | LIBTOOL=${S}/libtool | ||
52 | fi | ||
53 | # docs need "yodl" and I have no idea what that is | ||
54 | oe_runmake -C src "LIBTOOL=$LIBTOOL" | ||
55 | } | ||
diff --git a/openembedded/packages/rxvt/rxvt-2.7.9/include.patch b/openembedded/packages/rxvt/rxvt-2.7.9/include.patch deleted file mode 100644 index f7542843b1..0000000000 --- a/openembedded/packages/rxvt/rxvt-2.7.9/include.patch +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | diff -urN rxvt.orig/src/rxvtlib.h.in rxvt/src/rxvtlib.h.in | ||
2 | --- rxvt.orig/src/rxvtlib.h.in 2003-03-25 19:13:53.000000000 -0500 | ||
3 | +++ rxvt/src/rxvtlib.h.in 2004-04-03 20:35:13.000000000 -0500 | ||
4 | @@ -43,7 +43,11 @@ | ||
5 | #include <sys/wait.h> | ||
6 | #include <sys/stat.h> | ||
7 | |||
8 | -#include <X11/Intrinsic.h> /* Xlib, Xutil, Xresource, Xfuncproto */ | ||
9 | +#include <X11/Xlib.h> | ||
10 | +#include <X11/Xutil.h> | ||
11 | +#include <X11/Xresource.h> | ||
12 | +#include <X11/Xproto.h> | ||
13 | +#include <X11/region.h> | ||
14 | |||
15 | #ifdef ENABLE_XFT | ||
16 | #include <X11/Xft/Xft.h> | ||
diff --git a/openembedded/packages/rxvt/rxvt_2.7.9.bb b/openembedded/packages/rxvt/rxvt_2.7.9.bb deleted file mode 100644 index c201d16f8a..0000000000 --- a/openembedded/packages/rxvt/rxvt_2.7.9.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | DESCRIPTION = "Well known terminal emulator" | ||
2 | SECTION = "x11/utils" | ||
3 | PR = "r1" | ||
4 | DEPENDS = "x11 libxft" | ||
5 | LICENSE = "GPL" | ||
6 | SRC_URI = "${HANDHELDS_CVS};module=apps/rxvt \ | ||
7 | file://include.patch;patch=1" | ||
8 | |||
9 | inherit autotools update-alternatives | ||
10 | |||
11 | ALTERNATIVE_NAME = "x-terminal-emulator" | ||
12 | ALTERNATIVE_PATH = "${bindir}/rxvt-2.7.9" | ||
13 | |||
14 | S = ${WORKDIR}/rxvt | ||
15 | |||
16 | EXTRA_OECONF = "--disable-menubar --disable-xim \ | ||
17 | --enable-utmp --enable-wtmp --enable-lastlog \ | ||
18 | --disable-strings --with-term=rxvt --enable-keepscrolling \ | ||
19 | --with-xft --with-name=rxvt --enable-frills \ | ||
20 | --enable-swapscreen --enable-transparency \ | ||
21 | --with-codesets=eu,jp \ | ||
22 | --enable-cursor-blink --enable-pointer-blank \ | ||
23 | --enable-text-blink --enable-plain-scroll \ | ||
24 | --enable-combining --enable-shared \ | ||
25 | --with-x=${STAGING_LIBDIR}/.." | ||
26 | |||
27 | EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \ | ||
28 | 'XLIB=-L${STAGING_LIBDIR} -lX11 -lXft'" | ||
29 | |||
30 | do_configure () { | ||
31 | mv autoconf/configure.in . || true | ||
32 | rm autoconf/libtool.m4 | ||
33 | libtoolize --force | ||
34 | autotools_do_configure | ||
35 | echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h | ||
36 | echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h | ||
37 | echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h | ||
38 | echo '#define HAVE_XLOCALE 1' >> config.h | ||
39 | echo '#define HAVE_UTMP_H 1' >> config.h | ||
40 | echo '#define HAVE_TTYSLOT 1' >> config.h | ||
41 | } | ||