diff options
author | Richard Purdie <richard@openedhand.com> | 2005-09-28 17:31:21 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2005-09-28 17:31:21 +0000 |
commit | cb47354f1ce201e7b2d16698be19055c0d15c984 (patch) | |
tree | 14275fd46cef4a1e103864094231bc4875bddc1c /openembedded | |
parent | dd2bd6254c9649e5301d7a45b086c23053d895d1 (diff) | |
download | poky-cb47354f1ce201e7b2d16698be19055c0d15c984.tar.gz |
Add usbinit hack to get usbnet connection on 770 (will replace with udev in due course)
git-svn-id: https://svn.o-hand.com/repos/poky@53 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r-- | openembedded/packages/oh/usbinit.bb | 19 | ||||
-rwxr-xr-x | openembedded/packages/oh/usbinit/usb-gether | 19 |
2 files changed, 38 insertions, 0 deletions
diff --git a/openembedded/packages/oh/usbinit.bb b/openembedded/packages/oh/usbinit.bb new file mode 100644 index 0000000000..bfc8490dc1 --- /dev/null +++ b/openembedded/packages/oh/usbinit.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | DESCRIPTION = "Quick hack to start gadget Ethernet on the 770" | ||
2 | LICENSE = "GPL" | ||
3 | SECTION = "x11" | ||
4 | PRIORITY = "optional" | ||
5 | PR = "r0" | ||
6 | |||
7 | SRC_URI = "file://usb-gether" | ||
8 | S = ${WORKDIR} | ||
9 | |||
10 | do_install() { | ||
11 | install -d ${D}/etc | ||
12 | install -d ${D}/etc/init.d | ||
13 | install usb-gether ${D}/etc/init.d | ||
14 | } | ||
15 | |||
16 | inherit update-rc.d | ||
17 | |||
18 | INITSCRIPT_NAME = "usb-gether" | ||
19 | INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ." | ||
diff --git a/openembedded/packages/oh/usbinit/usb-gether b/openembedded/packages/oh/usbinit/usb-gether new file mode 100755 index 0000000000..590e77b22a --- /dev/null +++ b/openembedded/packages/oh/usbinit/usb-gether | |||
@@ -0,0 +1,19 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | case "$1" in | ||
4 | start) | ||
5 | /sbin/depmod -a | ||
6 | /sbin/modprobe g_ether | ||
7 | ifconfig usb0 192.168.1.120 | ||
8 | ;; | ||
9 | |||
10 | stop) | ||
11 | |||
12 | ;; | ||
13 | |||
14 | *) | ||
15 | echo "usage: $0 { start | stop }" | ||
16 | ;; | ||
17 | esac | ||
18 | |||
19 | exit 0 | ||