summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-03-23 23:32:58 +0000
committerRichard Purdie <richard@openedhand.com>2006-03-23 23:32:58 +0000
commit7f60e4b4e7d9b45bfe4b76802a2e82bb4edbba9f (patch)
treeb1ca54365729e3a4ac05c93616beb1207e497873 /openembedded
parent5d530ad71d08c3ebf127c6844969359c3a06a6ed (diff)
downloadpoky-7f60e4b4e7d9b45bfe4b76802a2e82bb4edbba9f.tar.gz
Sync initscripts with OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@331 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh20
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/banner4
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt169
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch52
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh5
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch15
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs43
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh40
-rw-r--r--openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map20
-rw-r--r--openembedded/packages/initscripts/initscripts_1.0.bb6
10 files changed, 13 insertions, 361 deletions
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh b/openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh
deleted file mode 100644
index bf193cb01c..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/alignment.sh
+++ /dev/null
@@ -1,20 +0,0 @@
1#!/bin/sh
2#
3# How to handle alignment faults on the ARM
4#
5# 0 - ignore, the value will probably be rotated
6# 1 - warn, a log message will be output
7# 2 - fixup, the kernel will do an expensive aligned read
8# 3 - fixup+warn
9# 4 - signal, the process will get an illegal instruction fault
10# 5 - signal+warn
11# 6 - invalid (has no effect)
12# 7 - invalid (has no effect)
13#
14# Set ALIGN in /etc/default/rcS to override (do not edit this
15# file!) Set ALIGN to empty to avoid changing the kernel
16# default (currently '0').
17ALIGN=1
18. /etc/default/rcS
19test -e /proc/cpu/alignment -a -n "$ALIGN" -a "$ALIGN" -ge 0 -a "$ALIGN" -lt 6 &&
20 echo "$ALIGN" >/proc/cpu/alignment
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/banner b/openembedded/packages/initscripts/initscripts-1.0/openslug/banner
deleted file mode 100644
index d80fb19fe4..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/banner
+++ /dev/null
@@ -1,4 +0,0 @@
1#!/bin/sh
2#NOTE: this script may execute with absolutely nothing
3# in /dev
4echo "OpenSlug booting..."
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt b/openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt
deleted file mode 100644
index ae3cb79913..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/device_table.txt
+++ /dev/null
@@ -1,169 +0,0 @@
1#/dev/ d 775 0 0 - - - - -
2#/dev/msys d 775 0 0 - - - - -
3#/dev/pts d 775 0 0 - - - - -
4#/var d 775 0 0 - - - - -
5/boot/var/empty d 755 0 3 - - - -
6/dev/apm_bios c 660 0 46 10 134 - - -
7/dev/audio c 660 0 29 14 4 - - -
8/dev/audio1 c 660 0 29 14 20 - - -
9/dev/audio2 c 660 0 29 14 36 - - -
10/dev/audio3 c 660 0 29 14 52 - - -
11#/dev/bty c 644 0 0 60 0 0 1 5
12/dev/buzzer c 660 0 0 62 0 - - -
13#/dev/sharp_fl c 640 0 44 254 0 - - -
14/dev/console c 662 0 5 5 1 - -
15/dev/cusa0 c 640 0 0 205 5 - - -
16/dev/cusa1 c 640 0 0 205 6 - - -
17/dev/cusa2 c 640 0 0 205 7 - - -
18/dev/dsp c 660 0 29 14 3 - - -
19/dev/dsp1 c 660 0 29 14 19 - - -
20/dev/dsp2 c 660 0 29 14 35 - - -
21/dev/dsp3 c 660 0 29 14 51 - - -
22/dev/fb c 660 0 44 29 0 0 32 2
23/dev/fb0autodetect c 660 0 44 29 1 - - -
24/dev/fb0current c 660 0 44 29 0 - - -
25#/dev/fb1 c 660 0 44 29 32 - - -
26/dev/fb1autodetect c 660 0 44 29 33 - - -
27/dev/fb1current c 660 0 44 29 32 - - -
28/dev/full c 666 0 7 - - -
29/dev/hda b 660 0 6 3 0 - - -
30/dev/hda b 660 0 6 3 1 1 1 20
31/dev/hdb b 660 0 6 3 64 - - -
32/dev/hdb b 660 0 6 3 65 1 1 20
33/dev/hdc b 660 0 6 22 0 - - -
34/dev/hdc b 660 0 6 22 1 1 1 20
35/dev/initctl p 600 0 0 - - - -
36/dev/i2c0 c 660 0 0 89 0 - - -
37/dev/inportbm c 660 0 0 10 2 - - -
38/dev/input/event c 660 0 0 13 64 0 1 20
39/dev/ircomm0 c 640 0 0 161 0 - - -
40/dev/jbm c 660 0 0 10 4 - - -
41/dev/kmem c 640 0 15 1 2 - - -
42/dev/leds c 660 0 0 126 0 - - -
43#/dev/lirc c 660 0 5 61 0 - - -
44/dev/logibm c 660 0 0 10 0 - - -
45/dev/loop0 b 660 0 11 7 0 - - -
46/dev/loop1 b 660 0 11 7 1 - - -
47/dev/mem c 640 0 15 1 1 - - -
48/dev/mixer c 666 0 0 14 0 - - -
49/dev/mixer1 c 666 0 0 14 16 - - -
50/dev/mixer2 c 666 0 0 14 32 - - -
51/dev/mixer3 c 666 0 0 14 48 - - -
52/dev/mmcda b 640 0 0 60 0 - - -
53/dev/mmcda1 b 640 0 0 60 1 - - -
54/dev/mmcda2 b 640 0 0 60 2 - - -
55/dev/msys/fla b 660 0 11 100 0 - - -
56/dev/msys/fla1 b 660 0 11 100 1 - - -
57/dev/msys/fla2 b 660 0 11 100 2 - - -
58/dev/msys/fla3 b 660 0 11 100 3 - - -
59/dev/msys/fla4 b 660 0 11 100 4 - - -
60/dev/msys/flb b 660 0 11 100 64 - - -
61/dev/msys/flb1 b 660 0 11 100 65 - - -
62/dev/msys/flb2 b 660 0 11 100 66 - - -
63/dev/msys/flb3 b 660 0 11 100 67 - - -
64/dev/msys/flb4 b 660 0 11 100 68 - - -
65/dev/mtd c 660 0 6 90 0 0 2 8
66/dev/mtdblock b 640 0 0 31 0 0 1 8
67/dev/nst0 c 664 0 11 9 128 - - -
68/dev/nst0a c 664 0 11 9 224 - - -
69/dev/nst0l c 664 0 11 9 160 - - -
70/dev/nst0m c 664 0 11 9 192 - - -
71/dev/nst1 c 664 0 11 9 129 - - -
72/dev/nst1a c 664 0 11 9 225 - - -
73/dev/nst1l c 664 0 11 9 161 - - -
74/dev/nst1m c 664 0 11 9 193 - - -
75/dev/null c 666 0 0 1 3 - - -
76/dev/par0 c 660 0 7 6 0 - - -
77/dev/par1 c 660 0 7 6 1 - - -
78/dev/par2 c 660 0 7 6 2 - - -
79/dev/pbuttons c 660 0 0 61 0 - - -
80/dev/port c 640 0 15 1 4 - - -
81/dev/ppp c 640 0 0 108 0 - - -
82/dev/psaux c 660 0 0 10 1 - - -
83/dev/ptmx c 666 0 5 5 2 - - -
84/dev/ptya0 c 660 0 5 2 176 - - -
85/dev/ptya1 c 660 0 5 2 177 - - -
86/dev/ptya2 c 660 0 5 2 178 - - -
87/dev/ptya3 c 660 0 5 2 179 - - -
88/dev/ptya4 c 660 0 5 2 180 - - -
89/dev/ptya5 c 660 0 5 2 181 - - -
90/dev/ptya6 c 660 0 5 2 182 - - -
91/dev/ptya7 c 660 0 5 2 183 - - -
92/dev/ptya8 c 660 0 5 2 184 - - -
93/dev/ptya9 c 660 0 5 2 185 - - -
94/dev/ptyaa c 660 0 5 2 186 - - -
95/dev/ptyab c 660 0 5 2 187 - - -
96/dev/ptyac c 660 0 5 2 188 - - -
97/dev/ptyad c 660 0 5 2 189 - - -
98/dev/ptyae c 660 0 5 2 190 - - -
99/dev/ptyaf c 660 0 5 2 191 - - -
100/dev/ram b 640 0 0 1 0 0 1 4
101/dev/random c 444 0 0 1 8 - - -
102/dev/rbuttons c 660 0 0 60 0 - - -
103/dev/rfcomm c 666 0 0 216 0 0 1 4
104/dev/rmidi0 c 660 0 0 35 64 - - -
105/dev/rmidi1 c 660 0 0 35 65 - - -
106/dev/rmidi2 c 660 0 0 35 66 - - -
107/dev/rmidi3 c 660 0 0 35 67 - - -
108/dev/rtc c 660 0 47 10 135 - - -
109/dev/scd0 b 660 0 6 11 0 - - -
110/dev/scd1 b 660 0 6 11 1 - - -
111/dev/sda b 660 0 6 8 0 - - -
112/dev/sda1 b 660 0 6 8 1 - - -
113/dev/sda2 b 660 0 6 8 2 - - -
114/dev/sda3 b 660 0 6 8 3 - - -
115/dev/sda4 b 660 0 6 8 4 - - -
116/dev/sda5 b 660 0 6 8 5 - - -
117/dev/sda6 b 660 0 6 8 6 - - -
118/dev/sda7 b 660 0 6 8 7 - - -
119/dev/sda8 b 660 0 6 8 8 - - -
120/dev/sda9 b 660 0 6 8 9 - - -
121/dev/sdb b 660 0 6 8 16 - - -
122/dev/sdb1 b 660 0 6 8 17 - - -
123/dev/sdb2 b 660 0 6 8 18 - - -
124/dev/sdb3 b 660 0 6 8 19 - - -
125/dev/sdb4 b 660 0 6 8 20 - - -
126/dev/sdb5 b 660 0 6 8 21 - - -
127/dev/sdb6 b 660 0 6 8 22 - - -
128/dev/sdb7 b 660 0 6 8 23 - - -
129/dev/sdb8 b 660 0 6 8 24 - - -
130/dev/sdb9 b 660 0 6 8 25 - - -
131/dev/sdc b 660 0 6 8 32 - - -
132/dev/sdc1 b 660 0 6 8 33 - - -
133/dev/sdc2 b 660 0 6 8 34 - - -
134/dev/sdc3 b 660 0 6 8 35 - - -
135/dev/sdc4 b 660 0 6 8 36 - - -
136/dev/sdc5 b 660 0 6 8 37 - - -
137/dev/sdc6 b 660 0 6 8 38 - - -
138/dev/sdc7 b 660 0 6 8 39 - - -
139/dev/sdc8 b 660 0 6 8 40 - - -
140/dev/sdc9 b 660 0 6 8 41 - - -
141/dev/sd_slotstat c 660 0 6 10 240 - - -
142#/dev/sharp_audioctl c 660 0 29 10 213 - - -
143#/dev/sharp_buz c 660 0 29 10 211 - - -
144#/dev/sharp_kbdctl c 660 0 45 10 214 - - -
145#/dev/sharp_led c 660 0 48 10 210 - - -
146#/dev/sharp_ts c 640 0 45 11 0 - - -
147/dev/smtpe0 c 640 0 0 35 128 - - -
148/dev/smtpe1 c 640 0 0 35 129 - - -
149/dev/smtpe2 c 640 0 0 35 130 - - -
150/dev/smtpe3 c 640 0 0 35 131 - - -
151/dev/sndstat c 660 0 29 14 6 - - -
152/dev/st0 c 660 0 11 9 0 - - -
153/dev/st0a c 660 0 11 9 96 - - -
154/dev/st0l c 660 0 11 9 32 - - -
155/dev/st0m c 660 0 11 9 64 - - -
156/dev/st1 c 660 0 11 9 1 - - -
157/dev/st1a c 660 0 11 9 97 - - -
158/dev/st1l c 660 0 11 9 33 - - -
159/dev/st1m c 660 0 11 9 65 - - -
160/dev/tty c 666 0 5 5 0 - - -
161/dev/tty c 666 0 5 4 0 0 1 9
162/dev/ttyS c 640 0 5 4 64 0 1 4
163/dev/ttySA c 640 0 5 204 5 0 1 4
164/dev/ttyUSB c 660 0 5 188 0 0 1 2
165/dev/urandom c 644 0 0 1 9 - - -
166/dev/usbmouse c 640 0 45 10 32 - - -
167/dev/video c 644 0 0 81 0 0 1 4
168/dev/zero c 644 0 0 1 5 - - -
169/dev/input/mice c 660 0 0 13 63 - - -
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch b/openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch
deleted file mode 100644
index 26b1841d5b..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/devices.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1#
2# Patch to allow /dev to reside permanently in the file
3# system.
4#
5--- old/devices 2005-05-28 21:51:39.012078699 -0700
6+++ new/devices 2005-06-12 00:16:29.222686303 -0700
7@@ -6,7 +6,7 @@
8 . /etc/default/rcS
9
10 # exit without doing anything if udev is active
11-if test -e /dev/.udevdb; then
12+if test -e /dev/.udevdb -o -e /dev/.permanent; then
13 exit 0
14 fi
15
16@@ -37,12 +37,20 @@
17 mknod /dev/ppp c 108 0
18 if test "$VERBOSE" != "no"; then echo "done"; fi
19 else
20- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
21- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
22- if test $? -ne 0; then
23- if test "$VERBOSE" != "no"; then echo "failed"; fi
24+ if test -e /dev/.noram
25+ then
26+ # There should be no files, any files will damage the
27+ # makedevs script below.
28+ rm $(find /dev -type f -print)
29+ :>/dev/.noram
30 else
31- if test "$VERBOSE" != "no"; then echo "done"; fi
32+ if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
33+ mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
34+ if test $? -ne 0; then
35+ if test "$VERBOSE" != "no"; then echo "failed"; fi
36+ else
37+ if test "$VERBOSE" != "no"; then echo "done"; fi
38+ fi
39 fi
40 if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
41 cd /
42@@ -60,6 +68,10 @@
43 if test "$VERBOSE" != "no"; then echo "failed"; fi
44 else
45 if test "$VERBOSE" != "no"; then echo "done"; fi
46+ if test -e /dev/.noram
47+ then
48+ :>/dev/.permanent
49+ fi
50 fi
51 fi
52
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh b/openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh
deleted file mode 100644
index 7113467d8c..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/domainname.sh
+++ /dev/null
@@ -1,5 +0,0 @@
1#
2# domainname.sh Set the domainname.
3#
4test -r /etc/defaultdomain &&
5 cat /etc/defaultdomain >/proc/sys/kernel/domainname
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch b/openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch
deleted file mode 100644
index 3f2a925879..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/rootopts.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1#
2# Ensure that the root file system is remounted with the correct
3# options from fstab
4#
5--- old/checkroot.sh 2005-05-28 19:30:55.488975598 -0700
6+++ new/checkroot.sh 2005-05-28 19:31:32.334390450 -0700
7@@ -149,7 +149,7 @@
8 # is on a ro fs until the remount succeeded. Then clean up old mtabs
9 # and finally write the new mtab.
10 #
11-mount -n -o remount,$rootmode /
12+mount -n -o remount,$rootopts /
13 if test "$rootmode" = rw
14 then
15 if test ! -L /etc/mtab
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs b/openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs
deleted file mode 100644
index d6f432dbda..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountfs
+++ /dev/null
@@ -1,43 +0,0 @@
1#! /bin/sh
2#
3# umountfs Turn off swap and unmount all local filesystems.
4#
5
6PATH=/sbin:/bin:/usr/sbin:/usr/bin
7
8# Ensure /proc is mounted
9test -r /proc/mounts || mount -t proc proc /proc
10
11echo "Deactivating swap..."
12swapoff -a
13
14# We leave /proc mounted, the umount of /dev/devpts seems to fail
15# quite frequently, the busybox umount apparently gives up at the
16# first failure, so it is necessary to go file system by file
17# system. It is necessary to go backward in the /proc list, because
18# later things may have been mounted on earlier mounts.
19devfs=
20unmount() {
21 local dev mp type opts
22 if read dev mp type opts
23 then
24 # recurse - unmount later items
25 unmount
26 # skip /proc and /dev but not the sub-directories
27 case "$mp" in
28 /|/proc)return 0;;
29 /dev) devfs=1
30 return 0;;
31 esac
32 # then unmount this, if possible, otherwise make
33 # it read-only
34 umount -f -r "$mp"
35 fi
36}
37
38echo "Unmounting local filesystems..."
39unmount </proc/mounts
40
41# now /dev and read-only / (halt/reboot may need /proc!)
42test -n "$devfs" && umount -f -r /dev
43mount -o remount,ro /
diff --git a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh b/openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh
deleted file mode 100644
index 994a919225..0000000000
--- a/openembedded/packages/initscripts/initscripts-1.0/openslug/umountnfs.sh
+++ /dev/null
@@ -1,40 +0,0 @@
1#! /bin/sh
2#
3# umountnfs.sh Unmount all network filesystems.
4#
5PATH=/sbin:/bin:/usr/sbin:/usr/bin
6
7# Write a reboot record to /var/log/wtmp before unmounting
8halt -w
9
10# Ensure /proc is mounted
11test -r /proc/mounts || mount -t proc proc /proc
12
13echo "Unmounting remote filesystems..."
14
15#
16# Read the list of mounted file systems and -f umount the
17# known network file systems. -f says umount it even if
18# the server is unreachable. Do not attempt to umount
19# the root file system. Unmount in reverse order from
20# that given by /proc/mounts (otherwise it may not work).
21#
22unmount() {
23 local dev mp type opts
24 if read dev mp type opts
25 then
26 # recurse - unmount later items
27 unmount
28 # skip /, /proc and /dev
29 case "$mp" in
30 /|/proc)return 0;;
31 /dev) return 0;;
32 esac
33 # then unmount this, if nfs
34 case "$type" in
35 nfs|smbfs|ncpfs) umount -f "$mp";;
36 esac
37 fi
38}
39
40unmount </proc/mounts
diff --git a/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map b/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map
index b27f21e320..31ca75b660 100644
--- a/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map
+++ b/openembedded/packages/initscripts/initscripts-1.0/tosa/keymap-2.4.map
@@ -42,16 +42,16 @@ keycode 38 = Right
42 altgr keycode 38 = Incr_Console 42 altgr keycode 38 = Incr_Console
43keycode 39 = Return 43keycode 39 = Return
44keycode 40 = F12 44keycode 40 = F12
45keycode 41 = one exclam 45keycode 41 = one exclam one
46keycode 42 = two quotedbl 46keycode 42 = two quotedbl two
47keycode 43 = three numbersign 47keycode 43 = three numbersign three
48keycode 44 = four dollar 48keycode 44 = four dollar four
49keycode 45 = five percent 49keycode 45 = five percent five
50keycode 46 = six ampersand 50keycode 46 = six ampersand six
51keycode 47 = seven apostrophe 51keycode 47 = seven apostrophe seven
52keycode 48 = eight parenleft 52keycode 48 = eight parenleft eight
53keycode 49 = nine parenright 53keycode 49 = nine parenright nine
54keycode 50 = zero asciitilde 54keycode 50 = zero asciitilde zero
55keycode 51 = minus equal 55keycode 51 = minus equal
56keycode 52 = asciicircum asciitilde 56keycode 52 = asciicircum asciitilde
57keycode 53 = backslash bar 57keycode 53 = backslash bar
diff --git a/openembedded/packages/initscripts/initscripts_1.0.bb b/openembedded/packages/initscripts/initscripts_1.0.bb
index 4e11097f89..d9b93005f5 100644
--- a/openembedded/packages/initscripts/initscripts_1.0.bb
+++ b/openembedded/packages/initscripts/initscripts_1.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "makedevs"
6DEPENDS_openzaurus = "makedevs virtual/kernel" 6DEPENDS_openzaurus = "makedevs virtual/kernel"
7RDEPENDS = "makedevs" 7RDEPENDS = "makedevs"
8LICENSE = "GPL" 8LICENSE = "GPL"
9PR = "r67" 9PR = "r69"
10 10
11SRC_URI = "file://halt \ 11SRC_URI = "file://halt \
12 file://ramdisk \ 12 file://ramdisk \
@@ -127,14 +127,14 @@ do_install () {
127 ln -sf ../init.d/sendsigs ${D}${sysconfdir}/rc6.d/S20sendsigs 127 ln -sf ../init.d/sendsigs ${D}${sysconfdir}/rc6.d/S20sendsigs
128# ln -sf ../init.d/urandom ${D}${sysconfdir}/rc6.d/S30urandom 128# ln -sf ../init.d/urandom ${D}${sysconfdir}/rc6.d/S30urandom
129 ln -sf ../init.d/umountnfs.sh ${D}${sysconfdir}/rc6.d/S31umountnfs.sh 129 ln -sf ../init.d/umountnfs.sh ${D}${sysconfdir}/rc6.d/S31umountnfs.sh
130# ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc6.d/S40umountfs 130 ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc6.d/S40umountfs
131 # udev will run at S55 if installed 131 # udev will run at S55 if installed
132 ln -sf ../init.d/ramdisk ${D}${sysconfdir}/rcS.d/S30ramdisk 132 ln -sf ../init.d/ramdisk ${D}${sysconfdir}/rcS.d/S30ramdisk
133 ln -sf ../init.d/reboot ${D}${sysconfdir}/rc6.d/S90reboot 133 ln -sf ../init.d/reboot ${D}${sysconfdir}/rc6.d/S90reboot
134 ln -sf ../init.d/sendsigs ${D}${sysconfdir}/rc0.d/S20sendsigs 134 ln -sf ../init.d/sendsigs ${D}${sysconfdir}/rc0.d/S20sendsigs
135# ln -sf ../init.d/urandom ${D}${sysconfdir}/rc0.d/S30urandom 135# ln -sf ../init.d/urandom ${D}${sysconfdir}/rc0.d/S30urandom
136 ln -sf ../init.d/umountnfs.sh ${D}${sysconfdir}/rc0.d/S31umountnfs.sh 136 ln -sf ../init.d/umountnfs.sh ${D}${sysconfdir}/rc0.d/S31umountnfs.sh
137# ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc0.d/S40umountfs 137 ln -sf ../init.d/umountfs ${D}${sysconfdir}/rc0.d/S40umountfs
138 # udev will run at S55 if installed 138 # udev will run at S55 if installed
139 ln -sf ../init.d/halt ${D}${sysconfdir}/rc0.d/S90halt 139 ln -sf ../init.d/halt ${D}${sysconfdir}/rc0.d/S90halt
140 ln -sf ../init.d/banner ${D}${sysconfdir}/rcS.d/S02banner 140 ln -sf ../init.d/banner ${D}${sysconfdir}/rcS.d/S02banner