summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2006-03-20 12:48:46 +0000
committerRoss Burton <ross@openedhand.com>2006-03-20 12:48:46 +0000
commitf12c6c68ddedec320f82c3c67c086541d4689722 (patch)
tree29090e63481e81f21783dc4373da987f044ca376 /openembedded
parentb58756b169ea993487acbfdaea29d08baee936af (diff)
downloadpoky-f12c6c68ddedec320f82c3c67c086541d4689722.tar.gz
Add GLib 2.10.x
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@303 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb b/openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb
new file mode 100644
index 0000000000..81ae84df0c
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb
@@ -0,0 +1,48 @@
1DESCRIPTION = "GLib is a general-purpose utility library, \
2which provides many useful data types, macros, \
3type conversions, string utilities, file utilities, a main \
4loop abstraction, and so on. It works on many \
5UNIX-like platforms, Windows, OS/2 and BeOS."
6LICENSE = "LGPL"
7SECTION = "libs"
8PRIORITY = "optional"
9MAINTAINER = "Philip Blundell <pb@handhelds.org>"
10DEPENDS += "glib-2.0-native gtk-doc"
11DEPENDS += "virtual/libiconv virtual/libintl"
12PACKAGES =+ "glib-2.0-utils "
13PR = "r1"
14
15LEAD_SONAME = "libglib-2.0.*"
16FILES_glib-2.0-utils = "${bindir}/*"
17
18EXTRA_OECONF = "--disable-debug"
19
20SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \
21 file://glibconfig-sysdefs.h"
22
23S = "${WORKDIR}/glib-${PV}"
24
25inherit autotools pkgconfig gettext
26
27python () {
28 if bb.data.getVar("USE_NLS", d, 1) == "no":
29 raise bb.parse.SkipPackage("${PN} requires native language support.")
30}
31
32acpaths = ""
33do_configure_prepend () {
34 install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
35}
36
37do_stage () {
38 oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
39 oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
40 oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
41 oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
42 autotools_stage_includes
43 install -d ${STAGING_INCDIR}/glib-2.0/glib
44 install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
45 install -d ${STAGING_DATADIR}/aclocal
46 install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
47 install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
48}