summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-10-06 11:42:44 +0000
committerChris Lord <chris@openedhand.com>2005-10-06 11:42:44 +0000
commit7469e31faccee9fe1021507281edd7da8d5221ec (patch)
tree81b3b8693ea748661b7b170c90646dcdaa446ef5 /openembedded
parentbab73940ce94653d4ef855a5f7979cb0030f689c (diff)
downloadpoky-7469e31faccee9fe1021507281edd7da8d5221ec.tar.gz
Add libgtkhtml-2.0
git-svn-id: https://svn.o-hand.com/repos/poky@124 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rwxr-xr-xopenembedded/packages/gtkhtml2/gtkhtml2_cvs.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/openembedded/packages/gtkhtml2/gtkhtml2_cvs.bb b/openembedded/packages/gtkhtml2/gtkhtml2_cvs.bb
new file mode 100755
index 0000000000..7755cffa26
--- /dev/null
+++ b/openembedded/packages/gtkhtml2/gtkhtml2_cvs.bb
@@ -0,0 +1,22 @@
1SECTION = "libs"
2DEPENDS = "gtk+ glib-2.0 libxml2"
3DESCRIPTION = "A GTK+ HTML rendering library."
4LICENSE = "GPL"
5MAINTAINER = "Chris Lord <chris@openedhand.com>"
6PV = "0.0cvs${CVSDATE}"
7
8SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gtkhtml2"
9
10S = "${WORKDIR}/${PN}"
11
12inherit pkgconfig autotools
13
14EXTRA_OECONF = " --disable-accessibility"
15
16do_stage() {
17 oe_libinstall -so -C libgtkhtml libgtkhtml-2 ${STAGING_LIBDIR}
18 install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
19 ( for i in css document dom dom/core dom/events dom/html dom/traversal dom/views graphics layout layout/html util view; do install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; install -m 0644 ${S}/libgtkhtml/$i/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; done )
20 install -m 0644 ${S}/libgtkhtml/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
21}
22