summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorJorn Baayen <jorn@openedhand.com>2006-07-20 10:43:56 +0000
committerJorn Baayen <jorn@openedhand.com>2006-07-20 10:43:56 +0000
commiteefc8d5e324124c260809a4ac1b2b75d5139e881 (patch)
treeb0aa1594f32082d486bf3423af1da3c850f7d06d /openembedded
parent1c3a546c0aefd3b2f107a3aad28613ab570e7ad4 (diff)
downloadpoky-eefc8d5e324124c260809a4ac1b2b75d5139e881.tar.gz
added glib 2.12 (needed for gtk 2.10 + decairoification patches)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@516 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb54
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb47
2 files changed, 101 insertions, 0 deletions
diff --git a/openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb b/openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb
new file mode 100644
index 0000000000..768f2777d8
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb
@@ -0,0 +1,54 @@
1DESCRIPTION = "GLib is a general-purpose utility library, \
2which provides many useful data types, macros, \
3type conversions, string utilities, file utilities, a main \
4loop abstraction, and so on. It works on many \
5UNIX-like platforms, Windows, OS/2 and BeOS."
6LICENSE = "LGPL"
7SECTION = "libs"
8PRIORITY = "optional"
9DEPENDS += "gtk-doc-native"
10PR="r1"
11
12EXTRA_OECONF = "--disable-debug"
13
14SRC_URI = "http://download.gnome.org/sources/glib/2.12/glib-${PV}.tar.bz2 \
15 file://glib-gettextize-dir.patch;patch=1 \
16 file://glibconfig-sysdefs.h"
17
18S = "${WORKDIR}/glib-${PV}"
19
20inherit autotools pkgconfig native gettext
21
22python () {
23 if bb.data.getVar("USE_NLS", d, 1) == "no":
24 raise bb.parse.SkipPackage("${PN} requires native language support.")
25}
26
27acpaths = ""
28do_configure_prepend () {
29 install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
30}
31
32do_stage () {
33 install -m 0755 gobject/glib-mkenums ${STAGING_BINDIR}/
34 install -m 0755 gobject/.libs/glib-genmarshal ${STAGING_BINDIR}/
35 install -m 0755 glib-gettextize ${STAGING_BINDIR}/
36 oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
37 oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
38 oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
39 oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
40 autotools_stage_includes
41 install -d ${STAGING_INCDIR}/glib-2.0/glib
42 install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
43 install -d ${STAGING_DATADIR}/aclocal
44 install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
45 install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
46 install -d ${STAGING_DATADIR}/glib-2.0/gettext/po
47 install -m 0755 mkinstalldirs ${STAGING_DATADIR}/glib-2.0/gettext/
48 install -m 0644 po/Makefile.in.in ${STAGING_DATADIR}/glib-2.0/gettext/po/
49}
50
51do_install () {
52 :
53}
54
diff --git a/openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb b/openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb
new file mode 100644
index 0000000000..31d7347a06
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "GLib is a general-purpose utility library, \
2which provides many useful data types, macros, \
3type conversions, string utilities, file utilities, a main \
4loop abstraction, and so on. It works on many \
5UNIX-like platforms, Windows, OS/2 and BeOS."
6LICENSE = "LGPL"
7SECTION = "libs"
8PRIORITY = "optional"
9DEPENDS += "glib-2.0-native gtk-doc"
10DEPENDS += "virtual/libiconv virtual/libintl"
11PACKAGES =+ "glib-2.0-utils "
12PR = "r1"
13
14LEAD_SONAME = "libglib-2.0.*"
15FILES_glib-2.0-utils = "${bindir}/*"
16
17EXTRA_OECONF = "--disable-debug"
18
19SRC_URI = "http://download.gnome.org/sources/glib/2.12/glib-${PV}.tar.bz2 \
20 file://glibconfig-sysdefs.h"
21
22S = "${WORKDIR}/glib-${PV}"
23
24inherit autotools pkgconfig gettext
25
26python () {
27 if bb.data.getVar("USE_NLS", d, 1) == "no":
28 raise bb.parse.SkipPackage("${PN} requires native language support.")
29}
30
31acpaths = ""
32do_configure_prepend () {
33 install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
34}
35
36do_stage () {
37 oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
38 oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
39 oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
40 oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
41 autotools_stage_includes
42 install -d ${STAGING_INCDIR}/glib-2.0/glib
43 install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
44 install -d ${STAGING_DATADIR}/aclocal
45 install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
46 install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
47}