summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-06-13 14:01:42 +0000
committerRichard Purdie <richard@openedhand.com>2006-06-13 14:01:42 +0000
commitb73894286424a80308c368464f4b1ecf91215caa (patch)
tree3bbae98f938978ed9b1c5aee018ef7c69fd9c894 /openembedded
parentd1d82773d5a49021d9f3130f9e3423c8a60d4a53 (diff)
downloadpoky-b73894286424a80308c368464f4b1ecf91215caa.tar.gz
die detect-stylus die
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@476 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch17
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch15
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch13
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus_0.13.bb18
4 files changed, 0 insertions, 63 deletions
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch
deleted file mode 100644
index cd8c52074d..0000000000
--- a/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch
+++ /dev/null
@@ -1,17 +0,0 @@
1Index: detect-stylus.c
2===================================================================
3RCS file: /cvs/gpe/base/detect-stylus/detect-stylus.c,v
4retrieving revision 1.12
5retrieving revision 1.13
6diff -u -r1.12 -r1.13
7--- detect-stylus.c 8 Sep 2004 15:57:15 -0000 1.12
8+++ detect-stylus.c 9 Sep 2004 23:08:42 -0000 1.13
9@@ -131,7 +131,7 @@
10 XChangeProperty (dpy, root, atom, XA_INTEGER, 8, PropModeReplace, &b, 1);
11
12 XCloseDisplay (dpy);
13- if (!access("/usr/bin/xrdb", X_OK))
14+ if (access("/usr/bin/xrdb", X_OK))
15 system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
16 else
17 system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/bin/xrdb -nocpp -merge");
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch
deleted file mode 100644
index 7c8213da1f..0000000000
--- a/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1diff -urNd ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c detect-stylus-0.13/detect-stylus.c
2--- ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c 2004-09-08 16:56:58.000000000 +0100
3+++ detect-stylus-0.13/detect-stylus.c 2004-09-13 21:36:03.000000000 +0100
4@@ -132,9 +132,9 @@
5
6 XCloseDisplay (dpy);
7 if (access("/usr/bin/xrdb", X_OK))
8- system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
9+ system ("echo \"Matchbox.cursor: no\nXcursor.theme: xcursor-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
10 else
11- system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/bin/xrdb -nocpp -merge");
12+ system ("echo \"Matchbox.cursor: no\nXcursor.theme: xcursor-transparent\" | /usr/bin/xrdb -nocpp -merge");
13 }
14
15 exit (0);
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch
deleted file mode 100644
index 94542b11aa..0000000000
--- a/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1diff -urNd ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c detect-stylus-0.13/detect-stylus.c
2--- ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c 2004-09-08 16:56:58.000000000 +0100
3+++ detect-stylus-0.13/detect-stylus.c 2004-09-18 23:43:12.000000000 +0100
4@@ -62,6 +62,9 @@
5 if (fd < 0)
6 fd = try_open ("/dev/touchscreen/ucb1x00");
7
8+ if (fd < 0)
9+ fd = try_open ("/dev/ts");
10+
11 if (fd < 0)
12 {
13 DIR *d;
diff --git a/openembedded/packages/detect-stylus/detect-stylus_0.13.bb b/openembedded/packages/detect-stylus/detect-stylus_0.13.bb
deleted file mode 100644
index 793cbef849..0000000000
--- a/openembedded/packages/detect-stylus/detect-stylus_0.13.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1inherit gpe pkgconfig
2LICENSE = "GPL"
3
4PR = "r2"
5
6DEPENDS = "libx11 xcursor-transparent-theme xrdb"
7SECTION = "gpe"
8RDEPENDS = "xrdb"
9
10DESCRIPTION = "Touchscreen detection utility"
11MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
12
13SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz \
14 file://access.patch;patch=1;pnum=0 \
15 file://extra-device-check.patch;patch=1 \
16 file://correct-theme-name.patch;patch=1"
17
18export CVSBUILD="no"