summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorChris Larson <kergoth@openedhand.com>2006-07-13 09:13:21 +0000
committerChris Larson <kergoth@openedhand.com>2006-07-13 09:13:21 +0000
commit5f3d79f3195e24dde7169971343f4db03847a02e (patch)
tree3070e4043e413f3e477a407d7e37e0c3de0391e0 /openembedded
parent9ddd9dcefa6c1c0788151be43ee844b13ef1dd8a (diff)
downloadpoky-5f3d79f3195e24dde7169971343f4db03847a02e.tar.gz
poky: ipkg-utils update from upstream OE. Locks down to a specific cvs version rather than floating, which seems to fix some issues with root filesystem population in the build.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@512 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch34
-rw-r--r--openembedded/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb (renamed from openembedded/packages/ipkg-utils/ipkg-link_1.6cvs.bb)9
-rw-r--r--openembedded/packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch17
-rw-r--r--openembedded/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb (renamed from openembedded/packages/ipkg-utils/ipkg-utils-native_1.6cvs.bb)12
-rw-r--r--openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb (renamed from openembedded/packages/ipkg-utils/ipkg-utils_1.6cvs.bb)8
5 files changed, 67 insertions, 13 deletions
diff --git a/openembedded/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch b/openembedded/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch
new file mode 100644
index 0000000000..7f495f9f4c
--- /dev/null
+++ b/openembedded/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch
@@ -0,0 +1,34 @@
1--- ipkg-utils/ipkg-link.orig 2006-04-05 00:08:28.518992136 +0200
2+++ ipkg-utils/ipkg-link 2006-04-05 00:08:40.399186072 +0200
3@@ -58,6 +58,31 @@
4 `ln -s "$PREFIX$line" "$line"`
5 fi
6 fi
7+
8+ # The next function checks whether the _source_ file (ie: /media/card/something)
9+ # does actually exist. If it doesn't, it could by a library symlink (ie: libsomething.0.1 -> libsomething.0)
10+ # Since VFAT & friends do not support symlinks, these library links would not exist after installation
11+ # and trying to symlink them into the rootfs with ipkg-link results in unconnected symlinks in the rootfs.
12+ # So we use the real lib file in /media/card/whatever and create all needed symlinks in the rootfs
13+ # using the real file as source.
14+
15+ if [ ! -e "$PREFIX$line" ]; then
16+ if ( echo "$line" | grep -q "lib" ) ; then
17+ libsearchfile=$(echo $line | sed -e "s#[a-z0-9/.]*/##g")
18+ libfoundfiles=$(find $PREFIX -name "$libsearchfile*")
19+
20+ for liblinkfile in $libfoundfiles; do
21+ echo "Linking $line to $liblinkfile"
22+ # link will be pointing to nowhere
23+ if test -L $line; then
24+ rm -f $line
25+ fi
26+ ln -s $liblinkfile $line
27+ done
28+ else
29+ echo "WARNING: Source file [$PREFIX$line] is missing!"
30+ fi
31+ fi
32 done
33 }
34
diff --git a/openembedded/packages/ipkg-utils/ipkg-link_1.6cvs.bb b/openembedded/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb
index 94f749cf62..35e5ba1086 100644
--- a/openembedded/packages/ipkg-utils/ipkg-link_1.6cvs.bb
+++ b/openembedded/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb
@@ -2,11 +2,12 @@ SECTION = "base"
2DESCRIPTION = "Itsy Package Manager utilities link script" 2DESCRIPTION = "Itsy Package Manager utilities link script"
3LICENSE = "GPL" 3LICENSE = "GPL"
4CONFLICTS = "ipkg-utils" 4CONFLICTS = "ipkg-utils"
5PV_append = "${SRCDATE}" 5SRCDATE = "20050404"
6PR = "r1" 6PR = "r4"
7
8SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \
9 file://link-vfat-libs.patch;patch=1"
7 10
8SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils"
9
10S = "${WORKDIR}/ipkg-utils" 11S = "${WORKDIR}/ipkg-utils"
11 12
12do_compile() { 13do_compile() {
diff --git a/openembedded/packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch b/openembedded/packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch
new file mode 100644
index 0000000000..a9e6fc4d05
--- /dev/null
+++ b/openembedded/packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch
@@ -0,0 +1,17 @@
1--- ../../../work/i686-linux/ipkg-utils-native-1.6+cvs20050404-r6/ipkg-utils/ipkg.py 2005-01-08 19:08:52.000000000 +0100
2+++ ipkg-utils/ipkg.py 2006-06-29 12:52:58.466446000 +0200
3@@ -150,11 +150,11 @@
4 stat = os.stat(fn)
5 self.size = stat[ST_SIZE]
6 self.filename = os.path.basename(fn)
7- ## sys.stderr.write(" extracting control.tar.gz from %s\n"% (fn,))
8+ sys.stderr.write(" extracting control.tar.gz from %s\n"% (fn,))
9 if self.isdeb:
10- control = os.popen("ar p "+fn+" control.tar.gz | tar xfzO - '*control'","r")
11+ control = os.popen("ar p "+fn+" control.tar.gz | tar xfzO - './control'","r")
12 else:
13- control = os.popen("tar xfzO "+fn+" '*control.tar.gz' | tar xfzO - '*control'","r")
14+ control = os.popen("tar xfzO "+fn+" 'control.tar.gz' | tar xfzO - './control'","r")
15 line = control.readline()
16 while 1:
17 if not line: break
diff --git a/openembedded/packages/ipkg-utils/ipkg-utils-native_1.6cvs.bb b/openembedded/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb
index 7b66751614..ab8f4d63e0 100644
--- a/openembedded/packages/ipkg-utils/ipkg-utils-native_1.6cvs.bb
+++ b/openembedded/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb
@@ -1,9 +1,13 @@
1SECTION = "base"
2include ipkg-utils_${PV}.bb 1include ipkg-utils_${PV}.bb
3PR = "r4" 2SRC_URI += "file://ipkg-utils-fix.patch;patch=1"
4inherit native 3
5DEPENDS = ""
6RDEPENDS = "" 4RDEPENDS = ""
5PR = "r7"
6
7inherit native
8
9# Avoid circular dependencies from package_ipk.bbclass
10PACKAGES = ""
7 11
8do_stage() { 12do_stage() {
9 for i in ${INSTALL}; do 13 for i in ${INSTALL}; do
diff --git a/openembedded/packages/ipkg-utils/ipkg-utils_1.6cvs.bb b/openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
index 059ce8cb58..12ed042f15 100644
--- a/openembedded/packages/ipkg-utils/ipkg-utils_1.6cvs.bb
+++ b/openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
@@ -1,16 +1,14 @@
1DESCRIPTION = "Itsy Package Manager utilities" 1DESCRIPTION = "Itsy Package Manager utilities"
2DEPENDS = ""
3SECTION = "base" 2SECTION = "base"
4PRIORITY = "optional" 3PRIORITY = "optional"
5MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6LICENSE = "GPL" 4LICENSE = "GPL"
7CONFLICTS = "ipkg-link" 5CONFLICTS = "ipkg-link"
8RDEPENDS = "python" 6RDEPENDS = "python"
9PV_append = "${SRCDATE}" 7SRCDATE = "20050404"
10PR = "r9" 8PR = "r11"
11 9
12SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils" 10SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils"
13 11
14S = "${WORKDIR}/ipkg-utils" 12S = "${WORKDIR}/ipkg-utils"
15 13
16INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py" 14INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py"