summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-04 20:18:25 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-04 20:18:25 +0000
commit38a06013d777588bd40cacc16d354e62caa3e6ab (patch)
treea0228e51275d10434f7006168fac6f0c9758b003 /openembedded
parentae58f06c2bea7bbc51ef5058b8dbf71eda7e4898 (diff)
downloadpoky-38a06013d777588bd40cacc16d354e62caa3e6ab.tar.gz
Remove unneeded packages/meta files
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@500 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/meta/maemo-image.bb27
-rw-r--r--openembedded/packages/meta/meta-maemo.bb93
-rw-r--r--openembedded/packages/meta/mythfront-image.bb13
-rw-r--r--openembedded/packages/meta/task-bootstrap.bb36
4 files changed, 0 insertions, 169 deletions
diff --git a/openembedded/packages/meta/maemo-image.bb b/openembedded/packages/meta/maemo-image.bb
deleted file mode 100644
index 2adc88b958..0000000000
--- a/openembedded/packages/meta/maemo-image.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1#
2# Meta package for maemo based system image
3#
4
5FEED_URIS_append_familiar = " maemo##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/maemo"
6
7PR = "r2"
8
9export IMAGE_BASENAME = "maemo-image"
10
11GUI_MACHINE_CLASS ?= "none"
12
13MAEMO_EXTRA_DEPENDS = "scap dosfstools"
14MAEMO_EXTRA_INSTALL = "osso-af-services osso-af-base-apps scap dosfstools"
15
16XSERVER ?= "xserver-kdrive-omap"
17
18DEPENDS = "task-bootstrap \
19 meta-maemo \
20 ${MAEMO_EXTRA_DEPENDS}"
21
22export IPKG_INSTALL = "task-bootstrap maemo-task-base maemo-task-theme \
23 maemo-task-apps ${MAEMO_EXTRA_INSTALL} \
24 ${XSERVER}"
25
26inherit image_ipk
27LICENSE = MIT
diff --git a/openembedded/packages/meta/meta-maemo.bb b/openembedded/packages/meta/meta-maemo.bb
deleted file mode 100644
index fc0e9854ed..0000000000
--- a/openembedded/packages/meta/meta-maemo.bb
+++ /dev/null
@@ -1,93 +0,0 @@
1
2PR = "r7"
3PACKAGES = maemo-task-base maemo-task-apps maemo-task-libs-install maemo-task-theme
4DESCRIPTION = "Meta-package for maemo environment"
5MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
6
7ALLOW_EMPTY = "1"
8
9maemo-base-depends = "\
10 diet-x11 \
11 virtual/xserver \
12 xpext \
13 xsp"
14
15RDEPENDS_maemo-base-depends := "${maemo-base-depends}"
16DEPENDS += " ${maemo-base-depends}"
17
18maemo-task-libs-install = "\
19 libsqlite0 \
20 libhildonlgpl0 \
21 libhildonbase0 \
22 libhildonwidgets0 \
23 libhildonfm1"
24
25RDEPENDS_maemo-task-libs-install := "${maemo-task-libs-install}"
26
27
28maemo-task-base = "\
29 bluez-utils-dbus \
30 matchbox \
31 shared-mime-info \
32 rxvt-unicode \
33 xst \
34 xhost \
35 xrdb \
36 libgtkstylus \
37 detect-stylus \
38 outo \
39 hildon-initscripts \
40 libosso \
41 osso-af-utils \
42 osso-af-startup \
43 osso-core-config \
44 osso-gnome-vfs2 \
45 osso-thumbnail \
46 xauth \
47 esd"
48
49RDEPENDS_maemo-task-base := "gdk-pixbuf-loader-png \
50 gdk-pixbuf-loader-xpm \
51 gdk-pixbuf-loader-jpeg \
52 pango-module-basic-x \
53 pango-module-basic-fc \
54 ${maemo-task-base}"
55
56DEPENDS += " ${maemo-task-base}"
57
58
59maemo-task-theme = "\
60 xcursor-transparent-theme \
61 sdk-default-theme \
62 sdk-default-theme-config \
63 sdk-default-icons \
64 sapwood \
65 ttf-bitstream-vera \
66 sapwood \
67 osso-sounds"
68
69RDEPENDS_maemo-task-theme := "${maemo-task-theme}"
70
71DEPENDS += " ${maemo-task-theme}"
72
73
74
75maemo-task-apps = "\
76 osso-gwobex \
77 osso-gwconnect \
78 osso-bttools \
79 hildon-status-bar \
80 hildon-home \
81 hildon-navigator \
82 hildon-control-panel \
83 osso-application-installer \
84 osso-app-killer \
85 osso-screenshot-tool \
86 gpe-todo-hildon \
87 gpe-contacts-hildon \
88 gpe-mini-browser-hildon"
89
90RDEPENDS_maemo-task-apps := "${maemo-task-apps}"
91DEPENDS += " ${maemo-task-apps}"
92
93LICENSE = "MIT"
diff --git a/openembedded/packages/meta/mythfront-image.bb b/openembedded/packages/meta/mythfront-image.bb
deleted file mode 100644
index 7836258940..0000000000
--- a/openembedded/packages/meta/mythfront-image.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1export IMAGE_BASENAME = "mythfront-image"
2
3IMAGE_ROOTFS_SIZE_ext2 = "85000"
4IMAGE_ROOTFS_SIZE_ext2.gz = "85000"
5IMAGE_LINGUAS = ""
6
7MYTHFRONT_PACKAGES = "task-bootstrap task-mythfront"
8
9export IPKG_INSTALL = "${MYTHFRONT_PACKAGES}"
10DEPENDS = "${MYTHFRONT_PACKAGES}"
11
12inherit image_ipk
13LICENSE = MIT
diff --git a/openembedded/packages/meta/task-bootstrap.bb b/openembedded/packages/meta/task-bootstrap.bb
deleted file mode 100644
index 497fc31d89..0000000000
--- a/openembedded/packages/meta/task-bootstrap.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1DESCRIPTION = "Core packages required for a basic installation"
2MAINTAINER = "Phil Blundell <pb@handhelds.org>"
3PR = "r26"
4
5# The BOOTSTRAP_EXTRA_ variables are often manipulated by the
6# MACHINE .conf files, so adjust PACKAGE_ARCH accordingly.
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9ALLOW_EMPTY = 1
10PACKAGES = "${PN}"
11
12MODUTILS ?= "24 26"
13
14def bootstrap_modutils_rdepends(d):
15 import bb
16 m = bb.data.getVar('MODUTILS', d, 1)
17 r = []
18 if '24' in m:
19 r.append('modutils-depmod')
20 if '26' in m:
21 r.append('module-init-tools-depmod')
22 return ' '.join(r)
23
24HOTPLUG ?= "linux-hotplug"
25
26RDEPENDS = 'base-files base-passwd busybox \
27 initscripts \
28 netbase sysvinit sysvinit-pidof tinylogin \
29 modutils-initscripts fuser setserial\
30 ${HOTPLUG} \
31 ${BOOTSTRAP_EXTRA_RDEPENDS} \
32 ${@bootstrap_modutils_rdepends(d)}'
33
34RRECOMMENDS = 'dropbear portmap \
35 ${BOOTSTRAP_EXTRA_RRECOMMENDS}'
36LICENSE = MIT