diff options
author | Richard Purdie <richard@openedhand.com> | 2005-09-28 22:53:51 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2005-09-28 22:53:51 +0000 |
commit | 71c9c36c486e97aa17b569f10bdb22be0d2bb998 (patch) | |
tree | d04ce886276041fed1b91371d0acbffa08a48f03 /openembedded | |
parent | 3fab5dd14e6fef46d67957d0ec3dc729a4406387 (diff) | |
download | poky-71c9c36c486e97aa17b569f10bdb22be0d2bb998.tar.gz |
Add gnome-common for eds-dbus
git-svn-id: https://svn.o-hand.com/repos/poky@57 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r-- | openembedded/packages/gnome/gnome-common/omf.patch | 13 | ||||
-rw-r--r-- | openembedded/packages/gnome/gnome-common_2.4.0.bb | 28 |
2 files changed, 41 insertions, 0 deletions
diff --git a/openembedded/packages/gnome/gnome-common/omf.patch b/openembedded/packages/gnome/gnome-common/omf.patch new file mode 100644 index 0000000000..334425e4b2 --- /dev/null +++ b/openembedded/packages/gnome/gnome-common/omf.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | --- gnome-common-2.4.0/doc-build/omf.make 2003-05-24 08:16:25.000000000 -0700 | ||
2 | +++ gnome-common-2.4.0.new/doc-build/omf.make 2004-11-15 14:01:12.185155192 -0700 | ||
3 | @@ -43,7 +43,9 @@ | ||
4 | install-data-hook-omf: | ||
5 | $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir) | ||
6 | for file in $(omffile); do \ | ||
7 | - $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \ | ||
8 | + if [ -f $$file.out ]; then \ | ||
9 | + $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \ | ||
10 | + fi; \ | ||
11 | done | ||
12 | -scrollkeeper-update -p $(scrollkeeper_localstate_dir) -o $(DESTDIR)$(omf_dest_dir) | ||
13 | |||
diff --git a/openembedded/packages/gnome/gnome-common_2.4.0.bb b/openembedded/packages/gnome/gnome-common_2.4.0.bb new file mode 100644 index 0000000000..2991db81c7 --- /dev/null +++ b/openembedded/packages/gnome/gnome-common_2.4.0.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | LICENSE = "GPL" | ||
2 | SECTION = "x11/gnome" | ||
3 | PR = "r0" | ||
4 | DESCRIPTION = "Common macros for building GNOME applications" | ||
5 | inherit gnome | ||
6 | |||
7 | # The omf.make file failed if scrollkeeper doesn't happen to be | ||
8 | # installed | ||
9 | |||
10 | SRC_URI += "file://omf.patch;patch=1" | ||
11 | |||
12 | EXTRA_AUTORECONF = "" | ||
13 | DEPENDS = "" | ||
14 | |||
15 | FILES_${PN} += "${datadir}/aclocal" | ||
16 | FILES_${PN}-dev = "" | ||
17 | |||
18 | do_stage () { | ||
19 | rm -rf ${STAGE_TEMP} | ||
20 | mkdir -p ${STAGE_TEMP} | ||
21 | make DESTDIR="${STAGE_TEMP}" install | ||
22 | cp -pPR ${STAGE_TEMP}${bindir}/* ${STAGING_DIR}/${BUILD_SYS}/bin | ||
23 | install -d ${STAGING_DATADIR}/gnome-common | ||
24 | install -d ${STAGING_DATADIR}/aclocal | ||
25 | cp -pPR ${STAGE_TEMP}${datadir}/gnome-common/* ${STAGING_DATADIR}/gnome-common | ||
26 | cp -pPR ${STAGE_TEMP}${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal | ||
27 | rm -rf ${STAGE_TEMP} | ||
28 | } | ||