diff options
author | Richard Purdie <richard@openedhand.com> | 2006-03-23 23:28:43 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-03-23 23:28:43 +0000 |
commit | 5d530ad71d08c3ebf127c6844969359c3a06a6ed (patch) | |
tree | 0b0e1db18aaa668c7dafeda3a84a46f0bfe17844 /openembedded/packages | |
parent | 1494095f626896f5429acd0aee6fca6389f21837 (diff) | |
download | poky-5d530ad71d08c3ebf127c6844969359c3a06a6ed.tar.gz |
Update hostap packages from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@330 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages')
18 files changed, 270 insertions, 303 deletions
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/defconfig b/openembedded/packages/hostap/hostap-daemon-0.4.4/defconfig deleted file mode 100644 index d0e22f2586..0000000000 --- a/openembedded/packages/hostap/hostap-daemon-0.4.4/defconfig +++ /dev/null | |||
@@ -1,66 +0,0 @@ | |||
1 | # Example hostapd build time configuration | ||
2 | # | ||
3 | # This file lists the configuration options that are used when building the | ||
4 | # hostapd binary. All lines starting with # are ignored. Configuration option | ||
5 | # lines must be commented out complete, if they are not to be included, i.e., | ||
6 | # just setting VARIABLE=n is not disabling that variable. | ||
7 | # | ||
8 | # This file is included in Makefile, so variables like CFLAGS and LIBS can also | ||
9 | # be modified from here. In most cass, these lines should use += in order not | ||
10 | # to override previous values of the variables. | ||
11 | |||
12 | # Driver interface for Host AP driver | ||
13 | CONFIG_DRIVER_HOSTAP=y | ||
14 | |||
15 | # Driver interface for wired authenticator | ||
16 | CONFIG_DRIVER_WIRED=y | ||
17 | |||
18 | # Driver interface for madwifi driver | ||
19 | #CONFIG_DRIVER_MADWIFI=y | ||
20 | #CFLAGS += -I../head # change to reflect local setup; directory for madwifi src | ||
21 | |||
22 | # Driver interface for Prism54 driver | ||
23 | CONFIG_DRIVER_PRISM54=y | ||
24 | |||
25 | # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver) | ||
26 | #CONFIG_DRIVER_BSD=y | ||
27 | #CFLAGS += -I/usr/local/include | ||
28 | #LIBS += -L/usr/local/lib | ||
29 | |||
30 | # IEEE 802.11F/IAPP | ||
31 | CONFIG_IAPP=y | ||
32 | |||
33 | # WPA2/IEEE 802.11i RSN pre-authentication | ||
34 | CONFIG_RSN_PREAUTH=y | ||
35 | |||
36 | # Integrated EAP authenticator | ||
37 | CONFIG_EAP=y | ||
38 | |||
39 | # EAP-MD5 for the integrated EAP authenticator | ||
40 | CONFIG_EAP_MD5=y | ||
41 | |||
42 | # EAP-TLS for the integrated EAP authenticator | ||
43 | CONFIG_EAP_TLS=y | ||
44 | |||
45 | # EAP-MSCHAPv2 for the integrated EAP authenticator | ||
46 | CONFIG_EAP_MSCHAPV2=y | ||
47 | |||
48 | # EAP-PEAP for the integrated EAP authenticator | ||
49 | CONFIG_EAP_PEAP=y | ||
50 | |||
51 | # EAP-GTC for the integrated EAP authenticator | ||
52 | CONFIG_EAP_GTC=y | ||
53 | |||
54 | # EAP-TTLS for the integrated EAP authenticator | ||
55 | CONFIG_EAP_TTLS=y | ||
56 | |||
57 | # EAP-SIM for the integrated EAP authenticator | ||
58 | #CONFIG_EAP_SIM=y | ||
59 | |||
60 | # PKCS#12 (PFX) support (used to read private key and certificate file from | ||
61 | # a file that usually has extension .p12 or .pfx) | ||
62 | CONFIG_PKCS12=y | ||
63 | |||
64 | # RADIUS authentication server. This provides access to the integrated EAP | ||
65 | # authenticator from external hosts using RADIUS. | ||
66 | CONFIG_RADIUS_SERVER=y | ||
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/init b/openembedded/packages/hostap/hostap-daemon-0.4.4/init deleted file mode 100644 index b0736c0baa..0000000000 --- a/openembedded/packages/hostap/hostap-daemon-0.4.4/init +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | DAEMON=/usr/sbin/hostapd | ||
3 | NAME=httpd | ||
4 | DESC="HOSTAP Daemon" | ||
5 | ARGS="/etc/hostapd.conf" | ||
6 | |||
7 | test -f $DAEMON || exit 0 | ||
8 | |||
9 | set -e | ||
10 | |||
11 | case "$1" in | ||
12 | start) | ||
13 | echo -n "starting $DESC: $NAME... " | ||
14 | start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS | ||
15 | echo "done." | ||
16 | ;; | ||
17 | stop) | ||
18 | echo -n "stopping $DESC: $NAME... " | ||
19 | start-stop-daemon -K -n $NAME | ||
20 | echo "done." | ||
21 | ;; | ||
22 | restart) | ||
23 | echo "restarting $DESC: $NAME... " | ||
24 | $0 stop | ||
25 | $0 start | ||
26 | echo "done." | ||
27 | ;; | ||
28 | reload) | ||
29 | echo -n "reloading $DESC: $NAME... " | ||
30 | killall -HUP $(basename ${DAEMON}) | ||
31 | echo "done." | ||
32 | ;; | ||
33 | *) | ||
34 | echo "Usage: $0 {start|stop|restart|reload}" | ||
35 | exit 1 | ||
36 | ;; | ||
37 | esac | ||
38 | |||
39 | exit 0 | ||
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff b/openembedded/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff deleted file mode 100644 index d9dab26a15..0000000000 --- a/openembedded/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | --- driver_madwifi.c.orig 2005-03-18 15:12:53.392793216 +0100 | ||
2 | +++ driver_madwifi.c 2005-03-18 15:13:09.246383104 +0100 | ||
3 | @@ -21,7 +21,8 @@ | ||
4 | #include <sys/types.h> | ||
5 | #include <sys/socket.h> | ||
6 | |||
7 | -#include <include/compat.h> | ||
8 | +#include <net80211/compat.h> | ||
9 | +#include <net80211/_ieee80211.h> | ||
10 | #include <net80211/ieee80211.h> | ||
11 | #include <net80211/ieee80211_crypto.h> | ||
12 | #include <net80211/ieee80211_ioctl.h> | ||
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff b/openembedded/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff deleted file mode 100644 index 25d2ca34bb..0000000000 --- a/openembedded/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | --- Makefile.orig 2005-03-18 14:34:27.274376504 +0100 | ||
2 | +++ Makefile 2005-03-18 14:35:56.609795456 +0100 | ||
3 | @@ -1,7 +1,9 @@ | ||
4 | -CC=gcc | ||
5 | +CC?=gcc | ||
6 | DIR_WPA_SUPPLICANT=. | ||
7 | DIR_HOSTAP=. | ||
8 | |||
9 | +TARGET_PREFIX ?= /usr/local/bin/ | ||
10 | + | ||
11 | ifndef CFLAGS | ||
12 | CFLAGS = -MMD -O2 -Wall -g | ||
13 | endif | ||
14 | @@ -170,10 +172,10 @@ | ||
15 | fi | ||
16 | |||
17 | install: all | ||
18 | - for i in $(ALL); do cp $$i /usr/local/bin/$$i; done | ||
19 | + for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done | ||
20 | |||
21 | hostapd: $(OBJS) | ||
22 | - $(CC) -o hostapd $(OBJS) $(LIBS) | ||
23 | + $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS) | ||
24 | |||
25 | driver_conf.c: Makefile .config | ||
26 | rm -f driver_conf.c | ||
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig b/openembedded/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig deleted file mode 100644 index 8c3065c3b9..0000000000 --- a/openembedded/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig +++ /dev/null | |||
@@ -1,66 +0,0 @@ | |||
1 | # Example hostapd build time configuration | ||
2 | # | ||
3 | # This file lists the configuration options that are used when building the | ||
4 | # hostapd binary. All lines starting with # are ignored. Configuration option | ||
5 | # lines must be commented out complete, if they are not to be included, i.e., | ||
6 | # just setting VARIABLE=n is not disabling that variable. | ||
7 | # | ||
8 | # This file is included in Makefile, so variables like CFLAGS and LIBS can also | ||
9 | # be modified from here. In most cass, these lines should use += in order not | ||
10 | # to override previous values of the variables. | ||
11 | |||
12 | # Driver interface for Host AP driver | ||
13 | CONFIG_DRIVER_HOSTAP=y | ||
14 | |||
15 | # Driver interface for wired authenticator | ||
16 | CONFIG_DRIVER_WIRED=y | ||
17 | |||
18 | # Driver interface for madwifi driver | ||
19 | CONFIG_DRIVER_MADWIFI=y | ||
20 | #CFLAGS += -I../head # change to reflect local setup; directory for madwifi src | ||
21 | |||
22 | # Driver interface for Prism54 driver | ||
23 | CONFIG_DRIVER_PRISM54=y | ||
24 | |||
25 | # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver) | ||
26 | #CONFIG_DRIVER_BSD=y | ||
27 | #CFLAGS += -I/usr/local/include | ||
28 | #LIBS += -L/usr/local/lib | ||
29 | |||
30 | # IEEE 802.11F/IAPP | ||
31 | CONFIG_IAPP=y | ||
32 | |||
33 | # WPA2/IEEE 802.11i RSN pre-authentication | ||
34 | CONFIG_RSN_PREAUTH=y | ||
35 | |||
36 | # Integrated EAP authenticator | ||
37 | CONFIG_EAP=y | ||
38 | |||
39 | # EAP-MD5 for the integrated EAP authenticator | ||
40 | CONFIG_EAP_MD5=y | ||
41 | |||
42 | # EAP-TLS for the integrated EAP authenticator | ||
43 | CONFIG_EAP_TLS=y | ||
44 | |||
45 | # EAP-MSCHAPv2 for the integrated EAP authenticator | ||
46 | CONFIG_EAP_MSCHAPV2=y | ||
47 | |||
48 | # EAP-PEAP for the integrated EAP authenticator | ||
49 | CONFIG_EAP_PEAP=y | ||
50 | |||
51 | # EAP-GTC for the integrated EAP authenticator | ||
52 | CONFIG_EAP_GTC=y | ||
53 | |||
54 | # EAP-TTLS for the integrated EAP authenticator | ||
55 | CONFIG_EAP_TTLS=y | ||
56 | |||
57 | # EAP-SIM for the integrated EAP authenticator | ||
58 | #CONFIG_EAP_SIM=y | ||
59 | |||
60 | # PKCS#12 (PFX) support (used to read private key and certificate file from | ||
61 | # a file that usually has extension .p12 or .pfx) | ||
62 | CONFIG_PKCS12=y | ||
63 | |||
64 | # RADIUS authentication server. This provides access to the integrated EAP | ||
65 | # authenticator from external hosts using RADIUS. | ||
66 | CONFIG_RADIUS_SERVER=y | ||
diff --git a/openembedded/packages/hostap/hostap-modules.inc b/openembedded/packages/hostap/hostap-modules.inc new file mode 100644 index 0000000000..72f2dc2da3 --- /dev/null +++ b/openembedded/packages/hostap/hostap-modules.inc | |||
@@ -0,0 +1,44 @@ | |||
1 | DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset" | ||
2 | SECTION = "kernel/modules" | ||
3 | PRIORITY = "optional" | ||
4 | MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>" | ||
5 | LICENSE = "GPL" | ||
6 | PROVIDES = "hostap-conf" | ||
7 | RPROVIDES = "virtual/kernel-hostap" | ||
8 | |||
9 | SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \ | ||
10 | file://hostap_cs.conf" | ||
11 | SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \ | ||
12 | file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0" | ||
13 | SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 " | ||
14 | |||
15 | S = "${WORKDIR}/hostap-driver-${PV}" | ||
16 | |||
17 | inherit module | ||
18 | |||
19 | # Hack Alert :D | ||
20 | ARCH_mipsel = "mips" | ||
21 | MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'" | ||
22 | |||
23 | NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep" | ||
24 | |||
25 | do_install() { | ||
26 | install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \ | ||
27 | ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \ | ||
28 | ${D}${sysconfdir}/pcmcia | ||
29 | for i in ${NET_MODULES} | ||
30 | do | ||
31 | install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/ | ||
32 | done | ||
33 | install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/ | ||
34 | install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf | ||
35 | cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf | ||
36 | } | ||
37 | |||
38 | PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules" | ||
39 | FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/" | ||
40 | FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}" | ||
41 | FILES_hostap-modules = "/lib/modules/" | ||
42 | RDEPENDS_hostap-modules-cs = "hostap-modules" | ||
43 | RDEPENDS_hostap-modules-pci = "hostap-modules" | ||
44 | RPROVIDES_hostap-modules-cs = "hostap-conf" | ||
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch b/openembedded/packages/hostap/hostap-modules/Makefile.patch index 2fc5e9ed4b..2fc5e9ed4b 100644 --- a/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch +++ b/openembedded/packages/hostap/hostap-modules/Makefile.patch | |||
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch b/openembedded/packages/hostap/hostap-modules/add_event.patch index d5f2a10e86..d5f2a10e86 100644 --- a/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch +++ b/openembedded/packages/hostap/hostap-modules/add_event.patch | |||
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch b/openembedded/packages/hostap/hostap-modules/hostap-utsname.patch index c29cc8d2c9..c29cc8d2c9 100644 --- a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch +++ b/openembedded/packages/hostap/hostap-modules/hostap-utsname.patch | |||
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch b/openembedded/packages/hostap/hostap-modules/hostap_cardid.patch index 05f716e22f..05f716e22f 100644 --- a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch +++ b/openembedded/packages/hostap/hostap-modules/hostap_cardid.patch | |||
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch b/openembedded/packages/hostap/hostap-modules/ipaq_compat.patch index b139ef38f1..b139ef38f1 100644 --- a/openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch +++ b/openembedded/packages/hostap/hostap-modules/ipaq_compat.patch | |||
diff --git a/openembedded/packages/hostap/hostap-modules/kernel_updates.patch b/openembedded/packages/hostap/hostap-modules/kernel_updates.patch new file mode 100644 index 0000000000..70487a96f8 --- /dev/null +++ b/openembedded/packages/hostap/hostap-modules/kernel_updates.patch | |||
@@ -0,0 +1,192 @@ | |||
1 | Index: hostap-driver-0.4.4/driver/modules/hostap_cs.c | ||
2 | =================================================================== | ||
3 | --- hostap-driver-0.4.4.orig/driver/modules/hostap_cs.c 2005-08-21 20:23:21.000000000 +0100 | ||
4 | +++ hostap-driver-0.4.4/driver/modules/hostap_cs.c 2005-09-17 17:09:05.000000000 +0100 | ||
5 | @@ -207,12 +207,17 @@ | ||
6 | #include "hostap_hw.c" | ||
7 | |||
8 | |||
9 | - | ||
10 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
11 | static void prism2_detach(dev_link_t *link); | ||
12 | +#else | ||
13 | +static void prism2_detach(struct pcmcia_device *p_dev); | ||
14 | +#endif | ||
15 | + | ||
16 | static void prism2_release(u_long arg); | ||
17 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
18 | static int prism2_event(event_t event, int priority, | ||
19 | event_callback_args_t *args); | ||
20 | - | ||
21 | +#endif | ||
22 | |||
23 | static int prism2_pccard_card_present(local_info_t *local) | ||
24 | { | ||
25 | @@ -508,25 +513,36 @@ | ||
26 | } | ||
27 | #endif | ||
28 | |||
29 | +static int prism2_config(dev_link_t *link); | ||
30 | |||
31 | /* allocate local data and register with CardServices | ||
32 | * initialize dev_link structure, but do not configure the card yet */ | ||
33 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
34 | static dev_link_t *prism2_attach(void) | ||
35 | +#else | ||
36 | +static int prism2_attach(struct pcmcia_device *p_dev) | ||
37 | +#endif | ||
38 | { | ||
39 | dev_link_t *link; | ||
40 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
41 | client_reg_t client_reg; | ||
42 | int ret; | ||
43 | +#endif | ||
44 | |||
45 | link = kmalloc(sizeof(dev_link_t), GFP_KERNEL); | ||
46 | if (link == NULL) | ||
47 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
48 | return NULL; | ||
49 | - | ||
50 | +#else | ||
51 | + return -ENOMEM; | ||
52 | +#endif | ||
53 | memset(link, 0, sizeof(dev_link_t)); | ||
54 | |||
55 | PDEBUG(DEBUG_HW, "%s: setting Vcc=33 (constant)\n", dev_info); | ||
56 | link->conf.Vcc = 33; | ||
57 | link->conf.IntType = INT_MEMORY_AND_IO; | ||
58 | |||
59 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
60 | /* register with CardServices */ | ||
61 | link->next = dev_list; | ||
62 | dev_list = link; | ||
63 | @@ -547,12 +563,28 @@ | ||
64 | prism2_detach(link); | ||
65 | return NULL; | ||
66 | } | ||
67 | + | ||
68 | return link; | ||
69 | -} | ||
70 | +#else | ||
71 | + link->handle = p_dev; | ||
72 | + p_dev->instance = link; | ||
73 | + | ||
74 | + link->state |= DEV_PRESENT | DEV_CONFIG_PENDING; | ||
75 | + prism2_config(link); | ||
76 | |||
77 | + return 0; | ||
78 | +#endif | ||
79 | +} | ||
80 | |||
81 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
82 | static void prism2_detach(dev_link_t *link) | ||
83 | +#else | ||
84 | +static void prism2_detach(struct pcmcia_device *p_dev) | ||
85 | +#endif | ||
86 | { | ||
87 | +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15)) | ||
88 | + dev_link_t *link = dev_to_instance(p_dev); | ||
89 | +#endif | ||
90 | dev_link_t **linkp; | ||
91 | |||
92 | PDEBUG(DEBUG_FLOW, "prism2_detach\n"); | ||
93 | @@ -570,6 +602,7 @@ | ||
94 | prism2_release((u_long)link); | ||
95 | } | ||
96 | |||
97 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
98 | if (link->handle) { | ||
99 | int res = pcmcia_deregister_client(link->handle); | ||
100 | if (res) { | ||
101 | @@ -577,6 +610,7 @@ | ||
102 | cs_error(link->handle, DeregisterClient, res); | ||
103 | } | ||
104 | } | ||
105 | +#endif | ||
106 | |||
107 | *linkp = link->next; | ||
108 | /* release net devices */ | ||
109 | @@ -855,7 +889,53 @@ | ||
110 | PDEBUG(DEBUG_FLOW, "release - done\n"); | ||
111 | } | ||
112 | |||
113 | +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15)) | ||
114 | +static int prism2_suspend1(struct pcmcia_device *dev) | ||
115 | +{ | ||
116 | + dev_link_t *link = dev_to_instance(dev); | ||
117 | + struct net_device *ndev = (struct net_device *) link->priv; | ||
118 | + | ||
119 | + PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_SUSPEND\n", dev_info); | ||
120 | + link->state |= DEV_SUSPEND; | ||
121 | + /* fall through */ | ||
122 | |||
123 | + if (link->state & DEV_CONFIG) { | ||
124 | + if (link->open) { | ||
125 | + netif_stop_queue(ndev); | ||
126 | + netif_device_detach(ndev); | ||
127 | + } | ||
128 | + prism2_suspend(ndev); | ||
129 | + pcmcia_release_configuration(link->handle); | ||
130 | + } | ||
131 | + | ||
132 | + return 0; | ||
133 | +} | ||
134 | + | ||
135 | +static int prism2_resume1(struct pcmcia_device *dev) | ||
136 | +{ | ||
137 | + dev_link_t *link = dev_to_instance(dev); | ||
138 | + struct net_device *ndev = (struct net_device *) link->priv; | ||
139 | + | ||
140 | + PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_RESUME\n", dev_info); | ||
141 | + | ||
142 | + link->state &= ~DEV_SUSPEND; | ||
143 | + /* fall through */ | ||
144 | + | ||
145 | + if (link->state & DEV_CONFIG) { | ||
146 | + pcmcia_request_configuration(link->handle, &link->conf); | ||
147 | + prism2_hw_shutdown(ndev, 1); | ||
148 | + prism2_hw_config(ndev, link->open ? 0 : 1); | ||
149 | + if (link->open) { | ||
150 | + netif_device_attach(ndev); | ||
151 | + netif_start_queue(ndev); | ||
152 | + } | ||
153 | + } | ||
154 | + | ||
155 | + return 0; | ||
156 | +} | ||
157 | +#endif | ||
158 | + | ||
159 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
160 | static int prism2_event(event_t event, int priority, | ||
161 | event_callback_args_t *args) | ||
162 | { | ||
163 | @@ -924,7 +1004,7 @@ | ||
164 | } | ||
165 | return 0; | ||
166 | } | ||
167 | - | ||
168 | +#endif | ||
169 | |||
170 | #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67) | ||
171 | #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13)) | ||
172 | @@ -983,11 +1063,20 @@ | ||
173 | .drv = { | ||
174 | .name = "hostap_cs", | ||
175 | }, | ||
176 | +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15)) | ||
177 | + .probe = prism2_attach, | ||
178 | + .remove = prism2_detach, | ||
179 | + .suspend = prism2_suspend1, | ||
180 | + .resume = prism2_resume1, | ||
181 | +#else | ||
182 | .attach = prism2_attach, | ||
183 | .detach = prism2_detach, | ||
184 | +#endif | ||
185 | .owner = THIS_MODULE, | ||
186 | #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13)) | ||
187 | +#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15)) | ||
188 | .event = prism2_event, | ||
189 | +#endif | ||
190 | .id_table = hostap_cs_ids, | ||
191 | #endif | ||
192 | }; | ||
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff b/openembedded/packages/hostap/hostap-modules/mtx_compat.diff index c2d6662d69..c2d6662d69 100644 --- a/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff +++ b/openembedded/packages/hostap/hostap-modules/mtx_compat.diff | |||
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff b/openembedded/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff index e979b72d93..e979b72d93 100644 --- a/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff +++ b/openembedded/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff | |||
diff --git a/openembedded/packages/hostap/hostap-modules_0.3.9.bb b/openembedded/packages/hostap/hostap-modules_0.3.9.bb index 940b23863b..508c653230 100644 --- a/openembedded/packages/hostap/hostap-modules_0.3.9.bb +++ b/openembedded/packages/hostap/hostap-modules_0.3.9.bb | |||
@@ -1,48 +1,7 @@ | |||
1 | DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset" | 1 | include hostap-modules.inc |
2 | SECTION = "kernel/modules" | 2 | PR = "r9" |
3 | PRIORITY = "optional" | ||
4 | MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>" | ||
5 | LICENSE = "GPL" | ||
6 | PROVIDES = "virtual/kernel-hostap hostap-conf" | ||
7 | PR = "r8" | ||
8 | 3 | ||
9 | SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \ | 4 | SRC_URI += "file://Makefile.patch;patch=1 \ |
10 | file://hostap_cs.conf \ | 5 | file://add_event.patch;patch=1 \ |
11 | file://Makefile.patch;patch=1 \ | 6 | file://hostap-utsname.patch;patch=1 \ |
12 | file://add_event.patch;patch=1 \ | 7 | file://hostap_cardid.patch;patch=1" |
13 | file://hostap-utsname.patch;patch=1 \ | ||
14 | file://hostap_cardid.patch;patch=1" | ||
15 | SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \ | ||
16 | file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0" | ||
17 | SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 " | ||
18 | |||
19 | S = "${WORKDIR}/hostap-driver-${PV}" | ||
20 | |||
21 | inherit module | ||
22 | |||
23 | # Hack Alert :D | ||
24 | ARCH_mipsel = "mips" | ||
25 | MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'" | ||
26 | |||
27 | NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep" | ||
28 | |||
29 | do_install() { | ||
30 | install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \ | ||
31 | ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \ | ||
32 | ${D}${sysconfdir}/pcmcia | ||
33 | for i in ${NET_MODULES} | ||
34 | do | ||
35 | install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/ | ||
36 | done | ||
37 | install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/ | ||
38 | install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf | ||
39 | cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf | ||
40 | } | ||
41 | |||
42 | PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules" | ||
43 | FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/" | ||
44 | FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}" | ||
45 | FILES_hostap-modules = "/lib/modules/" | ||
46 | RDEPENDS_hostap-modules-cs = "hostap-modules" | ||
47 | RDEPENDS_hostap-modules-pci = "hostap-modules" | ||
48 | RPROVIDES_hostap-modules-cs = "hostap-conf" | ||
diff --git a/openembedded/packages/hostap/hostap-utils.inc b/openembedded/packages/hostap/hostap-utils.inc new file mode 100644 index 0000000000..c5c5d5b3f9 --- /dev/null +++ b/openembedded/packages/hostap/hostap-utils.inc | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "User mode helpers for the hostap driver" | ||
2 | HOMEPAGE = "http://hostap.epitest.fi" | ||
3 | SECTION = "kernel/userland" | ||
4 | PRIORITY = "optional" | ||
5 | MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>" | ||
6 | LICENSE = "GPL" | ||
7 | RRECOMMENDS = "virtual/kernel-hostap" | ||
8 | PR = "r3" | ||
9 | |||
10 | SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \ | ||
11 | file://hostap-fw-load.patch;patch=1" | ||
12 | S = "${WORKDIR}/hostap-utils-${PV}" | ||
13 | |||
14 | BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \ | ||
15 | hostap_rid prism2_param prism2_srec split_combined_hex" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${sbindir}/ | ||
19 | for f in ${BINARIES} | ||
20 | do | ||
21 | install -m 0755 $f ${D}${sbindir}/ | ||
22 | done | ||
23 | } | ||
24 | |||
diff --git a/openembedded/packages/hostap/hostap-utils_0.3.7.bb b/openembedded/packages/hostap/hostap-utils_0.3.7.bb index cdfb0c1e3e..ad06cd3d6d 100644 --- a/openembedded/packages/hostap/hostap-utils_0.3.7.bb +++ b/openembedded/packages/hostap/hostap-utils_0.3.7.bb | |||
@@ -1,24 +1,3 @@ | |||
1 | DESCRIPTION = "User mode helpers for the hostap driver" | 1 | include hostap-utils.inc |
2 | HOMEPAGE = "http://hostap.epitest.fi" | ||
3 | SECTION = "kernel/userland" | ||
4 | PRIORITY = "optional" | ||
5 | MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>" | ||
6 | LICENSE = "GPL" | ||
7 | RDEPENDS = "virtual/kernel-hostap" | ||
8 | PR = "r2" | ||
9 | |||
10 | SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \ | ||
11 | file://hostap-fw-load.patch;patch=1" | ||
12 | S = "${WORKDIR}/hostap-utils-${PV}" | ||
13 | |||
14 | BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \ | ||
15 | hostap_rid prism2_param prism2_srec split_combined_hex" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${sbindir}/ | ||
19 | for f in ${BINARIES} | ||
20 | do | ||
21 | install -m 0755 $f ${D}${sbindir}/ | ||
22 | done | ||
23 | } | ||
24 | 2 | ||
3 | PR = "r3" | ||
diff --git a/openembedded/packages/hostap/hostap-utils_0.4.0.bb b/openembedded/packages/hostap/hostap-utils_0.4.0.bb index 98254602aa..ad06cd3d6d 100644 --- a/openembedded/packages/hostap/hostap-utils_0.4.0.bb +++ b/openembedded/packages/hostap/hostap-utils_0.4.0.bb | |||
@@ -1,25 +1,3 @@ | |||
1 | DESCRIPTION = "User mode helpers for the hostap driver" | 1 | include hostap-utils.inc |
2 | HOMEPAGE = "http://hostap.epitest.fi" | ||
3 | SECTION = "kernel/userland" | ||
4 | PRIORITY = "optional" | ||
5 | MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>" | ||
6 | LICENSE = "GPL" | ||
7 | DEPENDS = "virtual/kernel-hostap" | ||
8 | RRECOMMENDS = "virtual/kernel-hostap" | ||
9 | PR = "r3" | ||
10 | |||
11 | SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \ | ||
12 | file://hostap-fw-load.patch;patch=1" | ||
13 | S = "${WORKDIR}/hostap-utils-${PV}" | ||
14 | |||
15 | BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \ | ||
16 | hostap_rid prism2_param prism2_srec split_combined_hex" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${sbindir}/ | ||
20 | for f in ${BINARIES} | ||
21 | do | ||
22 | install -m 0755 $f ${D}${sbindir}/ | ||
23 | done | ||
24 | } | ||
25 | 2 | ||
3 | PR = "r3" | ||