summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/zip/zip_2.31.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-30 14:28:18 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-30 14:28:18 +0000
commitb86b4ae5db5c0fbfecb85584f486a17ec0b46437 (patch)
tree51f20ee7f13090389d69cb60110ab403f27b0d8f /openembedded/packages/zip/zip_2.31.bb
parent06b04dcace4eb99f565b8959d5b7ba1a4ae7f00a (diff)
downloadpoky-b86b4ae5db5c0fbfecb85584f486a17ec0b46437.tar.gz
Add minimo (+ deps: zip, libxi). Update puzzzles to include icon. Update meta packages with new programs.
git-svn-id: https://svn.o-hand.com/repos/poky@86 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/zip/zip_2.31.bb')
-rw-r--r--openembedded/packages/zip/zip_2.31.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/openembedded/packages/zip/zip_2.31.bb b/openembedded/packages/zip/zip_2.31.bb
new file mode 100644
index 0000000000..6c588a55e5
--- /dev/null
+++ b/openembedded/packages/zip/zip_2.31.bb
@@ -0,0 +1,17 @@
1SECTION = "console/utils"
2SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip231.tar.gz"
3LICENSE = "Info-ZIP"
4EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
5 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
6 'BINFLAGS=0755' 'INSTALL_D=install -d'"
7
8do_compile() {
9 oe_runmake -f unix/Makefile generic
10}
11
12do_install() {
13 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
14 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
15 install
16}
17