diff options
author | Richard Purdie <richard@openedhand.com> | 2006-02-05 13:41:24 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-02-05 13:41:24 +0000 |
commit | f4881f39508046ffca4a2aa0196d1ae4e4bd40e5 (patch) | |
tree | b403d9a43aaa1dcd1fffc91e0ad7ca288c44d9a6 /openembedded/packages/udev | |
parent | 6753d5b6e71973a6c08610ab583f81fd0ed47b58 (diff) | |
download | poky-f4881f39508046ffca4a2aa0196d1ae4e4bd40e5.tar.gz |
udev 084: Fix the firmware_helper path
git-svn-id: https://svn.o-hand.com/repos/poky@249 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/udev')
-rw-r--r-- | openembedded/packages/udev/udev-084/udev.rules | 98 | ||||
-rw-r--r-- | openembedded/packages/udev/udev_084.bb | 4 |
2 files changed, 99 insertions, 3 deletions
diff --git a/openembedded/packages/udev/udev-084/udev.rules b/openembedded/packages/udev/udev-084/udev.rules new file mode 100644 index 0000000000..b3a19cefc8 --- /dev/null +++ b/openembedded/packages/udev/udev-084/udev.rules | |||
@@ -0,0 +1,98 @@ | |||
1 | # There are a number of modifiers that are allowed to be used in some | ||
2 | # of the different fields. They provide the following subsitutions: | ||
3 | # | ||
4 | # %n the "kernel number" of the device. | ||
5 | # For example, 'sda3' has a "kernel number" of '3' | ||
6 | # %e the smallest number for that name which does not matches an existing node | ||
7 | # %k the kernel name for the device | ||
8 | # %M the kernel major number for the device | ||
9 | # %m the kernel minor number for the device | ||
10 | # %b the bus id for the device | ||
11 | # %c the string returned by the PROGRAM | ||
12 | # %s{filename} the content of a sysfs attribute | ||
13 | # %% the '%' char itself | ||
14 | # | ||
15 | |||
16 | # SCSI devices | ||
17 | BUS=="scsi", KERNEL=="sr[0-9]*", NAME="scd%n", SYMLINK+="sr%n" | ||
18 | |||
19 | # USB devices | ||
20 | BUS=="usb", KERNEL=="auer[0-9]*", NAME="usb/%k" | ||
21 | BUS=="usb", KERNEL=="cpad[0-9]*", NAME="usb/%k" | ||
22 | BUS=="usb", KERNEL=="dabusb*", NAME="usb/%k" | ||
23 | BUS=="usb", KERNEL=="hiddev*", NAME="usb/%k" | ||
24 | BUS=="usb", KERNEL=="legousbtower*", NAME="usb/%k" | ||
25 | BUS=="usb", KERNEL=="lp[0-9]*", NAME="usb/%k" | ||
26 | BUS=="usb", KERNEL=="ttyUSB*", SYSFS{product}=="Palm Handheld*", \ | ||
27 | SYMLINK+="pilot" | ||
28 | |||
29 | # usbfs-like devices | ||
30 | SUBSYSTEM=="usb_device", \ | ||
31 | PROGRAM="/bin/sh -c 'X=%k X=$${X#usbdev} B=$${X%%%%.*} D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c" | ||
32 | |||
33 | # serial devices | ||
34 | KERNEL=="capi", NAME="capi20", SYMLINK+="isdn/capi20" | ||
35 | KERNEL=="capi[0-9]*", NAME="capi/%n" | ||
36 | |||
37 | # video devices | ||
38 | KERNEL=="card[0-9]*", NAME="dri/%k" | ||
39 | |||
40 | # misc devices | ||
41 | KERNEL=="hw_random", NAME="hwrng" | ||
42 | KERNEL=="tun", NAME="net/%k" | ||
43 | |||
44 | KERNEL=="cdemu[0-9]*", NAME="cdemu/%n" | ||
45 | KERNEL=="pktcdvd[0-9]*", NAME="pktcdvd/%n" | ||
46 | KERNEL=="pktcdvd", NAME="pktcdvd/control" | ||
47 | |||
48 | KERNEL=="cpu[0-9]*", NAME="cpu/%n/cpuid" | ||
49 | KERNEL=="msr[0-9]*", NAME="cpu/%n/msr" | ||
50 | KERNEL=="microcode", NAME="cpu/microcode" | ||
51 | |||
52 | KERNEL=="umad*", NAME="infiniband/%k" | ||
53 | KERNEL=="issm*", NAME="infiniband/%k" | ||
54 | KERNEL=="uverbs*", NAME="infiniband/%k" | ||
55 | KERNEL=="ucm", NAME="infiniband/%k" | ||
56 | |||
57 | KERNEL=="buzzer", NAME="misc/buzzer" | ||
58 | |||
59 | # ALSA devices | ||
60 | KERNEL=="controlC[0-9]*", NAME="snd/%k" | ||
61 | KERNEL=="hwC[D0-9]*", NAME="snd/%k" | ||
62 | KERNEL=="pcmC[D0-9cp]*", NAME="snd/%k" | ||
63 | KERNEL=="midiC[D0-9]*", NAME="snd/%k" | ||
64 | KERNEL=="timer", NAME="snd/%k" | ||
65 | KERNEL=="seq", NAME="snd/%k" | ||
66 | |||
67 | # ieee1394 devices | ||
68 | KERNEL=="dv1394*", NAME="dv1394/%n" | ||
69 | KERNEL=="video1394*", NAME="video1394/%n" | ||
70 | |||
71 | # input devices | ||
72 | KERNEL=="mice", NAME="input/%k" | ||
73 | KERNEL=="mouse[0-9]*", NAME="input/%k" | ||
74 | KERNEL=="event[0-9]*", NAME="input/%k" | ||
75 | KERNEL=="js[0-9]*", NAME="input/%k" | ||
76 | KERNEL=="ts[0-9]*", NAME="input/%k" | ||
77 | KERNEL=="uinput", NAME="input/%k" | ||
78 | |||
79 | # Zaptel | ||
80 | KERNEL=="zapctl", NAME="zap/ctl" | ||
81 | KERNEL=="zaptimer", NAME="zap/timer" | ||
82 | KERNEL=="zapchannel", NAME="zap/channel" | ||
83 | KERNEL=="zappseudo", NAME="zap/pseudo" | ||
84 | KERNEL=="zap[0-9]*", NAME="zap/%n" | ||
85 | |||
86 | # AOE character devices | ||
87 | SUBSYSTEM=="aoe", KERNEL=="discover", NAME="etherd/%k" | ||
88 | SUBSYSTEM=="aoe", KERNEL=="err", NAME="etherd/%k" | ||
89 | SUBSYSTEM=="aoe", KERNEL=="interfaces", NAME="etherd/%k" | ||
90 | |||
91 | # device mapper creates its own device nodes, so ignore these | ||
92 | KERNEL=="dm-[0-9]*", OPTIONS+="ignore_device" | ||
93 | KERNEL=="device-mapper", NAME="mapper/control" | ||
94 | |||
95 | KERNEL="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660" | ||
96 | |||
97 | # Firmware Helper | ||
98 | ACTION=="add", SUBSYSTEM=="firmware", RUN+="/usr/lib/udev/firmware_helper" | ||
diff --git a/openembedded/packages/udev/udev_084.bb b/openembedded/packages/udev/udev_084.bb index d4bdb13382..b5bf464250 100644 --- a/openembedded/packages/udev/udev_084.bb +++ b/openembedded/packages/udev/udev_084.bb | |||
@@ -1,5 +1,3 @@ | |||
1 | DEFAULT_PREFERENCE = "-1" | ||
2 | |||
3 | DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \ | 1 | DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \ |
4 | /dev/, handles hotplug events and loads drivers at boot time. It replaces \ | 2 | /dev/, handles hotplug events and loads drivers at boot time. It replaces \ |
5 | the hotplug package and requires a kernel not older than 2.6.12." | 3 | the hotplug package and requires a kernel not older than 2.6.12." |
@@ -15,7 +13,7 @@ include udev.inc | |||
15 | 13 | ||
16 | INITSCRIPT_PARAMS = "start 03 S . start 55 0 6 ." | 14 | INITSCRIPT_PARAMS = "start 03 S . start 55 0 6 ." |
17 | 15 | ||
18 | PR = "r0" | 16 | PR = "r1" |
19 | 17 | ||
20 | UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/" | 18 | UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/" |
21 | 19 | ||