diff options
author | Richard Purdie <richard@openedhand.com> | 2006-02-03 09:02:41 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-02-03 09:02:41 +0000 |
commit | 4a64818533733e194138a45656aaf14d5a123e98 (patch) | |
tree | 79925075659d01f3b148e4267138ee6e8de91789 /openembedded/packages/udev/udev_084.bb | |
parent | bc4e7ed8993d3f598e5c03b78838bbc6199413ba (diff) | |
download | poky-4a64818533733e194138a45656aaf14d5a123e98.tar.gz |
Update to udev 084 from OE. This adds a coldplug script to emulate the calls necessary to load devices already inserted into the system at boot. It also adds a network interface control script.
git-svn-id: https://svn.o-hand.com/repos/poky@247 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/udev/udev_084.bb')
-rw-r--r-- | openembedded/packages/udev/udev_084.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/openembedded/packages/udev/udev_084.bb b/openembedded/packages/udev/udev_084.bb new file mode 100644 index 0000000000..d4bdb13382 --- /dev/null +++ b/openembedded/packages/udev/udev_084.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | DEFAULT_PREFERENCE = "-1" | ||
2 | |||
3 | DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \ | ||
4 | /dev/, handles hotplug events and loads drivers at boot time. It replaces \ | ||
5 | the hotplug package and requires a kernel not older than 2.6.12." | ||
6 | RPROVIDES = "hotplug" | ||
7 | |||
8 | SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \ | ||
9 | file://noasmlinkage.patch;patch=1 \ | ||
10 | file://flags.patch;patch=1 \ | ||
11 | file://udevsynthesize.patch;patch=1 \ | ||
12 | file://udevsynthesize.sh" | ||
13 | |||
14 | include udev.inc | ||
15 | |||
16 | INITSCRIPT_PARAMS = "start 03 S . start 55 0 6 ." | ||
17 | |||
18 | PR = "r0" | ||
19 | |||
20 | UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/" | ||
21 | |||
22 | do_install () { | ||
23 | install -d ${D}${usrsbindir} \ | ||
24 | ${D}${sbindir} | ||
25 | oe_runmake 'DESTDIR=${D}' INSTALL=install install | ||
26 | install -d ${D}${sysconfdir}/init.d | ||
27 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev | ||
28 | |||
29 | install -d ${D}${sysconfdir}/udev/rules.d/ | ||
30 | |||
31 | install -m 0644 ${WORKDIR}/local.rules ${D}${sysconfdir}/udev/rules.d/local.rules | ||
32 | install -m 0644 ${WORKDIR}/permissions.rules ${D}${sysconfdir}/udev/rules.d/permissions.rules | ||
33 | install -m 0644 ${WORKDIR}/udev.rules ${D}${sysconfdir}/udev/rules.d/udev.rules | ||
34 | if [ "${UDEV_DEVFS_RULES}" = "1" ]; then | ||
35 | install -m 0644 ${WORKDIR}/devfs-udev.rules ${D}${sysconfdir}/udev/rules.d/devfs-udev.rules | ||
36 | fi | ||
37 | |||
38 | install -d ${D}${sysconfdir}/udev/scripts/ | ||
39 | |||
40 | install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh | ||
41 | install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts | ||
42 | |||
43 | install -d ${D}${base_libdir}/udev/ | ||
44 | install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize | ||
45 | install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize | ||
46 | } | ||