summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/readline/readline_4.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-27 09:46:17 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-27 09:46:17 +0000
commit607b12a07ca910916aa50b0d66d3852785edcd99 (patch)
tree5584ce8247de739f939d1d77765b04efe905e7ec /openembedded/packages/readline/readline_4.3.bb
parent4a6c9c2ca185c81cc2617a8d7ec7f02eb8eb1a4c (diff)
downloadpoky-607b12a07ca910916aa50b0d66d3852785edcd99.tar.gz
Add strace, gdb and readline. Update meta-oh.bb to match this.
git-svn-id: https://svn.o-hand.com/repos/poky@38 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/readline/readline_4.3.bb')
-rw-r--r--openembedded/packages/readline/readline_4.3.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/openembedded/packages/readline/readline_4.3.bb b/openembedded/packages/readline/readline_4.3.bb
new file mode 100644
index 0000000000..234d697dfb
--- /dev/null
+++ b/openembedded/packages/readline/readline_4.3.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
3additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
4lines, and perform csh-like history expansion on previous commands."
5SECTION = "libs"
6PRIORITY = "optional"
7MAINTAINER = "Greg Gilbert <greg@treke.net>"
8LICENSE = "GPLv2"
9DEPENDS += "ncurses"
10RPROVIDES_${PN} += "readline"
11LEAD_SONAME = "libreadline.so"
12PR = "r2"
13
14SRC_URI = "ftp://ftp.cwru.edu/pub/bash/readline-${PV}.tar.gz \
15 file://shlink-termcap.patch;patch=1 \
16 file://acinclude.m4"
17S = "${WORKDIR}/readline-${PV}"
18
19inherit autotools
20
21do_configure () {
22 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
23 autotools_do_configure
24}
25
26do_install () {
27 autotools_do_install
28 # Make install doesn't properly install these
29 oe_libinstall -so -C shlib libhistory ${D}${libdir}
30 oe_libinstall -so -C shlib libreadline ${D}${libdir}
31}
32
33do_stage() {
34 oe_libinstall -a libhistory ${STAGING_LIBDIR}
35 oe_libinstall -a libreadline ${STAGING_LIBDIR}
36 oe_libinstall -so -C shlib libhistory ${STAGING_LIBDIR}
37 oe_libinstall -so -C shlib libreadline ${STAGING_LIBDIR}
38
39 install -d ${STAGING_INCDIR}/readline
40 for f in readline.h chardefs.h keymaps.h history.h tilde.h rlstdc.h \
41 rlconf.h rltypedefs.h
42 do
43 install -m 0644 $f ${STAGING_INCDIR}/readline/
44 done
45
46}