summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/perl
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-05-09 18:38:19 +0000
committerRichard Purdie <richard@openedhand.com>2006-05-09 18:38:19 +0000
commitb4cb437c6595ff8ac13506e502fe04b1a60c4e04 (patch)
treef529de217094f1a49049f90c49d779a49e19cd7c /openembedded/packages/perl
parent3baacb49c13a48798d45e30a0a0076ca0b8c9e6a (diff)
downloadpoky-b4cb437c6595ff8ac13506e502fe04b1a60c4e04.tar.gz
Merge packages changes from OE into poky.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@386 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/perl')
-rw-r--r--openembedded/packages/perl/perl-native_5.8.7.bb6
-rw-r--r--openembedded/packages/perl/perl.inc3
-rw-r--r--openembedded/packages/perl/perl_5.8.7.bb4
3 files changed, 9 insertions, 4 deletions
diff --git a/openembedded/packages/perl/perl-native_5.8.7.bb b/openembedded/packages/perl/perl-native_5.8.7.bb
index cc2b7fc5b1..170a0ebf8d 100644
--- a/openembedded/packages/perl/perl-native_5.8.7.bb
+++ b/openembedded/packages/perl/perl-native_5.8.7.bb
@@ -2,13 +2,15 @@ DESCRIPTION = "Perl is a popular scripting language."
2MAINTAINER="David Karlstrom <daka@thg.se>" 2MAINTAINER="David Karlstrom <daka@thg.se>"
3HOMEPAGE = "http://www.perl.org/" 3HOMEPAGE = "http://www.perl.org/"
4LICENSE = "Artistic|GPL" 4LICENSE = "Artistic|GPL"
5PR = "r1"
5 6
6SECTION = "libs" 7SECTION = "libs"
7inherit native 8inherit native
8 9
9DEPENDS = "db3-native gdbm-native" 10DEPENDS = "virtual/db-native gdbm-native"
10 11
11SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz" 12SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
13 file://Configure-multilib.patch;patch=1"
12S = "${WORKDIR}/perl-${PV}" 14S = "${WORKDIR}/perl-${PV}"
13 15
14#perl is not parallel_make safe 16#perl is not parallel_make safe
diff --git a/openembedded/packages/perl/perl.inc b/openembedded/packages/perl/perl.inc
index 12fffa1c33..52418903a2 100644
--- a/openembedded/packages/perl/perl.inc
+++ b/openembedded/packages/perl/perl.inc
@@ -5,7 +5,7 @@ SECTION = "devel"
5PRIORITY = "optional" 5PRIORITY = "optional"
6DEPENDS = "virtual/db perl-native" 6DEPENDS = "virtual/db perl-native"
7 7
8SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \ 8SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
9 file://Makefile.patch;patch=1 \ 9 file://Makefile.patch;patch=1 \
10 file://config.sh-arm-linux.patch;patch=1 \ 10 file://config.sh-arm-linux.patch;patch=1 \
11 file://libperl-5.8.3-create-libperl-soname.patch;patch=1;pnum=0 \ 11 file://libperl-5.8.3-create-libperl-soname.patch;patch=1;pnum=0 \
@@ -39,6 +39,7 @@ do_configure() {
39} 39}
40 40
41do_compile() { 41do_compile() {
42 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
42 cd Cross 43 cd Cross
43 oe_runmake perl 44 oe_runmake perl
44} 45}
diff --git a/openembedded/packages/perl/perl_5.8.7.bb b/openembedded/packages/perl/perl_5.8.7.bb
index a960439ad2..456cc95c84 100644
--- a/openembedded/packages/perl/perl_5.8.7.bb
+++ b/openembedded/packages/perl/perl_5.8.7.bb
@@ -6,7 +6,7 @@ SRC_URI += "file://config.sh-armeb-linux \
6 file://config.sh-arm-linux \ 6 file://config.sh-arm-linux \
7 file://config.sh-i386-linux" 7 file://config.sh-i386-linux"
8 8
9PR = "r14" 9PR = "r15"
10 10
11do_configure() { 11do_configure() {
12 ln -sf ${HOSTPERL} ${STAGING_BINDIR}/hostperl 12 ln -sf ${HOSTPERL} ${STAGING_BINDIR}/hostperl
@@ -18,6 +18,8 @@ do_configure() {
18 cp ${WORKDIR}/config.sh-i686-linux . 18 cp ${WORKDIR}/config.sh-i686-linux .
19 cp ${WORKDIR}/config.sh-i386-linux . 19 cp ${WORKDIR}/config.sh-i386-linux .
20 cp ${WORKDIR}/config.sh-armeb-linux . 20 cp ${WORKDIR}/config.sh-armeb-linux .
21 #perl insists on an extra config.sh for arm EABI
22 cp config.sh-arm-linux config.sh-arm-linux-gnueabi
21 # nslu2 LE uclibc builds do not work with the default config.sh 23 # nslu2 LE uclibc builds do not work with the default config.sh
22 if test "${MACHINE}" = nslu2 24 if test "${MACHINE}" = nslu2
23 then 25 then