summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/pcmciautils
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-20 15:19:38 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-20 15:19:38 +0000
commit8d66edc4085db428e67223f0f71cde6b3640f27e (patch)
treeda9dcd13d59b36f7350d3938f9094cb2ecc4449a /openembedded/packages/pcmciautils
parentb4a7122cacef647dbec3db5c9ebe1e504a7670df (diff)
downloadpoky-8d66edc4085db428e67223f0f71cde6b3640f27e.tar.gz
pcmciautils and udev updates. Slowly aiming to get rid of hotplug and pcmcia-cs
git-svn-id: https://svn.o-hand.com/repos/poky@27 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/pcmciautils')
-rw-r--r--openembedded/packages/pcmciautils/pcmciautils_010.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/openembedded/packages/pcmciautils/pcmciautils_010.bb b/openembedded/packages/pcmciautils/pcmciautils_010.bb
new file mode 100644
index 0000000000..f619a98235
--- /dev/null
+++ b/openembedded/packages/pcmciautils/pcmciautils_010.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
2DEPENDS = "sysfsutils udev"
3RDEPENDS = "udev"
4HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
5SECTION = "kernel/userland"
6PRIORITY = "optional"
7
8SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2"
9S = "${WORKDIR}/pcmciautils-${PV}"
10
11PR = "r1"
12
13inherit update-rc.d
14
15INITSCRIPT_NAME = "coldplug"
16INITSCRIPT_PARAMS = "defaults"
17
18export HOSTCC = "${BUILD_CC}"
19export etcdir = "${sysconfdir}"
20export pcmciaconfdir = "${sysconfdir}/pcmcia"
21export udevrulesdir = "${sysconfdir}/udev/rules.d"
22export UDEV = 1
23LD = "${CC}"
24CFLAGS =+ "-I${S}/src"
25CFLAGS =+ '-DPCMCIAUTILS_VERSION=010'
26
27PARALLEL_MAKE = ""
28EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
29
30do_install () {
31 oe_runmake 'DESTDIR=${D}' install
32}
33
34CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
35RCONFLICTS_${PN} += "pcmcia-cs"