summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/pcmcia-cs
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-16 16:15:32 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-16 16:15:32 +0000
commitd4f985f2bc606c6767f6c2e96c36c434f4d9fd0b (patch)
tree0a55cfcf0297370bde159af6498e288c49d8b1c6 /openembedded/packages/pcmcia-cs
parent7183f6298a60d489ee534802ec5fdd63ba9028b8 (diff)
downloadpoky-d4f985f2bc606c6767f6c2e96c36c434f4d9fd0b.tar.gz
GCC 4 fixes for pcmcia-cs and openswan
git-svn-id: https://svn.o-hand.com/repos/poky@180 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/pcmcia-cs')
-rw-r--r--openembedded/packages/pcmcia-cs/files/gcc4_fixes.patch26
-rw-r--r--openembedded/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/openembedded/packages/pcmcia-cs/files/gcc4_fixes.patch b/openembedded/packages/pcmcia-cs/files/gcc4_fixes.patch
new file mode 100644
index 0000000000..c68ba7a0f9
--- /dev/null
+++ b/openembedded/packages/pcmcia-cs/files/gcc4_fixes.patch
@@ -0,0 +1,26 @@
1Index: pcmcia-cs-3.2.8/debug-tools/lspnp.c
2===================================================================
3--- pcmcia-cs-3.2.8.orig/debug-tools/lspnp.c 2002-02-13 05:45:01.000000000 +0000
4+++ pcmcia-cs-3.2.8/debug-tools/lspnp.c 2005-11-11 23:43:33.000000000 +0000
5@@ -496,7 +496,7 @@
6 dump_io_fixed(r); break;
7 }
8 }
9- (u_char *)p += sz + 1;
10+ p = (union pnp_resource *) ((u_char *)p + sz + 1);
11 }
12 return (u_char *)p;
13 }
14Index: pcmcia-cs-3.2.8/debug-tools/setpnp.c
15===================================================================
16--- pcmcia-cs-3.2.8.orig/debug-tools/setpnp.c 2001-10-10 02:58:12.000000000 +0000
17+++ pcmcia-cs-3.2.8/debug-tools/setpnp.c 2005-11-11 23:44:32.000000000 +0000
18@@ -163,7 +163,7 @@
19 break;
20 }
21 }
22- (u_char *)p += sz + 1;
23+ p = (union pnp_resource *) ((u_char *)p + sz + 1);
24 }
25 return (u_char *)p;
26 }
diff --git a/openembedded/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb b/openembedded/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
index fa685f8d5f..e0ebf70d93 100644
--- a/openembedded/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
+++ b/openembedded/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
@@ -3,7 +3,7 @@ SECTION = "base"
3PRIORITY = "required" 3PRIORITY = "required"
4LICENSE = "GPL" 4LICENSE = "GPL"
5DEPENDS = "virtual/kernel" 5DEPENDS = "virtual/kernel"
6PR = "r22" 6PR = "r23"
7 7
8SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \ 8SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
9 file://busybox.patch;patch=1 \ 9 file://busybox.patch;patch=1 \
@@ -12,6 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
12 file://automount.patch;patch=1 \ 12 file://automount.patch;patch=1 \
13 file://ratoc-cfu1u.patch;patch=1 \ 13 file://ratoc-cfu1u.patch;patch=1 \
14 file://no-hostap-cards.patch;patch=1 \ 14 file://no-hostap-cards.patch;patch=1 \
15 file://gcc4_fixes.patch;patch=1 \
15 file://pcmcia \ 16 file://pcmcia \
16 file://ide.opts \ 17 file://ide.opts \
17 file://wireless.opts \ 18 file://wireless.opts \