summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/oprofile/oprofile_0.9.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /openembedded/packages/oprofile/oprofile_0.9.1.bb
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/oprofile/oprofile_0.9.1.bb')
-rw-r--r--openembedded/packages/oprofile/oprofile_0.9.1.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/openembedded/packages/oprofile/oprofile_0.9.1.bb b/openembedded/packages/oprofile/oprofile_0.9.1.bb
deleted file mode 100644
index 1cbb05d418..0000000000
--- a/openembedded/packages/oprofile/oprofile_0.9.1.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SECTION = "devel"
2DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
3of profiling all running code at low overhead."
4LICENSE = "GPL"
5MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6DEPENDS = "popt binutils"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
9 file://no_arm_mapping_syms.patch;patch=1 \
10 file://acinclude.m4"
11S = "${WORKDIR}/oprofile-${PV}"
12
13inherit autotools
14
15# NOTE: this disables the build of the kernel modules.
16# Should add the oprofile kernel modules, for those with 2.4
17# kernels, as a seperate .oe file.
18EXTRA_OECONF = "--with-kernel-support \
19 --without-x"
20
21do_configure () {
22 cp ${WORKDIR}/acinclude.m4 ${S}/
23 autotools_do_configure
24}
25# Available config options
26# --enable-abi enable abi portability code (default is disabled)
27# --enable-pch enable precompiled header (default is disabled)
28# --enable-gcov enable option for gcov coverage testing (default is disabled)
29# --disable-werror disable -Werror flag (default is enabled for non-release)
30# --disable-optimization disable optimization flags (default is enabled)
31# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
32# --with-linux=dir Path to Linux source tree
33# --with-module-dir=dir Path to module installation directory
34# --with-extra-includes=DIR add extra include paths
35# --with-extra-libs=DIR add extra library paths
36# --with-x use the X Window System
37# --with-qt-dir where the root of Qt is installed
38# --with-qt-includes where the Qt includes are.
39# --with-qt-libraries where the Qt library is installed.