summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/oh/usbinit.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-28 17:31:21 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-28 17:31:21 +0000
commitcb47354f1ce201e7b2d16698be19055c0d15c984 (patch)
tree14275fd46cef4a1e103864094231bc4875bddc1c /openembedded/packages/oh/usbinit.bb
parentdd2bd6254c9649e5301d7a45b086c23053d895d1 (diff)
downloadpoky-cb47354f1ce201e7b2d16698be19055c0d15c984.tar.gz
Add usbinit hack to get usbnet connection on 770 (will replace with udev in due course)
git-svn-id: https://svn.o-hand.com/repos/poky@53 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/oh/usbinit.bb')
-rw-r--r--openembedded/packages/oh/usbinit.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/openembedded/packages/oh/usbinit.bb b/openembedded/packages/oh/usbinit.bb
new file mode 100644
index 0000000000..bfc8490dc1
--- /dev/null
+++ b/openembedded/packages/oh/usbinit.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Quick hack to start gadget Ethernet on the 770"
2LICENSE = "GPL"
3SECTION = "x11"
4PRIORITY = "optional"
5PR = "r0"
6
7SRC_URI = "file://usb-gether"
8S = ${WORKDIR}
9
10do_install() {
11 install -d ${D}/etc
12 install -d ${D}/etc/init.d
13 install usb-gether ${D}/etc/init.d
14}
15
16inherit update-rc.d
17
18INITSCRIPT_NAME = "usb-gether"
19INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."