diff options
author | Richard Purdie <richard@openedhand.com> | 2006-02-10 14:33:55 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-02-10 14:33:55 +0000 |
commit | 5fb35ca11147ed30c619cf93e19331fd835f3da9 (patch) | |
tree | 45f05442e8a91453bfea03a29fb3cb96f49d80e5 /openembedded/packages/module-init-tools/module-init-tools_3.1.bb | |
parent | 42dfbb2a0223ba5d091f053ad5401ecce6446e41 (diff) | |
download | poky-5fb35ca11147ed30c619cf93e19331fd835f3da9.tar.gz |
Apply more chanegs from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@272 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/module-init-tools/module-init-tools_3.1.bb')
-rw-r--r-- | openembedded/packages/module-init-tools/module-init-tools_3.1.bb | 60 |
1 files changed, 0 insertions, 60 deletions
diff --git a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb b/openembedded/packages/module-init-tools/module-init-tools_3.1.bb deleted file mode 100644 index 62523f513a..0000000000 --- a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb +++ /dev/null | |||
@@ -1,60 +0,0 @@ | |||
1 | LICENSE = "GPL" | ||
2 | SECTION = "base" | ||
3 | DESCRIPTION = "This package contains a set of programs for loading, inserting, and \ | ||
4 | removing kernel modules for Linux (versions 2.5.48 and above). It serves \ | ||
5 | the same function that the modutils package serves for Linux 2.4." | ||
6 | PR = "r2" | ||
7 | |||
8 | PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod" | ||
9 | RDEPENDS_${PN} += "module-init-tools-depmod" | ||
10 | |||
11 | FILES_module-init-tools-depmod = "${sbindir}/depmod.26" | ||
12 | FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static" | ||
13 | |||
14 | SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \ | ||
15 | file://ignore_arch_directory;patch=1 \ | ||
16 | file://modutils_extension;patch=1 \ | ||
17 | file://no_man_rebuild;patch=1 \ | ||
18 | file://manpagesopt;patch=1 \ | ||
19 | file://soc.patch;patch=1;pnum=0" | ||
20 | S = "${WORKDIR}/module-init-tools-${PV}" | ||
21 | |||
22 | EXTRA_OECONF = "--disable-manpages" | ||
23 | |||
24 | bindir = "/bin" | ||
25 | sbindir = "/sbin" | ||
26 | |||
27 | inherit autotools | ||
28 | |||
29 | do_install() { | ||
30 | autotools_do_install | ||
31 | for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do | ||
32 | mv ${D}/$f ${D}/$f.26 | ||
33 | done | ||
34 | } | ||
35 | |||
36 | pkg_postinst_module-init-tools() { | ||
37 | #!/bin/sh | ||
38 | for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do | ||
39 | bn=`basename $f` | ||
40 | update-alternatives --install /$f $bn /$f.26 20 | ||
41 | done | ||
42 | } | ||
43 | |||
44 | pkg_prerm_module-init-tools() { | ||
45 | #!/bin/sh | ||
46 | for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do | ||
47 | bn=`basename $f` | ||
48 | update-alternatives --remove $bn /$f.26 | ||
49 | done | ||
50 | } | ||
51 | |||
52 | pkg_postinst_module-init-tools-depmod() { | ||
53 | #!/bin/sh | ||
54 | update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 20 | ||
55 | } | ||
56 | |||
57 | pkg_prerm_module-init-tools() { | ||
58 | #!/bin/sh | ||
59 | update-alternatives --remove depmod /sbin/depmod.26 | ||
60 | } | ||