summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/meta/task-bootstrap.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-04 20:18:25 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-04 20:18:25 +0000
commit38a06013d777588bd40cacc16d354e62caa3e6ab (patch)
treea0228e51275d10434f7006168fac6f0c9758b003 /openembedded/packages/meta/task-bootstrap.bb
parentae58f06c2bea7bbc51ef5058b8dbf71eda7e4898 (diff)
downloadpoky-38a06013d777588bd40cacc16d354e62caa3e6ab.tar.gz
Remove unneeded packages/meta files
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@500 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/meta/task-bootstrap.bb')
-rw-r--r--openembedded/packages/meta/task-bootstrap.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/openembedded/packages/meta/task-bootstrap.bb b/openembedded/packages/meta/task-bootstrap.bb
deleted file mode 100644
index 497fc31d89..0000000000
--- a/openembedded/packages/meta/task-bootstrap.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1DESCRIPTION = "Core packages required for a basic installation"
2MAINTAINER = "Phil Blundell <pb@handhelds.org>"
3PR = "r26"
4
5# The BOOTSTRAP_EXTRA_ variables are often manipulated by the
6# MACHINE .conf files, so adjust PACKAGE_ARCH accordingly.
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9ALLOW_EMPTY = 1
10PACKAGES = "${PN}"
11
12MODUTILS ?= "24 26"
13
14def bootstrap_modutils_rdepends(d):
15 import bb
16 m = bb.data.getVar('MODUTILS', d, 1)
17 r = []
18 if '24' in m:
19 r.append('modutils-depmod')
20 if '26' in m:
21 r.append('module-init-tools-depmod')
22 return ' '.join(r)
23
24HOTPLUG ?= "linux-hotplug"
25
26RDEPENDS = 'base-files base-passwd busybox \
27 initscripts \
28 netbase sysvinit sysvinit-pidof tinylogin \
29 modutils-initscripts fuser setserial\
30 ${HOTPLUG} \
31 ${BOOTSTRAP_EXTRA_RDEPENDS} \
32 ${@bootstrap_modutils_rdepends(d)}'
33
34RRECOMMENDS = 'dropbear portmap \
35 ${BOOTSTRAP_EXTRA_RRECOMMENDS}'
36LICENSE = MIT