summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/maemo/xpext_1.0-5.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 16:13:52 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 16:13:52 +0000
commitf32bed3ebd85c6c36ab4c629c49770bdeb62c348 (patch)
treebd14cfdcee83c88a88064b872a4ee75317901f2b /openembedded/packages/maemo/xpext_1.0-5.bb
parenta716d991156aa04939496ba177c29ff87a26608c (diff)
downloadpoky-f32bed3ebd85c6c36ab4c629c49770bdeb62c348.tar.gz
Add nokia770 machine support files
git-svn-id: https://svn.o-hand.com/repos/poky@7 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/maemo/xpext_1.0-5.bb')
-rw-r--r--openembedded/packages/maemo/xpext_1.0-5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/openembedded/packages/maemo/xpext_1.0-5.bb b/openembedded/packages/maemo/xpext_1.0-5.bb
new file mode 100644
index 0000000000..cd5aec2d13
--- /dev/null
+++ b/openembedded/packages/maemo/xpext_1.0-5.bb
@@ -0,0 +1,27 @@
1PR = "r0"
2LICENSE= "MIT"
3DESCRIPTION = "X Server Nokia 770 extensions library"
4SECTION = "x11/libs"
5PRIORITY = "optional"
6DEPENDS = "x11 xextensions xext"
7
8SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/${PN}/${PN}_${PV}.tar.gz \
9 file://auxdir.patch;patch=1;pnum=0"
10S = "${WORKDIR}/xpext-1.0"
11
12inherit autotools pkgconfig
13
14do_configure_prepend () {
15 cd ${S}
16 chmod +x ./autogen.sh
17 ./autogen.sh
18}
19
20do_stage() {
21 oe_runmake install prefix=${STAGING_DIR} \
22 bindir=${STAGING_BINDIR} \
23 includedir=${STAGING_INCDIR} \
24 libdir=${STAGING_LIBDIR} \
25 datadir=${STAGING_DATADIR} \
26 mandir=${STAGING_DATADIR}/man
27}