summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/lttng
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-03-22 15:07:03 +0000
committerRichard Purdie <richard@openedhand.com>2006-03-22 15:07:03 +0000
commit91a5b96208f739ab8448081f2c895f80a92412b1 (patch)
tree5c1cb49cca1b557bf0291dd157c667db3a76b9c4 /openembedded/packages/lttng
parent1a630d6ef9a06079771fa1709e8efea1e67b29a5 (diff)
downloadpoky-91a5b96208f739ab8448081f2c895f80a92412b1.tar.gz
Add LTTng packages
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@323 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/lttng')
-rw-r--r--openembedded/packages/lttng/lttng-control_0.1.bb14
-rw-r--r--openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch59
-rw-r--r--openembedded/packages/lttng/lttng-modules_0.12.bb22
-rw-r--r--openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb20
4 files changed, 115 insertions, 0 deletions
diff --git a/openembedded/packages/lttng/lttng-control_0.1.bb b/openembedded/packages/lttng/lttng-control_0.1.bb
new file mode 100644
index 0000000000..018187741b
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-control_0.1.bb
@@ -0,0 +1,14 @@
1SECTION = "devel"
2DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
3extract program execution details from the Linux operating system and \
4interpret them."
5LICENSE = "GPL"
6MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
7
8SRC_URI = "http://ltt.polymtl.ca/lttng/ltt-control-${PV}-11032006.tar.gz"
9
10S = "${WORKDIR}/ltt-control-${PV}-11032006"
11
12inherit autotools
13
14FILES_${PN} += "${datadir}/ltt-control/facilities/*" \ No newline at end of file
diff --git a/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch b/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch
new file mode 100644
index 0000000000..68abc7dda4
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch
@@ -0,0 +1,59 @@
1Index: ltt-modules-0.12/ltt-statedump.c
2===================================================================
3--- ltt-modules-0.12.orig/ltt-statedump.c 2006-03-09 19:33:38.000000000 +0000
4+++ ltt-modules-0.12/ltt-statedump.c 2006-03-22 12:43:30.000000000 +0000
5@@ -19,8 +19,14 @@
6 #include <linux/proc_fs.h>
7 #include <linux/file.h>
8 #include <linux/interrupt.h>
9-#include <linux/irq.h>
10 #include <linux/ltt/ltt-facility-statedump.h>
11+#ifndef CONFIG_ARM
12+#include <linux/irq.h>
13+#else
14+#include <asm/mach/irq.h>
15+#endif
16+
17+
18
19 #define NB_PROC_CHUNK 20
20
21@@ -160,6 +166,7 @@
22 return 0;
23 }
24
25+#ifndef CONFIG_ARM
26 static inline int ltt_enumerate_interrupts(void)
27 {
28 unsigned int i;
29@@ -182,7 +189,9 @@
30
31 return 0;
32 }
33-
34+#else
35+#define ltt_enumerate_interrupts(x)
36+#endif
37
38 static inline int ltt_enumerate_process_states(void)
39 {
40Index: ltt-modules-0.12/Makefile
41===================================================================
42--- ltt-modules-0.12.orig/Makefile 2006-03-11 18:16:17.000000000 +0000
43+++ ltt-modules-0.12/Makefile 2006-03-22 12:39:44.000000000 +0000
44@@ -1,9 +1,7 @@
45-ifneq ($(KERNELRELEASE),)
46 ifneq ($(CONFIG_LTT),)
47 obj-m := ltt-control.o ltt-statedump.o
48 endif
49
50-else
51 KERNELDIR ?= /lib/modules/$(shell uname -r)/build
52 PWD := $(shell pwd)
53 KERNELRELEASE = $(shell cat $(KERNELDIR)/$(KBUILD_OUTPUT)/include/linux/version.h | sed -n 's/.*UTS_RELEASE.*\"\(.*\)\".*/\1/p')
54@@ -21,4 +19,4 @@
55
56 clean:
57 $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
58-endif
59+
diff --git a/openembedded/packages/lttng/lttng-modules_0.12.bb b/openembedded/packages/lttng/lttng-modules_0.12.bb
new file mode 100644
index 0000000000..51f6a05ec1
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-modules_0.12.bb
@@ -0,0 +1,22 @@
1SECTION = "devel"
2DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
3extract program execution details from the Linux operating system and \
4interpret them."
5LICENSE = "GPL"
6MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
7
8SRC_URI = "http://ltt.polymtl.ca/lttng/${PN}-${PV}.tar.gz \
9 file://ltt-modules-fixes.patch;patch=1"
10
11S = "${WORKDIR}/ltt-modules-${PV}"
12
13inherit module
14
15export KERNELDIR="${STAGING_KERNEL_DIR}"
16
17do_install() {
18 install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
19 install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
20}
21
22FILES = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
diff --git a/openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb b/openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb
new file mode 100644
index 0000000000..b76f8b8116
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb
@@ -0,0 +1,20 @@
1SECTION = "devel"
2DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
3extract program execution details from the Linux operating system and \
4interpret them."
5LICENSE = "GPL"
6MAINTAINER = "Richrd Purdie <richard@openedhand.com>"
7PR = "r1"
8DEPENDS = "gtk+ pango popt"
9
10ALTNAME = "LinuxTraceToolkitViewer-0.8.34-17032006"
11
12SRC_URI = "http://ltt.polymtl.ca/packages/${ALTNAME}.tar.gz "
13S = "${WORKDIR}/${ALTNAME}"
14
15inherit autotools
16
17FILES_${PN} += "\
18 ${libdir}/lttv/plugins/* \
19 ${datadir}/LinuxTraceToolkitViewer/facilities/* \
20 ${datadir}/LinuxTraceToolkitViewer/pixmaps/* "