summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/libxml/libxml2_2.6.22.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-05-09 18:38:19 +0000
committerRichard Purdie <richard@openedhand.com>2006-05-09 18:38:19 +0000
commitb4cb437c6595ff8ac13506e502fe04b1a60c4e04 (patch)
treef529de217094f1a49049f90c49d779a49e19cd7c /openembedded/packages/libxml/libxml2_2.6.22.bb
parent3baacb49c13a48798d45e30a0a0076ca0b8c9e6a (diff)
downloadpoky-b4cb437c6595ff8ac13506e502fe04b1a60c4e04.tar.gz
Merge packages changes from OE into poky.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@386 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/libxml/libxml2_2.6.22.bb')
-rw-r--r--openembedded/packages/libxml/libxml2_2.6.22.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/openembedded/packages/libxml/libxml2_2.6.22.bb b/openembedded/packages/libxml/libxml2_2.6.22.bb
new file mode 100644
index 0000000000..fae00a6063
--- /dev/null
+++ b/openembedded/packages/libxml/libxml2_2.6.22.bb
@@ -0,0 +1,39 @@
1PR = "r1"
2DESCRIPTION = "GNOME XML library"
3SECTION = "libs"
4PRIORITY = "optional"
5LICENSE = "MIT"
6PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
7
8FILES_${PN}-dev += "${bindir}/xml-config"
9FILES_${PN}-utils += "${bindir}"
10
11SRC_URI = "http://xmlsoft.org/sources/libxml2/libxml2-${PV}.tar.gz \
12 file://no-testapi.patch;patch=1"
13inherit autotools pkgconfig
14
15EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --without-c14n"
16
17headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
18
19do_stage () {
20 oe_libinstall -so libxml2 ${STAGING_LIBDIR}
21
22 mkdir -p ${STAGING_INCDIR}/libxml2/libxml
23 for i in ${headers}; do
24 install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
25 done
26
27 cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
28 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
29 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
30 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
31 chmod a+rx ${STAGING_BINDIR}/xml2-config
32 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
33}
34
35python populate_packages_prepend () {
36 # autonamer would call this libxml2-2, but we don't want that
37 if bb.data.getVar('DEBIAN_NAMES', d, 1):
38 bb.data.setVar('PKG_libxml2', 'libxml2', d)
39}