summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/jpeg/jpeg_6b.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
commit4b46c1f6e891b1ddd5968536440b888661fade3e (patch)
treee0ba2c1f56f61b868bf746da5c4feabb25b800b2 /openembedded/packages/jpeg/jpeg_6b.bb
downloadpoky-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.gz
Initial population
git-svn-id: https://svn.o-hand.com/repos/poky@1 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/jpeg/jpeg_6b.bb')
-rw-r--r--openembedded/packages/jpeg/jpeg_6b.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/openembedded/packages/jpeg/jpeg_6b.bb b/openembedded/packages/jpeg/jpeg_6b.bb
new file mode 100644
index 0000000000..49e0382b6e
--- /dev/null
+++ b/openembedded/packages/jpeg/jpeg_6b.bb
@@ -0,0 +1,35 @@
1SECTION = "libs"
2PRIORITY = "required"
3MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
4DEPENDS = "libtool-cross"
5DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
6PACKAGES =+ "jpeg-tools "
7FILES_jpeg-tools = "${bindir}"
8LICENSE ="jpeg"
9SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
10 file://debian.patch;patch=1 \
11 file://ldflags.patch;patch=1 \
12 file://paths.patch;patch=1"
13S = "${WORKDIR}/jpeg-${PV}"
14
15inherit autotools
16
17EXTRA_OECONF="--enable-static --enable-shared"
18EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR}/${HOST_SYS}-libtool"'
19
20CFLAGS_append = " -D_REENTRANT"
21
22do_stage() {
23 install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
24 install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
25 install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
26 install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
27 install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
28 oe_libinstall -so libjpeg ${STAGING_LIBDIR}
29}
30
31do_install() {
32 install -d ${D}${bindir} ${D}${includedir} \
33 ${D}${mandir}/man1 ${D}${libdir}
34 oe_runmake 'DESTDIR=${D}' install
35}