summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
diff options
context:
space:
mode:
authorChris Larson <kergoth@openedhand.com>2006-07-13 09:13:21 +0000
committerChris Larson <kergoth@openedhand.com>2006-07-13 09:13:21 +0000
commit5f3d79f3195e24dde7169971343f4db03847a02e (patch)
tree3070e4043e413f3e477a407d7e37e0c3de0391e0 /openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
parent9ddd9dcefa6c1c0788151be43ee844b13ef1dd8a (diff)
downloadpoky-5f3d79f3195e24dde7169971343f4db03847a02e.tar.gz
poky: ipkg-utils update from upstream OE. Locks down to a specific cvs version rather than floating, which seems to fix some issues with root filesystem population in the build.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@512 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb')
-rw-r--r--openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb b/openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
new file mode 100644
index 0000000000..12ed042f15
--- /dev/null
+++ b/openembedded/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Itsy Package Manager utilities"
2SECTION = "base"
3PRIORITY = "optional"
4LICENSE = "GPL"
5CONFLICTS = "ipkg-link"
6RDEPENDS = "python"
7SRCDATE = "20050404"
8PR = "r11"
9
10SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils"
11
12S = "${WORKDIR}/ipkg-utils"
13
14INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py"
15
16do_compile() {
17 oe_runmake ipkg-compare-versions
18}
19
20do_install() {
21 install -d ${D}${bindir}
22 for i in ${INSTALL}
23 do
24 install -m 0755 $i ${D}${bindir}
25 done
26}
27
28#FIXME: ipkg-utils is not allowed to have packages or else a ipkg-native -> ipkg-utils -> ipkg-utils
29# recursive dependency is triggered. This has been fixed by installing the ipkg-link script in
30# a dedicated package.
31#PACKAGES_prepend = "ipkg-link "
32#FILES_ipkg-link = "${bindir}/ipkg-link"
33