summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/hostap
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-20 07:04:35 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-20 07:04:35 +0000
commitb4a7122cacef647dbec3db5c9ebe1e504a7670df (patch)
tree006885a1f4e8032062632ee1a091e72c32dd2810 /openembedded/packages/hostap
parentf9e1d16bfa73a2df5254c63ae1abb6a4bbe0a062 (diff)
downloadpoky-b4a7122cacef647dbec3db5c9ebe1e504a7670df.tar.gz
Updates against mainline OE
git-svn-id: https://svn.o-hand.com/repos/poky@26 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/hostap')
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch11
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch28
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch77
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch70
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch (renamed from openembedded/packages/hostap/hostap-modules-0.4.4/ipaq_compat.patch)0
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff (renamed from openembedded/packages/hostap/hostap-modules-0.4.4/mtx_compat.diff)0
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff (renamed from openembedded/packages/hostap/hostap-modules-0.4.4/mtx_hostap_deferred_irq.diff)0
-rw-r--r--openembedded/packages/hostap/hostap-modules_0.3.9.bb (renamed from openembedded/packages/hostap/hostap-modules_0.4.4.bb)8
8 files changed, 192 insertions, 2 deletions
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch
new file mode 100644
index 0000000000..2fc5e9ed4b
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch
@@ -0,0 +1,11 @@
1--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
2+++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
3@@ -51,7 +51,7 @@
4
5 VERFILE := $(KERNEL_PATH)/include/linux/version.h
6 KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
7- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
8+ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
9 else uname -r; fi)
10 KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
11 sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch
new file mode 100644
index 0000000000..d5f2a10e86
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch
@@ -0,0 +1,28 @@
1Index: hostap-driver-0.3.7/driver/modules/hostap_cs.c
2===================================================================
3--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-08-03 17:05:53.000000000 +0100
4+++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-08-03 17:07:59.000000000 +0100
5@@ -526,11 +526,13 @@
6 dev_list = link;
7 client_reg.dev_info = &dev_info;
8 client_reg.Attributes = INFO_IO_CLIENT;
9+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
10 client_reg.EventMask = CS_EVENT_CARD_INSERTION |
11 CS_EVENT_CARD_REMOVAL |
12 CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
13 CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
14 client_reg.event_handler = &prism2_event;
15+#endif
16 client_reg.Version = 0x0210;
17 client_reg.event_callback_args.client_data = link;
18 ret = pcmcia_register_client(&link->handle, &client_reg);
19@@ -913,6 +915,9 @@
20 .name = "hostap_cs",
21 },
22 .attach = prism2_attach,
23+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
24+ .event = prism2_event,
25+#endif
26 .detach = prism2_detach,
27 .owner = THIS_MODULE,
28 };
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch
new file mode 100644
index 0000000000..c29cc8d2c9
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch
@@ -0,0 +1,77 @@
1diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap.c hostap-driver-0.3.7/driver/modules/hostap.c
2--- hostap-driver-0.3.7.orig/driver/modules/hostap.c 2005-07-25 09:14:01.995965088 +0000
3+++ hostap-driver-0.3.7/driver/modules/hostap.c 2005-07-25 09:13:22.301999488 +0000
4@@ -25,6 +25,7 @@
5 #include <linux/if_arp.h>
6 #include <linux/delay.h>
7 #include <linux/random.h>
8+#include <linux/utsname.h>
9 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
10 #include <linux/tqueue.h>
11 #else
12diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c
13--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:14:01.996964936 +0000
14+++ hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:13:22.302999336 +0000
15@@ -19,6 +19,7 @@
16 #include <linux/netdevice.h>
17 #include <linux/if_ether.h>
18 #include <linux/if_arp.h>
19+#include <linux/utsname.h>
20 #include <asm/string.h>
21
22 #include "hostap_crypt.h"
23diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c
24--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:14:01.996964936 +0000
25+++ hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:13:22.302999336 +0000
26@@ -19,6 +19,7 @@
27 #include <linux/netdevice.h>
28 #include <linux/if_ether.h>
29 #include <linux/if_arp.h>
30+#include <linux/utsname.h>
31 #include <asm/string.h>
32
33 #include "hostap_crypt.h"
34diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c
35--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c 2005-07-25 09:14:01.996964936 +0000
36+++ hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c 2005-07-25 09:13:22.302999336 +0000
37@@ -15,6 +15,7 @@
38 #include <linux/init.h>
39 #include <linux/slab.h>
40 #include <linux/random.h>
41+#include <linux/utsname.h>
42 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
43 #include <linux/tqueue.h>
44 #else
45diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c hostap-driver-0.3.7/driver/modules/hostap_cs.c
46--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-07-25 09:14:01.997964784 +0000
47+++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-07-25 09:13:22.302999336 +0000
48@@ -12,6 +12,7 @@
49 #include <linux/timer.h>
50 #include <linux/skbuff.h>
51 #include <linux/netdevice.h>
52+#include <linux/utsname.h>
53 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
54 #include <linux/tqueue.h>
55 #else
56diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c hostap-driver-0.3.7/driver/modules/hostap_pci.c
57--- hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c 2005-07-25 09:14:01.997964784 +0000
58+++ hostap-driver-0.3.7/driver/modules/hostap_pci.c 2005-07-25 09:13:22.303999184 +0000
59@@ -11,6 +11,7 @@
60 #include <linux/if.h>
61 #include <linux/skbuff.h>
62 #include <linux/netdevice.h>
63+#include <linux/utsname.h>
64 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
65 #include <linux/tqueue.h>
66 #else
67diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c hostap-driver-0.3.7/driver/modules/hostap_plx.c
68--- hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c 2005-07-25 09:14:01.997964784 +0000
69+++ hostap-driver-0.3.7/driver/modules/hostap_plx.c 2005-07-25 09:13:22.303999184 +0000
70@@ -14,6 +14,7 @@
71 #include <linux/if.h>
72 #include <linux/skbuff.h>
73 #include <linux/netdevice.h>
74+#include <linux/utsname.h>
75 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
76 #include <linux/tqueue.h>
77 #else
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch
new file mode 100644
index 0000000000..05f716e22f
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch
@@ -0,0 +1,70 @@
1Index: hostap-driver-0.3.9/driver/modules/hostap_cs.c
2===================================================================
3--- hostap-driver-0.3.9.orig/driver/modules/hostap_cs.c 2005-08-24 10:11:47.000000000 +0100
4+++ hostap-driver-0.3.9/driver/modules/hostap_cs.c 2005-08-24 10:39:10.000000000 +0100
5@@ -908,6 +908,57 @@
6 return 0;
7 }
8
9+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
10+static struct pcmcia_device_id hostap_cs_ids[] = {
11+ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7100),
12+ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
13+ PCMCIA_DEVICE_MANF_CARD(0x0101, 0x0777),
14+ PCMCIA_DEVICE_MANF_CARD(0x0126, 0x8000),
15+ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
16+ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
17+ PCMCIA_DEVICE_MANF_CARD(0x0250, 0x0002),
18+ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1612),
19+ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
20+ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
21+ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
22+ PCMCIA_DEVICE_MANF_CARD(0x02d2, 0x0001),
23+ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x0001),
24+ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
25+ PCMCIA_DEVICE_MANF_CARD(0xc00f, 0x0000),
26+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
27+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
28+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0010),
29+ PCMCIA_MFC_DEVICE_PROD_ID12(0, "SanDisk", "ConnectPlus",
30+ 0x7a954bd9, 0x74be00c6),
31+ PCMCIA_DEVICE_PROD_ID1234(
32+ "Intersil", "PRISM 2_5 PCMCIA ADAPTER", "ISL37300P",
33+ "Eval-RevA",
34+ 0x4b801a17, 0x6345a0bf, 0xc9049a39, 0xc23adc0e),
35+ PCMCIA_DEVICE_PROD_ID123(
36+ "Addtron", "AWP-100 Wireless PCMCIA", "Version 01.02",
37+ 0xe6ec52ce, 0x08649af2, 0x4b74baa0),
38+ PCMCIA_DEVICE_PROD_ID123(
39+ "D", "Link DWL-650 11Mbps WLAN Card", "Version 01.02",
40+ 0x71b18589, 0xb6f1b0ab, 0x4b74baa0),
41+ PCMCIA_DEVICE_PROD_ID123(
42+ "Instant Wireless ", " Network PC CARD", "Version 01.02",
43+ 0x11d901af, 0x6e9bd926, 0x4b74baa0),
44+ PCMCIA_DEVICE_PROD_ID123(
45+ "SMC", "SMC2632W", "Version 01.02",
46+ 0xc4f8b18b, 0x474a1f2a, 0x4b74baa0),
47+ PCMCIA_DEVICE_PROD_ID12("Compaq", "WL200_11Mbps_Wireless_PCI_Card",
48+ 0x54f7c49c, 0x15a75e5b),
49+ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE",
50+ 0x74c5e40d, 0xdb472a18),
51+ PCMCIA_DEVICE_PROD_ID12("Linksys", "Wireless CompactFlash Card",
52+ 0x0733cc81, 0x0c52f395),
53+ PCMCIA_DEVICE_PROD_ID12(
54+ "ZoomAir 11Mbps High", "Rate wireless Networking",
55+ 0x273fe3db, 0x32a1eaee),
56+ PCMCIA_DEVICE_NULL
57+};
58+MODULE_DEVICE_TABLE(pcmcia, hostap_cs_ids);
59+#endif
60
61 #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
62 static struct pcmcia_driver hostap_driver = {
63@@ -917,6 +968,7 @@
64 .attach = prism2_attach,
65 #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
66 .event = prism2_event,
67+ .id_table = hostap_cs_ids,
68 #endif
69 .detach = prism2_detach,
70 .owner = THIS_MODULE,
diff --git a/openembedded/packages/hostap/hostap-modules-0.4.4/ipaq_compat.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch
index b139ef38f1..b139ef38f1 100644
--- a/openembedded/packages/hostap/hostap-modules-0.4.4/ipaq_compat.patch
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch
diff --git a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_compat.diff b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff
index c2d6662d69..c2d6662d69 100644
--- a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_compat.diff
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff
diff --git a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_hostap_deferred_irq.diff b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff
index e979b72d93..e979b72d93 100644
--- a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_hostap_deferred_irq.diff
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff
diff --git a/openembedded/packages/hostap/hostap-modules_0.4.4.bb b/openembedded/packages/hostap/hostap-modules_0.3.9.bb
index fd7a3eaff9..1be1e6a77e 100644
--- a/openembedded/packages/hostap/hostap-modules_0.4.4.bb
+++ b/openembedded/packages/hostap/hostap-modules_0.3.9.bb
@@ -3,10 +3,14 @@ SECTION = "kernel/modules"
3PRIORITY = "optional" 3PRIORITY = "optional"
4MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>" 4MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5LICENSE = "GPL" 5LICENSE = "GPL"
6PR = "r4"
6 7
7SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \ 8SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
8 file://hostap_cs.conf " 9 file://hostap_cs.conf \
9 10 file://Makefile.patch;patch=1 \
11 file://add_event.patch;patch=1 \
12 file://hostap-utsname.patch;patch=1 \
13 file://hostap_cardid.patch;patch=1"
10SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \ 14SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
11 file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0" 15 file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
12SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 " 16SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "