summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/hal
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-03 13:07:08 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-03 13:07:08 +0000
commit923c1b061e0197c654a09e33b8443e26c6c1d735 (patch)
treeaacfed081a120f2dcad6d1711518adbd281a743f /openembedded/packages/hal
parent9a725b75ff28d0729af42a355ea89f9edf2c88f6 (diff)
downloadpoky-923c1b061e0197c654a09e33b8443e26c6c1d735.tar.gz
Remove linux-openzaurus-2.6.14-rc4 and add hal
git-svn-id: https://svn.o-hand.com/repos/poky@158 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/hal')
-rw-r--r--openembedded/packages/hal/hal_0.5.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/openembedded/packages/hal/hal_0.5.4.bb b/openembedded/packages/hal/hal_0.5.4.bb
new file mode 100644
index 0000000000..3db5753996
--- /dev/null
+++ b/openembedded/packages/hal/hal_0.5.4.bb
@@ -0,0 +1,31 @@
1SECTION = "unknown"
2DESCRIPTION = "Hardware Abstraction Layer"
3MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
4DEPENDS = "dbus expat libusb"
5RDEPENDS += "hotplug"
6RDEPENDS_hal-device-manager = "python hal python-pygnome"
7RRECOMMENDS = "udev-utils"
8HOMEPAGE = "http://freedesktop.org/Software/hal"
9LICENSE = "GPL LGPL AFL"
10
11SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
12S = "${WORKDIR}/hal-${PV}"
13
14inherit autotools pkgconfig
15
16EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
17 --with-expat=${STAGING_LIBDIR}/.. \
18 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
19 --with-hotplug=${sysconfdir}/hotplug.d"
20
21do_stage() {
22 autotools_stage_includes
23 install -d ${STAGING_LIBDIR}
24 install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
25 install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
26}
27
28PACKAGES += "hal-device-manager"
29FILES_${PN} = "${sysconfdir} ${bindir}/lshal ${bindir}/hal-get-property ${bindir}/hal-set-property ${sbindir} ${libdir}/libhal.so* ${libdir}/libhal-storage.so* ${libexecdir} ${datadir}/hal/fdi"
30FILES_hal-device-manager = "${datadir}/hal/device-manager/ ${bindir}/hal-device-manager"
31