summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/gtk+
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-10-04 00:57:50 +0000
committerChris Lord <chris@openedhand.com>2005-10-04 00:57:50 +0000
commit86ac5925e2460bc4df852f9b4d22c2a04a698164 (patch)
tree4fd52e6ec943f5e7c5bcf35ee889daae3d3188cc /openembedded/packages/gtk+
parentc9b9b5bbbd5a8081740d319c15f3f1cebd0c4921 (diff)
downloadpoky-86ac5925e2460bc4df852f9b4d22c2a04a698164.tar.gz
Remove some gtk 2.6.7 patches aimed at 240x320 screens that make things
look ugly git-svn-id: https://svn.o-hand.com/repos/poky@113 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/gtk+')
-rw-r--r--openembedded/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch50
-rw-r--r--openembedded/packages/gtk+/gtk+_2.6.7.bb3
2 files changed, 1 insertions, 52 deletions
diff --git a/openembedded/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch b/openembedded/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch
index 20481f059b..2c5fc39d23 100644
--- a/openembedded/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch
+++ b/openembedded/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch
@@ -1,53 +1,3 @@
1--- gtk+-2.4.1/gtk/gtkarrow.c 2004-03-13 09:51:13.000000000 +1100
2+++ gtk+-2.4.1/gtk/gtkarrow.c 2004-05-26 14:52:17.000000000 +1000
3@@ -29,7 +29,7 @@
4 #include "gtkarrow.h"
5 #include "gtkintl.h"
6
7-#define MIN_ARROW_SIZE 15
8+#define MIN_ARROW_SIZE 7
9
10 enum {
11 PROP_0,
12@@ -53,6 +53,8 @@
13 guint prop_id,
14 GValue *value,
15 GParamSpec *pspec);
16+static void gtk_arrow_size_request (GtkWidget *arrow,
17+ GtkRequisition *requisition);
18
19 GType
20 gtk_arrow_get_type (void)
21@@ -111,6 +113,7 @@
22 G_PARAM_READABLE | G_PARAM_WRITABLE));
23
24 widget_class->expose_event = gtk_arrow_expose;
25+ widget_class->size_request = gtk_arrow_size_request;
26 }
27
28 static void
29@@ -166,13 +169,18 @@
30 }
31
32 static void
33+gtk_arrow_size_request (GtkWidget *arrow,
34+ GtkRequisition *requisition)
35+{
36+ requisition->width = MIN_ARROW_SIZE + GTK_MISC (arrow)->xpad * 2;
37+ requisition->height = MIN_ARROW_SIZE + GTK_MISC (arrow)->ypad * 2;
38+}
39+
40+static void
41 gtk_arrow_init (GtkArrow *arrow)
42 {
43 GTK_WIDGET_SET_FLAGS (arrow, GTK_NO_WINDOW);
44
45- GTK_WIDGET (arrow)->requisition.width = MIN_ARROW_SIZE + GTK_MISC (arrow)->xpad * 2;
46- GTK_WIDGET (arrow)->requisition.height = MIN_ARROW_SIZE + GTK_MISC (arrow)->ypad * 2;
47-
48 arrow->arrow_type = GTK_ARROW_RIGHT;
49 arrow->shadow_type = GTK_SHADOW_OUT;
50 }
51--- gtk+-2.4.1/gtk/gtkcalendar.c 2004-03-06 14:37:26.000000000 +1100 1--- gtk+-2.4.1/gtk/gtkcalendar.c 2004-03-06 14:37:26.000000000 +1100
52+++ gtk+-2.4.1/gtk/gtkcalendar.c 2004-05-26 14:58:57.000000000 +1000 2+++ gtk+-2.4.1/gtk/gtkcalendar.c 2004-05-26 14:58:57.000000000 +1000
53@@ -340,6 +340,9 @@ 3@@ -340,6 +340,9 @@
diff --git a/openembedded/packages/gtk+/gtk+_2.6.7.bb b/openembedded/packages/gtk+/gtk+_2.6.7.bb
index 54e0e0e6e1..b53d7350e8 100644
--- a/openembedded/packages/gtk+/gtk+_2.6.7.bb
+++ b/openembedded/packages/gtk+/gtk+_2.6.7.bb
@@ -6,14 +6,13 @@ SECTION = "libs"
6PRIORITY = "optional" 6PRIORITY = "optional"
7MAINTAINER = "Philip Blundell <pb@handhelds.org>" 7MAINTAINER = "Philip Blundell <pb@handhelds.org>"
8DEPENDS = "glib-2.0 pango atk jpeg libpng xext libxcursor gtk-doc libgcrypt" 8DEPENDS = "glib-2.0 pango atk jpeg libpng xext libxcursor gtk-doc libgcrypt"
9PR = "r2" 9PR = "r3"
10 10
11SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \ 11SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
12 file://no-demos.patch;patch=1 \ 12 file://no-demos.patch;patch=1 \
13 file://no-xwc.patch;patch=1 \ 13 file://no-xwc.patch;patch=1 \
14 file://automake-lossage.patch;patch=1 \ 14 file://automake-lossage.patch;patch=1 \
15 file://gtk+-handhelds.patch;patch=1 \ 15 file://gtk+-handhelds.patch;patch=1 \
16 file://spinbutton.patch;patch=1 \
17 file://hardcoded_libtool.patch;patch=1 \ 16 file://hardcoded_libtool.patch;patch=1 \
18 file://disable-tooltips.patch;patch=1 \ 17 file://disable-tooltips.patch;patch=1 \
19 file://gtklabel-resize-patch;patch=1 \ 18 file://gtklabel-resize-patch;patch=1 \