diff options
author | Richard Purdie <richard@openedhand.com> | 2006-02-10 14:33:55 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-02-10 14:33:55 +0000 |
commit | 5fb35ca11147ed30c619cf93e19331fd835f3da9 (patch) | |
tree | 45f05442e8a91453bfea03a29fb3cb96f49d80e5 /openembedded/packages/gnome | |
parent | 42dfbb2a0223ba5d091f053ad5401ecce6446e41 (diff) | |
download | poky-5fb35ca11147ed30c619cf93e19331fd835f3da9.tar.gz |
Apply more chanegs from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@272 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/gnome')
4 files changed, 39 insertions, 6 deletions
diff --git a/openembedded/packages/gnome/gconf-dbus/xml-backend-locks-compile-fix.patch b/openembedded/packages/gnome/gconf-dbus/xml-backend-locks-compile-fix.patch new file mode 100644 index 0000000000..c195aad639 --- /dev/null +++ b/openembedded/packages/gnome/gconf-dbus/xml-backend-locks-compile-fix.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | --- trunk/backends/xml-backend.c~ 2006-01-18 09:57:39.000000000 -0800 | ||
2 | +++ trunk/backends/xml-backend.c 2006-01-19 11:38:37.000000000 -0800 | ||
3 | @@ -115,6 +115,13 @@ | ||
4 | |||
5 | typedef struct _XMLSource XMLSource; | ||
6 | |||
7 | +extern GConfLock* | ||
8 | +gconf_get_lock (const gchar *lock_directory, | ||
9 | + GError **err); | ||
10 | +extern gboolean | ||
11 | +gconf_release_lock (GConfLock *lock, | ||
12 | + GError **err); | ||
13 | + | ||
14 | /* XMLSource **/ | ||
15 | |||
16 | struct _XMLSource { | ||
diff --git a/openembedded/packages/gnome/gconf-dbus/xml-backend-oldxml-Makefile.patch b/openembedded/packages/gnome/gconf-dbus/xml-backend-oldxml-Makefile.patch new file mode 100644 index 0000000000..312a356c84 --- /dev/null +++ b/openembedded/packages/gnome/gconf-dbus/xml-backend-oldxml-Makefile.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- trunk/backends/Makefile~ 2006-01-19 09:52:22.000000000 -0800 | ||
2 | +++ trunk/backends/Makefile 2006-01-19 13:13:23.000000000 -0800 | ||
3 | @@ -84,7 +84,7 @@ | ||
4 | xml_test_OBJECTS = $(am_xml_test_OBJECTS) | ||
5 | xml_test_DEPENDENCIES = $(am__DEPENDENCIES_1) \ | ||
6 | $(top_builddir)/gconf/libgconf-$(MAJOR_VERSION).la \ | ||
7 | - $(top_builddir)/backends/libgconfbackend-oldxml.la | ||
8 | + libgconfbackend-oldxml.la | ||
9 | DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir) | ||
10 | depcomp = $(SHELL) $(top_srcdir)/depcomp | ||
11 | am__depfiles_maybe = depfiles | ||
diff --git a/openembedded/packages/gnome/gconf-dbus_svn.bb b/openembedded/packages/gnome/gconf-dbus_svn.bb index b71d5179cb..d6b79494be 100644 --- a/openembedded/packages/gnome/gconf-dbus_svn.bb +++ b/openembedded/packages/gnome/gconf-dbus_svn.bb | |||
@@ -12,19 +12,26 @@ PR = "r0" | |||
12 | 12 | ||
13 | SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \ | 13 | SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \ |
14 | file://gconf-dbus-update.patch;patch=1;pnum=0 \ | 14 | file://gconf-dbus-update.patch;patch=1;pnum=0 \ |
15 | file://xml-backend-locks-compile-fix.patch;patch=1 \ | ||
16 | file://xml-backend-oldxml-Makefile.patch \ | ||
15 | file://69gconfd-dbus" | 17 | file://69gconfd-dbus" |
16 | 18 | ||
17 | PARALLEL_MAKE = "" | ||
18 | |||
19 | inherit pkgconfig autotools | 19 | inherit pkgconfig autotools |
20 | S = "${WORKDIR}/trunk" | 20 | S = "${WORKDIR}/trunk" |
21 | 21 | ||
22 | PARALLEL_MAKE = "" | ||
23 | |||
22 | FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus*" | 24 | FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus*" |
23 | 25 | ||
24 | EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static" | 26 | EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static" |
25 | 27 | ||
26 | HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h" | 28 | HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h" |
27 | 29 | ||
30 | do_compile_prepend() { | ||
31 | cd ${S} | ||
32 | patch -p1 < ../xml-backend-oldxml-Makefile.patch | ||
33 | } | ||
34 | |||
28 | do_stage() { | 35 | do_stage() { |
29 | oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR} | 36 | oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR} |
30 | install -d ${STAGING_INCDIR}/gconf/2/gconf/ | 37 | install -d ${STAGING_INCDIR}/gconf/2/gconf/ |
diff --git a/openembedded/packages/gnome/gnome-mime-data_2.4.2.bb b/openembedded/packages/gnome/gnome-mime-data_2.4.2.bb index bf98e1441c..c71f21c9d8 100644 --- a/openembedded/packages/gnome/gnome-mime-data_2.4.2.bb +++ b/openembedded/packages/gnome/gnome-mime-data_2.4.2.bb | |||
@@ -1,8 +1,7 @@ | |||
1 | LICENSE = "GPL" | 1 | LICENSE = "GPL" |
2 | 2 | inherit gnome | |
3 | inherit pkgconfig autotools | ||
4 | |||
5 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${PN}/2.4/${PN}-${PV}.tar.bz2" | ||
6 | 3 | ||
7 | DEPENDS += "shared-mime-info intltool-native" | 4 | DEPENDS += "shared-mime-info intltool-native" |
8 | RDEPENDS = "shared-mime-info" | 5 | RDEPENDS = "shared-mime-info" |
6 | |||
7 | PR = "r2" | ||