diff options
author | Richard Purdie <richard@openedhand.com> | 2005-11-16 16:20:35 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2005-11-16 16:20:35 +0000 |
commit | 1a5f0fedce5084690bb478a302d7dd326198afee (patch) | |
tree | 4ee4c487b833e01dd4b82eaf4d6ee13578bfd78b /openembedded/packages/gcc/gcc-4.0.2 | |
parent | f0d9a3840ce349e606f5a6bfcf552c1adcaf2a46 (diff) | |
download | poky-1a5f0fedce5084690bb478a302d7dd326198afee.tar.gz |
Add gcc versions 4.0.2, 3.3.4 and 3.4.4
git-svn-id: https://svn.o-hand.com/repos/poky@182 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/gcc/gcc-4.0.2')
-rw-r--r-- | openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch | 24 | ||||
-rw-r--r-- | openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch | 16 | ||||
-rw-r--r-- | openembedded/packages/gcc/gcc-4.0.2/ldflags.patch | 22 |
3 files changed, 62 insertions, 0 deletions
diff --git a/openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch b/openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch new file mode 100644 index 0000000000..c4897c0330 --- /dev/null +++ b/openembedded/packages/gcc/gcc-4.0.2/arm-nolibfloat.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | # Dimitry Andric <dimitry@andric.com>, 2004-05-01 | ||
2 | # | ||
3 | # * Removed the extra -lfloat option from LIBGCC_SPEC, since it isn't needed | ||
4 | # anymore. (The required functions are now in libgcc.) | ||
5 | # | ||
6 | # Fixes errors like | ||
7 | # arm-softfloat-linux-gnu/3.4.0/../../../../arm-softfloat-linux-gnu/bin/ld: cannot find -lfloat | ||
8 | # collect2: ld returned 1 exit status | ||
9 | # make[2]: *** [arm-softfloat-linux-gnu/gcc-3.4.0-glibc-2.3.2/build-glibc/iconvdata/ISO8859-1.so] Error 1 | ||
10 | # when building glibc-2.3.3 with gcc-3.4.0 for arm-softfloat | ||
11 | |||
12 | Index: gcc-4.0.2/gcc/config/arm/linux-elf.h | ||
13 | =================================================================== | ||
14 | --- gcc-4.0.2.orig/gcc/config/arm/linux-elf.h 2005-03-04 16:14:01.000000000 +0000 | ||
15 | +++ gcc-4.0.2/gcc/config/arm/linux-elf.h 2005-11-11 18:02:54.000000000 +0000 | ||
16 | @@ -56,7 +56,7 @@ | ||
17 | %{shared:-lc} \ | ||
18 | %{!shared:%{profile:-lc_p}%{!profile:-lc}}" | ||
19 | |||
20 | -#define LIBGCC_SPEC "%{msoft-float:-lfloat} %{mfloat-abi=soft*:-lfloat} -lgcc" | ||
21 | +#define LIBGCC_SPEC "-lgcc" | ||
22 | |||
23 | /* Provide a STARTFILE_SPEC appropriate for GNU/Linux. Here we add | ||
24 | the GNU/Linux magical crtbegin.o file (see crtstuff.c) which | ||
diff --git a/openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch b/openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch new file mode 100644 index 0000000000..c86c83ed15 --- /dev/null +++ b/openembedded/packages/gcc/gcc-4.0.2/arm-softfloat.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Index: gcc-4.0.2/gcc/config/arm/t-linux | ||
2 | =================================================================== | ||
3 | --- gcc-4.0.2.orig/gcc/config/arm/t-linux 2004-05-15 12:41:35.000000000 +0000 | ||
4 | +++ gcc-4.0.2/gcc/config/arm/t-linux 2005-11-11 16:07:53.000000000 +0000 | ||
5 | @@ -4,7 +4,10 @@ | ||
6 | LIBGCC2_DEBUG_CFLAGS = -g0 | ||
7 | |||
8 | LIB1ASMSRC = arm/lib1funcs.asm | ||
9 | -LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx | ||
10 | +LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx \ | ||
11 | + _negdf2 _addsubdf3 _muldivdf3 _cmpdf2 _unorddf2 _fixdfsi _fixunsdfsi \ | ||
12 | + _truncdfsf2 _negsf2 _addsubsf3 _muldivsf3 _cmpsf2 _unordsf2 \ | ||
13 | + _fixsfsi _fixunssfsi _floatdidf _floatdisf | ||
14 | |||
15 | # MULTILIB_OPTIONS = mhard-float/msoft-float | ||
16 | # MULTILIB_DIRNAMES = hard-float soft-float | ||
diff --git a/openembedded/packages/gcc/gcc-4.0.2/ldflags.patch b/openembedded/packages/gcc/gcc-4.0.2/ldflags.patch new file mode 100644 index 0000000000..1196bf0c8e --- /dev/null +++ b/openembedded/packages/gcc/gcc-4.0.2/ldflags.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | --- gcc-4.0.0/Makefile.tpl.old 2005-06-10 13:05:09.000000000 +0100 | ||
2 | +++ gcc-4.0.0/Makefile.tpl 2005-06-10 13:05:10.000000000 +0100 | ||
3 | @@ -339,7 +339,7 @@ | ||
4 | NM = @NM@ | ||
5 | |||
6 | LD = @LD@ | ||
7 | -LDFLAGS = | ||
8 | +LDFLAGS = @LDFLAGS@ | ||
9 | |||
10 | RANLIB = @RANLIB@ | ||
11 | |||
12 | --- gcc-4.0.0/Makefile.in.old 2005-06-10 17:13:12.000000000 +0100 | ||
13 | +++ gcc-4.0.0/Makefile.in 2005-06-10 17:13:22.000000000 +0100 | ||
14 | @@ -336,7 +336,7 @@ | ||
15 | NM = @NM@ | ||
16 | |||
17 | LD = @LD@ | ||
18 | -LDFLAGS = | ||
19 | +LDFLAGS = @LDFLAGS@ | ||
20 | |||
21 | RANLIB = @RANLIB@ | ||
22 | |||