summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/dbus
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2006-03-21 11:44:29 +0000
committerRoss Burton <ross@openedhand.com>2006-03-21 11:44:29 +0000
commit884f57015c0d993a0568a9ea493a25dd1a3ff7ca (patch)
treec76a423728efb4947275c8a9057d67ed60fa7185 /openembedded/packages/dbus
parent3d54063c988980544587c59593286de6e1a748ed (diff)
downloadpoky-884f57015c0d993a0568a9ea493a25dd1a3ff7ca.tar.gz
Remove dbus 0.23
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@312 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/dbus')
-rw-r--r--openembedded/packages/dbus/dbus_0.23.1-osso5.bb72
1 files changed, 0 insertions, 72 deletions
diff --git a/openembedded/packages/dbus/dbus_0.23.1-osso5.bb b/openembedded/packages/dbus/dbus_0.23.1-osso5.bb
deleted file mode 100644
index b2fc9c44ac..0000000000
--- a/openembedded/packages/dbus/dbus_0.23.1-osso5.bb
+++ /dev/null
@@ -1,72 +0,0 @@
1DEFAULT_PREFERENCE = "-1"
2SECTION = "base"
3PR = "r1"
4HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
5DESCRIPTION = "message bus system for applications to talk to one another"
6LICENSE = "GPL"
7DEPENDS = "expat glib-2.0 virtual/libintl"
8
9SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/d/${PN}/${PN}_${PV}.tar.gz \
10 file://cross.patch;patch=1 \
11 file://tmpdir.patch;patch=1 \
12 file://gettext.patch;patch=1 \
13 file://0.23.1.diff;patch=1 \
14 file://dbus-monitor.patch;patch=1 \
15 file://dbussend.patch;patch=1;pnum=0 \
16 file://spawn-priority.diff;patch=1 \
17 file://config.diff;patch=1;pnum=0 \
18 file://dbus-quiesce-startup-errors.patch;patch=1 \
19 file://tools.diff;patch=1;pnum=0 \
20 file://dbus-1.init"
21
22inherit autotools pkgconfig update-rc.d gettext
23
24S = "${WORKDIR}/dbus-0.23.1"
25
26INITSCRIPT_NAME = "dbus-1"
27INITSCRIPT_PARAMS = "defaults"
28
29CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
30
31FILES_${PN} = "${bindir}/dbus-daemon-1 ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
32FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
33
34pkg_postinst_dbus() {
35#!/bin/sh
36
37# can't do adduser stuff offline
38if [ "x$D" != "x" ]; then
39 exit 1
40fi
41
42MESSAGEUSER=messagebus
43MESSAGEHOME=/var/run/dbus
44
45mkdir -p $MESSAGEHOME || true
46chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
47chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
48}
49
50EXTRA_OECONF = "--disable-qt --disable-gtk --disable-tests \
51 --disable-checks --disable-xml-docs --disable-doxygen-docs \
52 --with-xml=expat --without-x"
53
54do_stage () {
55 oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
56 oe_libinstall -so -C glib libdbus-glib-1 ${STAGING_LIBDIR}
57
58 autotools_stage_includes
59
60 mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
61 install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
62}
63
64do_install_append () {
65 install -d ${D}${sysconfdir}/init.d
66 install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
67}
68
69python populate_packages_prepend () {
70 if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
71 bb.data.setVar('PKG_dbus', 'dbus-1', d)
72}