summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/contacts/contacts_svn.bb
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-12-22 16:50:56 +0000
committerChris Lord <chris@openedhand.com>2005-12-22 16:50:56 +0000
commit597f73ebe7890f67ad02f8ac54acc3280330b097 (patch)
tree7e66c196d740cc7f82f0e56b7d0bb8628bd46620 /openembedded/packages/contacts/contacts_svn.bb
parente7cf0cc43167bf9bdc87e6168e64db38d6468427 (diff)
downloadpoky-597f73ebe7890f67ad02f8ac54acc3280330b097.tar.gz
Add packages for Contacts 0.1 and svn
git-svn-id: https://svn.o-hand.com/repos/poky@203 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/contacts/contacts_svn.bb')
-rwxr-xr-xopenembedded/packages/contacts/contacts_svn.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/openembedded/packages/contacts/contacts_svn.bb b/openembedded/packages/contacts/contacts_svn.bb
new file mode 100755
index 0000000000..121f256a43
--- /dev/null
+++ b/openembedded/packages/contacts/contacts_svn.bb
@@ -0,0 +1,36 @@
1LICENSE = "LGPL"
2SECTION = "x11"
3DEPENDS = "glib-2.0 gtk+ libglade eds-dbus gnome-vfs"
4RDEPENDS = "gnome-vfs-plugin-file"
5RRECOMMENDS = "gnome-vfs-plugin-http"
6MAINTAINER = "Chris Lord <chris@openedhand.com>"
7DESCRIPTION = "Contacts is an address-book application."
8
9SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
10 file://stock_contact.png \
11 file://stock_person.png \
12 file://index.theme"
13
14inherit autotools pkgconfig
15
16S = "${WORKDIR}/trunk"
17
18EXTRA_OECONF = "--enable-gnome-vfs"
19
20do_install_append () {
21 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
22 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
23
24 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
25 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
26 install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
27}
28
29FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
30 ${datadir}/icons/hicolor/48x48/stock/*/*.png \
31 ${datadir}/icons/hicolor/index.theme"
32
33pkg_postinst_${PN} () {
34 gtk-update-icon-cache /usr/share/icons/hicolor
35}
36