diff options
author | Richard Purdie <richard@openedhand.com> | 2005-12-12 14:52:04 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2005-12-12 14:52:04 +0000 |
commit | 8fd58431099933596268fb47245e673cf55ce3c6 (patch) | |
tree | f4405b22fa75ec422d7012cb5cc80e057c5ba5ce /openembedded/packages/console-tools | |
parent | 3c470b4e199b91c16da139eef47df253627f00e3 (diff) | |
download | poky-8fd58431099933596268fb47245e673cf55ce3c6.tar.gz |
oe/packages Updates from Openembedded
git-svn-id: https://svn.o-hand.com/repos/poky@189 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/console-tools')
-rw-r--r-- | openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch | 73 | ||||
-rw-r--r-- | openembedded/packages/console-tools/console-tools_0.3.2.bb | 5 |
2 files changed, 76 insertions, 2 deletions
diff --git a/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch b/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch new file mode 100644 index 0000000000..47d7ea54b9 --- /dev/null +++ b/openembedded/packages/console-tools/console-tools-0.3.2/kbdrate.patch | |||
@@ -0,0 +1,73 @@ | |||
1 | Patch from Matthias Goebl <oe@m.goebl.net> | ||
2 | Added via OE bugtracker: bug #478 | ||
3 | |||
4 | --- console-tools-0.3.2/kbdtools/kbd_mode.c.orig | ||
5 | +++ console-tools-0.3.2/kbdtools/kbd_mode.c | ||
6 | @@ -29,11 +29,16 @@ | ||
7 | OPT("-u --unicode ", _("UTF-8 mode (UNICODE)")); | ||
8 | OPT("-s --scancode ", _("scancode mode (RAW)")); | ||
9 | OPT(" --mode={8bit,keycode,unicode,scancode} ", _("set mode")); | ||
10 | + OPT("-r --rate=RATE ", _("set repeat rate (default: 33)")); | ||
11 | + OPT("-d --delay=DELAY ", _("set repeat delay (default: 250)")); | ||
12 | |||
13 | OPT("-h --help ", HELPDESC); | ||
14 | OPT("-V --version ", VERSIONDESC); | ||
15 | } | ||
16 | |||
17 | +int rate=-1; | ||
18 | +int delay=-1; | ||
19 | + | ||
20 | static int parse_cmdline (int argc, char *argv[]) | ||
21 | { | ||
22 | int mode = -1; | ||
23 | @@ -46,11 +51,13 @@ | ||
24 | { "mode" , required_argument, NULL, 'm' }, | ||
25 | { "scancode" , no_argument, NULL, 's' }, | ||
26 | { "unicode" , no_argument, NULL, 'u' }, | ||
27 | + { "rate" , required_argument, NULL, 'r' }, | ||
28 | + { "delay" , required_argument, NULL, 'd' }, | ||
29 | { NULL, 0, NULL, 0 } | ||
30 | }; | ||
31 | int c; | ||
32 | |||
33 | - while ( (c = getopt_long (argc, argv, "Vhaksu", long_opts, NULL)) != EOF) | ||
34 | + while ( (c = getopt_long (argc, argv, "Vhaksur:d:", long_opts, NULL)) != EOF) | ||
35 | switch (c) { | ||
36 | case 'h': | ||
37 | usage (); | ||
38 | @@ -58,6 +65,14 @@ | ||
39 | case 'V': | ||
40 | version (); | ||
41 | exit(0); | ||
42 | + case 'r': | ||
43 | + rate = atoi(optarg); | ||
44 | + mode = -2; | ||
45 | + break; | ||
46 | + case 'd': | ||
47 | + delay = atoi(optarg); | ||
48 | + mode = -2; | ||
49 | + break; | ||
50 | case 'a': | ||
51 | mode = K_XLATE; | ||
52 | break; | ||
53 | @@ -129,6 +144,20 @@ | ||
54 | exit(0); | ||
55 | } | ||
56 | |||
57 | + if ( rate != -1 || delay != -1 ) | ||
58 | + { | ||
59 | + struct kbd_repeat kbd_rep; | ||
60 | + kbd_rep.delay = delay; | ||
61 | + kbd_rep.period = rate; | ||
62 | + if (ioctl(fd, KDKBDREP, &kbd_rep)) | ||
63 | + { | ||
64 | + fprintf(stderr, progname); | ||
65 | + perror(_(": error setting keyboard repeat mode\n")); | ||
66 | + exit(1); | ||
67 | + } | ||
68 | + if(mode==-2) exit(0); | ||
69 | + } | ||
70 | + | ||
71 | if (ioctl(fd, KDSKBMODE, mode)) | ||
72 | { | ||
73 | fprintf(stderr, progname); | ||
diff --git a/openembedded/packages/console-tools/console-tools_0.3.2.bb b/openembedded/packages/console-tools/console-tools_0.3.2.bb index 2a94a4f896..f7455825e0 100644 --- a/openembedded/packages/console-tools/console-tools_0.3.2.bb +++ b/openembedded/packages/console-tools/console-tools_0.3.2.bb | |||
@@ -1,12 +1,13 @@ | |||
1 | SECTION = "base" | 1 | SECTION = "base" |
2 | LICENSE = "GPL" | 2 | LICENSE = "GPL" |
3 | DESCRIPTION = "Allows you to set-up and manipulate the Linux console." | 3 | DESCRIPTION = "Allows you to set-up and manipulate the Linux console." |
4 | PR = "r1" | 4 | PR = "r2" |
5 | 5 | ||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \ | 6 | SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \ |
7 | file://codepage.patch;patch=1 \ | 7 | file://codepage.patch;patch=1 \ |
8 | file://configure.patch;patch=1 \ | 8 | file://configure.patch;patch=1 \ |
9 | file://compile.patch;patch=1 \ | 9 | file://compile.patch;patch=1 \ |
10 | file://kbdrate.patch;patch=1 \ | ||
10 | file://config/*.m4" | 11 | file://config/*.m4" |
11 | 12 | ||
12 | export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \ | 13 | export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \ |
@@ -43,4 +44,4 @@ pkg_prerm_${PN} () { | |||
43 | update-alternatives --remove deallocvt deallocvt.${PN} | 44 | update-alternatives --remove deallocvt deallocvt.${PN} |
44 | update-alternatives --remove openvt openvt.${PN} | 45 | update-alternatives --remove openvt openvt.${PN} |
45 | } | 46 | } |
46 | 47 | ||