summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.50.2.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-01-23 16:05:48 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-26 13:09:10 +0000
commitcda5a1664d18efebef9b01ddc37b0a397f0ceb55 (patch)
tree72f2c50ce3dc0f765fdc4c0bef5f5cef1952a52f /meta/recipes-support/vte/vte_0.50.2.bb
parent71c405068ca5bcba72b2aaa1b6f40360fada141e (diff)
downloadpoky-cda5a1664d18efebef9b01ddc37b0a397f0ceb55.tar.gz
vte: upgrade to version 0.50.2
0.50.1 -> 0.50.2 (From OE-Core rev: 9b1e000dccd16e2210d7c1bef72652d4e187155f) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vte/vte_0.50.2.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.50.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.50.2.bb b/meta/recipes-support/vte/vte_0.50.2.bb
new file mode 100644
index 0000000000..8b9ee33eca
--- /dev/null
+++ b/meta/recipes-support/vte/vte_0.50.2.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Virtual terminal emulator GTK+ widget library"
2BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
3LICENSE = "LGPLv2.1+"
4DEPENDS = "glib-2.0 gtk+3 libpcre2 intltool-native libxml2-native gperf-native"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8inherit gnomebase gtk-doc distro_features_check upstream-version-is-even gobject-introspection
9
10# vapigen.m4 is required when vala is not present (but the one from vala should be used normally)
11SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch \
12 ${@bb.utils.contains('PACKAGECONFIG', 'vala', '', 'file://0001-Add-m4-vapigen.m4.patch', d) } \
13 "
14SRC_URI[archive.md5sum] = "1912cfd1d9cdd30cebeb908507acadc5"
15SRC_URI[archive.sha256sum] = "79dd316bfaff48f2fb74d066baae0d830e1f44436796fe410a57297e5c5f09cf"
16
17ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
18
19# Instead of "inherit vala" we do the relevant settings here so we can
20# set DEPENDS based on PACKAGECONFIG.
21
22# Our patched version of Vala looks in STAGING_DATADIR for .vapi files
23export STAGING_DATADIR
24# Upstream Vala >= 0.11 looks in XDG_DATA_DIRS for .vapi files
25export XDG_DATA_DIRS = "${STAGING_DATADIR}"
26
27# Help g-ir-scanner find the .so for linking
28do_compile_prepend() {
29 export GIR_EXTRA_LIBS_PATH="${B}/src/.libs"
30}
31
32# Package additional files
33FILES_${PN}-dev += "${datadir}/vala/vapi/*"
34
35PACKAGECONFIG ??= "gnutls"
36PACKAGECONFIG[vala] = "--enable-vala,--disable-vala,vala-native vala"
37PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
38
39CFLAGS += "-D_GNU_SOURCE"
40
41EXTRA_OECONF = "--disable-test-application"
42
43# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
44# Use libtool-cross (which has a hack to prevent that) instead.
45EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
46
47PACKAGES =+ "libvte"
48FILES_libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*"