summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.48.3.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-06-01 13:36:46 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-03 23:46:07 +0100
commit7e554c7dec6b7f9f63e61ebf5f945e3a8f4e14eb (patch)
tree6c5e72dbe6af153ab7a6a08e0a7703b6c7c6311d /meta/recipes-support/vte/vte_0.48.3.bb
parent25bd6c19ce7031d62b973d306a23f5c55bc3ad5d (diff)
downloadpoky-7e554c7dec6b7f9f63e61ebf5f945e3a8f4e14eb.tar.gz
vte: Upgrade 0.46.1 -> 0.48.3
Depend on gperf-native: The tarball used to include files generated with gperf and this is no longer the case. Use GIR_EXTRA_LIBS_PATH to fix introspection generation. (From OE-Core rev: 028c398d0977b8f65a78f6a9ba2df8cc07dcc3cd) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vte/vte_0.48.3.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.48.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.48.3.bb b/meta/recipes-support/vte/vte_0.48.3.bb
new file mode 100644
index 0000000000..47208417b4
--- /dev/null
+++ b/meta/recipes-support/vte/vte_0.48.3.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Virtual terminal emulator GTK+ widget library"
2BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
3LICENSE = "LGPLv2.1+"
4DEPENDS = "glib-2.0 gtk+3 libpcre2 intltool-native libxml2-native gperf-native"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8inherit gnomebase gtk-doc distro_features_check upstream-version-is-even gobject-introspection
9
10# vapigen.m4 is required when vala is not present (but the one from vala should be used normally)
11SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch \
12 ${@bb.utils.contains('PACKAGECONFIG', 'vala', '', 'file://0001-Add-m4-vapigen.m4.patch', d) } \
13 "
14SRC_URI[archive.md5sum] = "b300675ac5f269aa6eb48fe89a0d726d"
15SRC_URI[archive.sha256sum] = "a3a9fb182740b392a45cd3f46fa61a985f68bb6b1817b52daec22034c46158c3"
16
17ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
18
19# Instead of "inherit vala" we do the relevant settings here so we can
20# set DEPENDS based on PACKAGECONFIG.
21
22# Our patched version of Vala looks in STAGING_DATADIR for .vapi files
23export STAGING_DATADIR
24# Upstream Vala >= 0.11 looks in XDG_DATA_DIRS for .vapi files
25export XDG_DATA_DIRS = "${STAGING_DATADIR}"
26
27# Help g-ir-scanner find the .so for linking
28do_compile_prepend() {
29 export GIR_EXTRA_LIBS_PATH="${B}/src/.libs"
30}
31
32# Package additional files
33FILES_${PN}-dev += "${datadir}/vala/vapi/*"
34
35PACKAGECONFIG ??= "gnutls"
36PACKAGECONFIG[vala] = "--enable-vala,--disable-vala,vala-native vala"
37PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
38
39CFLAGS += "-D_GNU_SOURCE"
40
41EXTRA_OECONF = "--disable-test-application"
42
43# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
44# Use libtool-cross (which has a hack to prevent that) instead.
45EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
46
47PACKAGES =+ "libvte"
48FILES_libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*"