summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.44.2.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-10-11 13:58:02 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-11 22:16:11 +0100
commit9304fccd31cadf0c41720f832ad4fe43972a6f70 (patch)
tree16d7f93ed5c520857ab570f30ff23cf68df52c33 /meta/recipes-support/vte/vte_0.44.2.bb
parent4a7eb4b92f32c17abd1111246b1acb9ad3daa355 (diff)
downloadpoky-9304fccd31cadf0c41720f832ad4fe43972a6f70.tar.gz
vte: Build without vala by default
vala.bbclass DEPENDS on vala and vala-native: Drop the inherit so that these dependencies can be added on-demand based on vte PACKAGECONFIG. Add relevant items from vala class into the recipe. Add copy of vapigen.m4 so building without vala actually succeeds. Make building without vala the default PACKAGECONFIG. Fixes [YOCTO #10386]. (From OE-Core rev: 516b5c407e19029c09b870d460f64b7133f742b4) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/vte/vte_0.44.2.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.44.2.bb25
1 files changed, 20 insertions, 5 deletions
diff --git a/meta/recipes-support/vte/vte_0.44.2.bb b/meta/recipes-support/vte/vte_0.44.2.bb
index a1204a3c3b..a0b671e05b 100644
--- a/meta/recipes-support/vte/vte_0.44.2.bb
+++ b/meta/recipes-support/vte/vte_0.44.2.bb
@@ -5,24 +5,39 @@ DEPENDS = "glib-2.0 gtk+3 intltool-native"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7 7
8inherit gnomebase gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection 8inherit gnomebase gtk-doc distro_features_check upstream-version-is-even gobject-introspection
9 9
10SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch" 10# vapigen.m4 is required when vala is not present (but the one from vala should be used normally)
11SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch \
12 ${@bb.utils.contains('PACKAGECONFIG', 'vala', '', 'file://0001-Add-m4-vapigen.m4.patch', d) } \
13 "
11SRC_URI[archive.md5sum] = "eca8f8a9d9f9bb8e9d592d0acfeec015" 14SRC_URI[archive.md5sum] = "eca8f8a9d9f9bb8e9d592d0acfeec015"
12SRC_URI[archive.sha256sum] = "a1ea594814bb136a3a9a6c7656b46240571f6a198825c1111007fe99194b0949" 15SRC_URI[archive.sha256sum] = "a1ea594814bb136a3a9a6c7656b46240571f6a198825c1111007fe99194b0949"
13 16
14ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" 17ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
15 18
19# Instead of "inherit vala" we do the relevant settings here so we can
20# set DEPENDS based on PACKAGECONFIG.
21
22# Our patched version of Vala looks in STAGING_DATADIR for .vapi files
23export STAGING_DATADIR
24# Upstream Vala >= 0.11 looks in XDG_DATA_DIRS for .vapi files
25export XDG_DATA_DIRS = "${STAGING_DATADIR}"
26
27# Package additional files
28FILES_${PN}-dev += "${datadir}/vala/vapi/*"
29
30PACKAGECONFIG ??= ""
31PACKAGECONFIG[vala] = "--enable-vala,--disable-vala,vala-native vala"
16PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls" 32PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
17 33
18CFLAGS += "-D_GNU_SOURCE" 34CFLAGS += "-D_GNU_SOURCE"
19 35
20# Enable vala only if gobject-introspection is enabled 36EXTRA_OECONF = "--disable-test-application"
21EXTRA_OECONF = "--enable-vala=auto --disable-test-application"
22 37
23# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds. 38# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
24# Use libtool-cross (which has a hack to prevent that) instead. 39# Use libtool-cross (which has a hack to prevent that) instead.
25EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" 40EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
26 41
27PACKAGES =+ "libvte" 42PACKAGES =+ "libvte"
28FILES_libvte = "${libdir}/*.so.*" 43FILES_libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*"