summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/rng-tools/rng-tools_6.9.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-01-03 05:01:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-03 22:35:48 +0000
commitcf8918a9597d0d253dd29dd45449595e31f7f63b (patch)
treeec7177cc599ce08980fe841bbe81967269cb215b /meta/recipes-support/rng-tools/rng-tools_6.9.bb
parent70a4fe6531f31b60e9538577f016bd223189322d (diff)
downloadpoky-cf8918a9597d0d253dd29dd45449595e31f7f63b.tar.gz
rng-tools: upgrade 6.8 -> 6.9
(From OE-Core rev: ff5da959ad0816eaa6be8e6938b14b3d54cb80c4) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/rng-tools/rng-tools_6.9.bb')
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_6.9.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-support/rng-tools/rng-tools_6.9.bb b/meta/recipes-support/rng-tools/rng-tools_6.9.bb
new file mode 100644
index 0000000000..913342c315
--- /dev/null
+++ b/meta/recipes-support/rng-tools/rng-tools_6.9.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Random number generator daemon"
2DESCRIPTION = "Check and feed random data from hardware device to kernel"
3AUTHOR = "Philipp Rumpf, Jeff Garzik <jgarzik@pobox.com>, \
4 Henrique de Moraes Holschuh <hmh@debian.org>"
5HOMEPAGE = "https://github.com/nhorman/rng-tools"
6BUGTRACKER = "https://github.com/nhorman/rng-tools/issues"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9DEPENDS = "sysfsutils"
10
11SRC_URI = "\
12 git://github.com/nhorman/rng-tools.git \
13 file://init \
14 file://default \
15 file://rngd.service \
16"
17SRCREV = "4a865797a69dd38c64a86aa32884ecc9ba7b4d08"
18
19S = "${WORKDIR}/git"
20
21inherit autotools update-rc.d systemd pkgconfig
22
23PACKAGECONFIG ??= "libgcrypt libjitterentropy"
24PACKAGECONFIG_libc-musl = "libargp libjitterentropy"
25
26PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
27PACKAGECONFIG[libgcrypt] = "--with-libgcrypt,--without-libgcrypt,libgcrypt,"
28PACKAGECONFIG[libjitterentropy] = "--enable-jitterentropy,--disable-jitterentropy,libjitterentropy"
29PACKAGECONFIG[libp11] = "--with-pkcs11,--without-pkcs11,libp11 openssl"
30PACKAGECONFIG[nistbeacon] = "--with-nistbeacon,--without-nistbeacon,curl libxml2 openssl"
31
32INITSCRIPT_NAME = "rng-tools"
33INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30 0 6 1 ."
34
35SYSTEMD_SERVICE_${PN} = "rngd.service"
36
37# Refer autogen.sh in rng-tools
38do_configure_prepend() {
39 cp ${S}/README.md ${S}/README
40}
41
42do_install_append() {
43 install -Dm 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/rng-tools
44 install -Dm 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rng-tools
45 install -Dm 0644 ${WORKDIR}/rngd.service \
46 ${D}${systemd_system_unitdir}/rngd.service
47 sed -i \
48 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
49 -e 's,@SBINDIR@,${sbindir},g' \
50 ${D}${sysconfdir}/init.d/rng-tools \
51 ${D}${systemd_system_unitdir}/rngd.service
52}