summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pth/pth_2.0.7.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2012-12-03 18:22:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:31:12 +0000
commit1600f72fa8eec82c43786802042ac4c92335cef0 (patch)
treefa44baf9e0afd3d70eede030a3616402ee67a30f /meta/recipes-support/pth/pth_2.0.7.bb
parentbd368cf0e6478edd98cbb7a29f00195a0b789bf3 (diff)
downloadpoky-1600f72fa8eec82c43786802042ac4c92335cef0.tar.gz
pth: add pkgconfig support
Add pkgconfig support to pth. [YOCTO #2453] (From OE-Core rev: c5f14ef7797394bcee1b0e295cc2dac4b62e55e2) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/pth/pth_2.0.7.bb')
-rw-r--r--meta/recipes-support/pth/pth_2.0.7.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-support/pth/pth_2.0.7.bb b/meta/recipes-support/pth/pth_2.0.7.bb
index 83a03b334f..fc9ed16aca 100644
--- a/meta/recipes-support/pth/pth_2.0.7.bb
+++ b/meta/recipes-support/pth/pth_2.0.7.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/pth/"
3SECTION = "libs" 3SECTION = "libs"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;beginline=12;endline=15;md5=a48af114a80c222cafd37f24370a77b1" 5LIC_FILES_CHKSUM = "file://COPYING;beginline=12;endline=15;md5=a48af114a80c222cafd37f24370a77b1"
6PR = "r2" 6PR = "r3"
7 7
8python __anonymous () { 8python __anonymous () {
9 import re 9 import re
@@ -13,16 +13,17 @@ python __anonymous () {
13} 13}
14 14
15SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \ 15SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
16 " 16 file://pth-add-pkgconfig-support.patch"
17 17
18SRC_URI[md5sum] = "9cb4a25331a4c4db866a31cbe507c793" 18SRC_URI[md5sum] = "9cb4a25331a4c4db866a31cbe507c793"
19SRC_URI[sha256sum] = "72353660c5a2caafd601b20e12e75d865fd88f6cf1a088b306a3963f0bc77232" 19SRC_URI[sha256sum] = "72353660c5a2caafd601b20e12e75d865fd88f6cf1a088b306a3963f0bc77232"
20 20
21PARALLEL_MAKE="" 21PARALLEL_MAKE=""
22 22
23inherit autotools binconfig 23inherit autotools binconfig pkgconfig
24 24
25do_configure() { 25do_configure() {
26 gnu-configize 26 gnu-configize
27 autoconf
27 oe_runconf 28 oe_runconf
28} 29}