summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
diff options
context:
space:
mode:
authorAnibal Limon <anibal.limon@linaro.org>2021-09-27 13:58:46 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-29 21:47:45 +0100
commit35b8966e61131b9ee951ffadcaa9a4b25f25f0ef (patch)
treeea993b7bbe60858baedc6fb9f3869ca67fab0adb /meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
parent3af6389ece4492b1fd6ecacc6f3e670f1a2a6dfe (diff)
downloadpoky-35b8966e61131b9ee951ffadcaa9a4b25f25f0ef.tar.gz
recipes-support/ptest-runner: Bump to v2.4.2
Changes, bcb8280 utils.c: add system data collection when a test gets stuck. c29240c utils.c: handle test timeouts directly with poll() d6f509f tests/utils.c: fix a memory corruption in find_word c10e747 main: Do not return number of failed tests when calling ptest-runner 4958988 utils.c: fix memory leak in run_ptests() fcfa6a1 clang: clean-ups to avoid -Weverything warnings. 215e52d Makefile: allow using CC env var to pick compiler fdd233d mem: Simplify memory management e5e218a mem: Fix memleak for ptest_opts 0dc42eb git: Extend the gitignore (From OE-Core rev: 710fa373375beb977af704e17a925ed41c9a858d) Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
new file mode 100644
index 0000000000..1d3c24a177
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
@@ -0,0 +1,30 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "bcb82804daa8f725b6add259dcef2067e61a75aa"
11PV .= "+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
14"
15
16S = "${WORKDIR}/git"
17
18FILES:${PN} = "${bindir}/ptest-runner"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
28}
29
30RDEPENDS:${PN}:append:libc-glibc = " libgcc"