summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
diff options
context:
space:
mode:
authorAnibal Limon <anibal.limon@linaro.org>2020-04-28 16:18:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-22 13:27:37 +0000
commit4a58a7660cecaa5cd631fb785590289fd04f9557 (patch)
tree98d45f8563a795b3c4db1ba53d527b0a3c9ddaef /meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
parenta0a4838076388720eef88ad98776bba6a3e12566 (diff)
downloadpoky-4a58a7660cecaa5cd631fb785590289fd04f9557.tar.gz
ptest-runner: Bump to 2.4.0
Add support for un ptests in multiple directories, useful in multilib builds. Changes, 1e9a845 Add support to specify multiple folder for ptest-runner 287ba30 Makefile: Fix TEST_LDFLAGS gcc cmdline position [YOCTO #12604] (From OE-Core rev: bd7de7dd0992e0d7a6cc322a54cf9e69b052acca) Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1203ee86e3cf4d73f6ba513452717f1c4f78c501) Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
new file mode 100644
index 0000000000..9e62c486ac
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "1e9a84585909b970cc8850d3ea02a7215dcfa5a3"
11PV = "2.4.0+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
14"
15
16S = "${WORKDIR}/git"
17
18FILES_${PN} = "${bindir}/ptest-runner"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
28}