summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.3.2.bb
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2019-08-01 16:36:48 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-03 23:56:01 +0100
commit640c59a70658708863ff15e3b9de5a4b4bfab2e4 (patch)
treec9e59d45867b4c482adbc58d9dcff880da861a37 /meta/recipes-support/ptest-runner/ptest-runner_2.3.2.bb
parentf2a951f479bbb68ae7702785c7916325fc97f1c2 (diff)
downloadpoky-640c59a70658708863ff15e3b9de5a4b4bfab2e4.tar.gz
ptest-runner: update from 2.3.1 to 2.3.2
All local patches are now upstream so they have been dropped. Other upstream commits make ptest-runner build using: clang -Weverything $ git log --oneline b73bd54..7015e91 7015e91 (HEAD -> oe-core-master, tag: v2.3.2, origin/master, origin/HEAD, master) Fix additional warnings when using clang dd1daa8 tests: fix clang warnings. 15fd131 main code: fix clang warnings 59381a6 utils: ensure child can be session leader 5fe2c0a utils: Ensure pipes are read after exit 79a9c27 use process groups when spawning b73bd54 utils: Ensure stdout/stderr are flushed (From OE-Core rev: 9a80a352a9d0c4ea09de7bb370267672c32771f2) Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.3.2.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.3.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.3.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.3.2.bb
new file mode 100644
index 0000000000..187f22df04
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.3.2.bb
@@ -0,0 +1,28 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "7015e9199ce748c0717addeebe7a8c47448bab03"
11PV = "2.3.2+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
14"
15
16S = "${WORKDIR}/git"
17
18FILES_${PN} = "${bindir}/ptest-runner"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
28}