summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linaro.org>2019-01-30 11:14:32 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-31 23:23:26 +0000
commitf1fa6e1bb9e8312188d55cd4bc361bfc1ad78228 (patch)
tree24722d5e6745fbb50e5ac6ceab2d54508f4ada9b /meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
parent7b17274c30c6e95d87bc6a08f1311f0200c3f609 (diff)
downloadpoky-f1fa6e1bb9e8312188d55cd4bc361bfc1ad78228.tar.gz
ptest-runner: Upgrade to 2.3.1
Changeset, 05b112b utils.c: Print DURATION after ERROR acb5efb utils.c: run_child redirect stderr to stdout e1062f7 ptest-runner: make DEFAULT_DIRECTORY be able to be defined when compiling (From OE-Core rev: f0b3fa049e0395ffc56237404f79975852ce4e4e) Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
new file mode 100644
index 0000000000..4b7992bf2f
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "05b112bda7ac2adba8e9b0f088d6e5843b148a38"
11PV = "2.3.1+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
14S = "${WORKDIR}/git"
15
16FILES_${PN} = "${bindir}/ptest-runner"
17
18EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
19
20do_compile () {
21 oe_runmake
22}
23
24do_install () {
25 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
26}