summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2012-12-19 17:18:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-26 11:34:04 +0000
commitdaad0d8dda05546385186086e57cf18388a3b90b (patch)
treec3836d0bdbba773efdfd98e65e7835df239fdecf /meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
parent1d2c6833ae802553d6df3dbb249336c44cef5df5 (diff)
downloadpoky-daad0d8dda05546385186086e57cf18388a3b90b.tar.gz
New package: ptest-runner
This package contains a simple shell script which searches for all installed ptests on the rootfs and runs each test in sequence. (From OE-Core rev: da25002a0968c12f16719f9fed21c76b9321aeb5) Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_1.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
new file mode 100644
index 0000000000..6b866d4de2
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
@@ -0,0 +1,17 @@
1SRC_URI += "file://ptest-runner"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9do_install () {
10 mkdir -p ${D}${bindir}
11 install -m 0755 ${WORKDIR}/ptest-runner ${D}${bindir}
12}
13
14do_patch[noexec] = "1"
15do_configure[noexec] = "1"
16do_compile[noexec] = "1"
17do_build[noexec] = "1"