summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pinentry/pinentry_1.1.0.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2017-12-17 08:34:31 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-02 17:24:38 +0000
commitf2245b51bd99b73e166fa027fd5385944c5e6157 (patch)
tree55b64fdfc93232e60d9284d13ff00987026cd4e8 /meta/recipes-support/pinentry/pinentry_1.1.0.bb
parenta509a5d9f7753f5cb49264d35544a9254715d5ee (diff)
downloadpoky-f2245b51bd99b73e166fa027fd5385944c5e6157.tar.gz
pinentry: update to 1.1.0
(From OE-Core rev: c147eb60bdcd5de9cf51414bef7cff7ee5bdc8ba) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/pinentry/pinentry_1.1.0.bb')
-rw-r--r--meta/recipes-support/pinentry/pinentry_1.1.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/pinentry/pinentry_1.1.0.bb b/meta/recipes-support/pinentry/pinentry_1.1.0.bb
new file mode 100644
index 0000000000..3b77709ffb
--- /dev/null
+++ b/meta/recipes-support/pinentry/pinentry_1.1.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11inherit autotools pkgconfig
12
13DEPENDS = "gettext-native libassuan libgpg-error"
14
15UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
16SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
17 file://libassuan_pkgconf.patch \
18 file://gpg-error_pkconf.patch \
19"
20
21SRC_URI[md5sum] = "3829315cb0a1e9cedc05ffe6def7a2c6"
22SRC_URI[sha256sum] = "68076686fa724a290ea49cdf0d1c0c1500907d1b759a3bcbfbec0293e8f56570"
23
24EXTRA_OECONF = "--disable-rpath --disable-dependency-tracking \
25 --disable-pinentry-qt5 \
26"
27
28PACKAGECONFIG ??= "ncurses libcap"
29
30PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
31PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
32PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qt4-x11"
33PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
34
35#To use libsecret, add meta-gnome
36PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"