summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle/nettle_3.5.1.bb
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-08-06 13:05:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 16:08:15 +0100
commitc1ac9c679066402375909ebb7a96962f4596c035 (patch)
treefec2fe8148dd9c470f3cce1813b9588d3a4a5d64 /meta/recipes-support/nettle/nettle_3.5.1.bb
parent060e7db0c4988e762fe874070af6c8ad8562822d (diff)
downloadpoky-c1ac9c679066402375909ebb7a96962f4596c035.tar.gz
nettle:upgrade 3.4.1 -> 3.5.1
nettle-stdint.h was no longer use. Remove nettle/nettle-stdint.h in do_install_append() of .bb file. Changelog in ChangeLog file as follows: 2019-01-06 Niels Möller <nisse@lysator.liu.se> * nettle-types.h: Don't use nettle-stdint.h, include <stdint.h> directly. * nettle-write.h: Likewise. * configure.ac: Delete use of AX_CREATE_STDINT_H. * aclocal.m4 (AX_CREATE_STDINT_H): Delete. * Makefile.in (INSTALL_HEADERS, distclean-here): Delete mention of nettle-stdint.h. (From OE-Core rev: a44e40675e151eb079d7d9e87e734ca5cfb923b5) Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/nettle/nettle_3.5.1.bb')
-rw-r--r--meta/recipes-support/nettle/nettle_3.5.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-support/nettle/nettle_3.5.1.bb b/meta/recipes-support/nettle/nettle_3.5.1.bb
new file mode 100644
index 0000000000..d92db0ef95
--- /dev/null
+++ b/meta/recipes-support/nettle/nettle_3.5.1.bb
@@ -0,0 +1,55 @@
1SUMMARY = "A low level cryptographic library"
2HOMEPAGE = "http://www.lysator.liu.se/~nisse/nettle/"
3SECTION = "libs"
4LICENSE = "LGPLv3+ | GPLv2+"
5
6LIC_FILES_CHKSUM = "file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
7 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://serpent-decrypt.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e \
9 file://serpent-set-key.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e"
10
11DEPENDS += "gmp"
12
13SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
14 file://Add-target-to-only-build-tests-not-run-them.patch \
15 file://run-ptest \
16 file://check-header-files-of-openssl-only-if-enable_.patch \
17 "
18
19SRC_URI_append_class-target = "\
20 file://dlopen-test.patch \
21 "
22
23SRC_URI[md5sum] = "0e5707b418c3826768d41130fbe4ee86"
24SRC_URI[sha256sum] = "75cca1998761b02e16f2db56da52992aef622bf55a3b45ec538bc2eedadc9419"
25
26UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
27
28inherit autotools ptest multilib_header
29
30EXTRA_AUTORECONF += "--exclude=aclocal"
31
32EXTRA_OECONF = "--disable-openssl"
33CFLAGS_append = " -std=gnu99"
34
35do_compile_ptest() {
36 oe_runmake buildtest
37}
38
39do_install_append() {
40 oe_multilib_header nettle/version.h
41}
42
43do_install_ptest() {
44 install -d ${D}${PTEST_PATH}/testsuite/
45 install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/
46 install ${S}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
47 # tools can be found in PATH, not in ../tools/
48 sed -i -e 's|../tools/||' ${D}${PTEST_PATH}/testsuite/*-test
49 install ${B}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
50}
51
52RDEPENDS_${PN}-ptest += "${PN}-dev"
53INSANE_SKIP_${PN}-ptest += "dev-deps"
54
55BBCLASSEXTEND = "native nativesdk"