summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzop/lzop_1.04.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-18 17:49:05 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-19 16:14:57 +0000
commita25637e7e6be1d4e40db8085b654a5beeed7fbc1 (patch)
treec0c8a6c1f3109978aa3730d187dd0cd92326bd59 /meta/recipes-support/lzop/lzop_1.04.bb
parent290e68af72086647fa984a797354dab7afc996d6 (diff)
downloadpoky-a25637e7e6be1d4e40db8085b654a5beeed7fbc1.tar.gz
lzop: upgrade 1.03 -> 1.04
License checksum changed due to updated copyright year and cleanup. 3 patches for miniacc.h were incorporated upstream. Build-tested on qemu targets, including x32. (From OE-Core rev: e243edc0456858d26b21a5b643ea9c0ae143fa4b) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lzop/lzop_1.04.bb')
-rw-r--r--meta/recipes-support/lzop/lzop_1.04.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/lzop/lzop_1.04.bb b/meta/recipes-support/lzop/lzop_1.04.bb
new file mode 100644
index 0000000000..b50c230437
--- /dev/null
+++ b/meta/recipes-support/lzop/lzop_1.04.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Real-time file compressor"
2DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\
3It is based on the LZO data compression library and its main advantages over \n\
4gzip are much higher compression and decompression speed at the cost of some \n\
5compression ratio. The lzop compression utility was designed with the goals \n\
6of reliability, speed, portability and with reasonable drop-in compatibility \n\
7to gzip."
8DEPENDS += "lzo"
9
10LICENSE = "GPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://src/lzop.c;beginline=5;endline=21;md5=23d767de7754eb24b9e900b025cf7fc8"
13
14SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \
15 file://acinclude.m4 \
16 "
17SRC_URI[md5sum] = "271eb10fde77a0a96b9cbf745e719ddf"
18SRC_URI[sha256sum] = "7e72b62a8a60aff5200a047eea0773a8fb205caf7acbe1774d95147f305a2f41"
19
20inherit autotools
21
22do_configure_prepend () {
23 install -Dm 0644 ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
24}
25
26BBCLASSEXTEND = "native nativesdk"