summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzop/lzop_1.03.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2011-12-08 10:35:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-12 21:50:16 +0000
commit896f2abab6ef1df3102dbd551f7a67dc2da20bee (patch)
tree8d3a7c99226bdf7894aa06bb8a1810baca80c6ff /meta/recipes-support/lzop/lzop_1.03.bb
parent7ec44994e95b62ee00c4dbd4765adbce224b147f (diff)
downloadpoky-896f2abab6ef1df3102dbd551f7a67dc2da20bee.tar.gz
lzop-1.03: add recipe
This is needed by some kernels when CONFIG_KERNEL_LZO=y (specifically, given the current defconfig, this affects linux-omap4 2.6 in the meta-ti layer). (From OE-Core rev: 9b3991cf6a8bb751e45c1abfc48d65d952c048b8) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lzop/lzop_1.03.bb')
-rw-r--r--meta/recipes-support/lzop/lzop_1.03.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/lzop/lzop_1.03.bb b/meta/recipes-support/lzop/lzop_1.03.bb
new file mode 100644
index 0000000000..63a2a62c83
--- /dev/null
+++ b/meta/recipes-support/lzop/lzop_1.03.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Real-time file compressor"
2DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\
3It is based on the LZO data compression library and its main advantages over \n\
4gzip are much higher compression and decompression speed at the cost of some \n\
5compression ratio. The lzop compression utility was designed with the goals \n\
6of reliability, speed, portability and with reasonable drop-in compatibility \n\
7to gzip."
8DEPENDS += "lzo"
9PR = "r0"
10
11LICENSE = "GPLv2+"
12LIC_FILES_CHKSUM = "file://COPYING;md5=dfeaf3dc4beef4f5a7bdbc35b197f39e \
13 file://src/lzop.c;beginline=5;endline=21;md5=6797bd3ed0a1a49327b7ebf9366ebd86"
14
15SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \
16 file://acinclude.m4"
17SRC_URI[md5sum] = "006c5e27fb78cdd14a628fdfa5aa1905"
18SRC_URI[sha256sum] = "c1425b8c77d49f5a679d5a126c90ea6ad99585a55e335a613cae59e909dbb2c9"
19
20inherit autotools
21
22do_configure () {
23 ln -sf ../acinclude.m4
24 autotools_do_configure
25}
26
27BBCLASSEXTEND += "native nativesdk"